locked
Live Mesh Remote Desktop not available RRS feed

  • Question

  • Hi,
     
    I cant seem to enable Live Mesh Remote Desktop, I have Mesh installed on my PC and Laptop both running Vista Business SP1, I have gone throught the help and i didn't get an option to enable it during the install and i can find the " System notifications icon System notifications" to enable either.  I only installed it today and i am running the latest version. 

    Thanks

    David
    Friday, October 31, 2008 11:10 AM

Answers

  • Hi David,

    There are a couple of things you can try:

    First, open an elevated command prompt window (right-click and select "Run as Administrator), then type "regsvr32 firewallapi.dll" (without quotes) and hit enter.

     

    The second option here might not apply to you, if this is the first time you installed Live Mesh, but: If an earlier version of Live Mesh was installed it may have left the “%program files%\Live Mesh” directory behind without cleaning up during uninstall.  You need to delete that directory.

     

    Once these are fixed, right-click Live Mesh and check for updates.  That should get everything running correctly.

    Please let me know whether this helps or not.

    Thanks,

    Ben.
    Monday, November 3, 2008 6:24 PM

All replies

  • Hi David,

    Would you mind clarifying what you mean when you say that you can't enable Live Mesh Remote Desktop?  Are you trying to open a remote session and getting an error message?  Or are your remote devices not showing up as available for a remote connection?

    Thanks,

    Ben.
    Friday, October 31, 2008 6:44 PM
  • My remote devices are showing up as not available for remote connection
    Monday, November 3, 2008 9:44 AM
  • Hi David,

    There are a couple of things you can try:

    First, open an elevated command prompt window (right-click and select "Run as Administrator), then type "regsvr32 firewallapi.dll" (without quotes) and hit enter.

     

    The second option here might not apply to you, if this is the first time you installed Live Mesh, but: If an earlier version of Live Mesh was installed it may have left the “%program files%\Live Mesh” directory behind without cleaning up during uninstall.  You need to delete that directory.

     

    Once these are fixed, right-click Live Mesh and check for updates.  That should get everything running correctly.

    Please let me know whether this helps or not.

    Thanks,

    Ben.
    Monday, November 3, 2008 6:24 PM
  • Ben,
    Are you saying that if we have a program files\Live Mesh directory, we should delete it?  It looks like there's files in there that are "current" (modified 10/30).  OR are you saying if we uninstall Mesh and it leaves that directory, to delete it?
    Thanks.
    Brian
    • Edited by triggerx Tuesday, November 4, 2008 12:08 AM
    Tuesday, November 4, 2008 12:07 AM
  • I Have tried everything you suggested but this made no differance, I have un-installed the software and and re-installed it and it now seems to work, but when i connect i just get a black screen?
    Tuesday, November 4, 2008 10:19 AM
  • triggerx said:

    Ben,
    Are you saying that if we have a program files\Live Mesh directory, we should delete it?  It looks like there's files in there that are "current" (modified 10/30).  OR are you saying if we uninstall Mesh and it leaves that directory, to delete it?
    Thanks.
    Brian



    Hi Brian,

    I'm sorry - you're right, that was not clear.  I meant that if you uninstall, you should delete that directory before reinstalling.

    I apologize for the confusion.

    Ben.
    Tuesday, November 4, 2008 6:23 PM
  • David Guillaume said:

    I Have tried everything you suggested but this made no differance, I have un-installed the software and and re-installed it and it now seems to work, but when i connect i just get a black screen?



    David,

    Are you logged into an administrator account on the computer that you're connecting from?  Sometimes the "black screen" issue indicates that you're connecting in non-admin mode (i.e., from an account that is not an administrator on the current machine).  If that is the case, try logging into an administrator account, installing Live Mesh, and connecting.  If you're seeing the black screen while logged into an administrator account, please collect your Live Mesh logs (instructions are in an Announcement at the top of the forums) and send them to lmprev@microsoft.com, with a detailed description of the problem and anything you've tried to resolve it.

    Thanks,

    Ben.
    Tuesday, November 4, 2008 6:27 PM
  • Ben,

    (1)  Can you clarify what "regsvr32 firewallapi.dll" is going to do?
    (2)  Since deleting the folder is something to be done after uninstalling, but BEFORE reinstalling Live Mesh - is it your recommendation that we uninstall, delete the folder, and reinstall again?

    (3)  Is there any connection to, or would this fix, the "401 Not authorized to access specified resource" problem?  Both of these problems showed up at the same time (that of the recent update) and on only 1 of the 2 computers in my mesh.

    • Edited by DarrenUtd Friday, November 7, 2008 5:07 PM
    Friday, November 7, 2008 5:05 PM
  • DarrenUtd said:

    Ben,

    (1)  Can you clarify what "regsvr32 firewallapi.dll" is going to do?
    (2)  Since deleting the folder is something to be done after uninstalling, but BEFORE reinstalling Live Mesh - is it your recommendation that we uninstall, delete the folder, and reinstall again?

    (3)  Is there any connection to, or would this fix, the "401 Not authorized to access specified resource" problem?  Both of these problems showed up at the same time (that of the recent update) and on only 1 of the 2 computers in my mesh.



    Hi,

    (1) It will register a firewall component that Live Mesh is looking for but cannot find.
    (2) If necessary, yes.  That is, if you do uninstall, please make sure the directory is cleaned before reinstalling (though uninstalling may not always be necessary).
    (3) I'm not sure.  We're looking into a number of 401 errors, with potentially different root causes.  If this helps, let us know!

    Thanks,

    Ben.
    Monday, November 10, 2008 10:30 PM
  • After numerous attempts to uninstall/reinstall/reboot with it not fixing this issue I tried deleting the "ProgramFiles\Live Mesh" folder and then a "check for updates" step. It immediately fixed the problem.

    Thanks for the help. :)
    Thursday, June 11, 2009 11:29 AM
  • I'm having this problem also, and I tried these steps, but it still shows as "Live Mesh Remote Desktop is not available"
    did the uninstall> remove folder>resinstall. Even tried with a reboot inbetween. nothing seems to work.
    Monday, June 29, 2009 6:05 PM
  • After trying everything previously posted in this article, I was able to get Remote Desktop working by doing a repair install of Windows Live Essentials 2011.  Once that completed I was able to enable remote desktop and testing it successfully. 
    Thursday, March 10, 2011 3:35 AM