locked
Backup problems RRS feed

  • Question

  • My desktop keeps getting backup failures and the detail tab gives the cryptic message: "The computer failed to take a snapshot of the volume for backup"  I've reinstalled WHS twice trying to fix this.  It happens on both the automatic backup and manual backup.

    Also, when I tried to backup my laptop (twice) I get the blue screen of death, even when starting it manually.  The blue screen reads "A problem has been detected and windows has shut down to prevent damage to your computer.  BAD_POOL_HEADER.  If this is the first time you've seen this Stop Error Screen, follow these steps:
    - Reinstall software.....
    - Disable hardware.....

    Tech Info:  ***STOP: 0x00000019 (0x00000020, 0xE1048370, 0x0C040801).

    None of the media scanners work either...  I'd appreciate any help you can provide.

    bill
    Monday, July 13, 2009 1:19 PM

Answers

  • Could you please run chkdsk /r on all the partitions on the client with the problem? You may be notified that one or more partitions requires a reboot because the volume is in use; that's expected. If chkdsk detects and fixes any errors, those may have been interfering with the backup.
    I'm not on the WHS team, I just post a lot. :)
    Sunday, July 26, 2009 2:44 PM
    Moderator

All replies

  • Did you ever use Acronis or other imaging software on this system or any of the drives?

    If yes please check out the answer in this thread. If that doesn't fix it please run chkdsk /r from a command prompt on all partitions. If no errors found, or all errors corrected and the problem still isn't fixed pleas check out this thread.
    Monday, July 13, 2009 1:54 PM
    Moderator
  • Followed the instructions and deleted the hidden volumes.  Everything worked just as described until the final reboot.  At that point, I couldn't get past the WHS control panel.  When I try accessing anything on the server (clicking on the HP MediaSmart Server icon for example), the computer locks up.  At this point the WHS icon in the system tray is gray.  I can ping the server and see it, but thats as far as I can get.  I tried reinstalling the WHS software but it asks for my password, acts like it is "downloading software from the server" but stays at 0% until it fails.

    Now, not only can I not back anything up, but I can't even access the server...

    Any suggestions before I throw this thing out the window?...

    bill
    Wednesday, July 22, 2009 12:04 PM
  • If you can not even access the console it sounds more like a server side problem.

    If you have similar problems when trying to connect from another client the best solution is probably a server reinstall using the server recovery disk (run from a client, do NOT select factory reset but the other option). This should revive the server unless there's a major hardware problem. Server reinstall should preserve all data in shares and also client backups. You will need to create users again, connect clients and all other modifications (installation of Add-inns).

    Wednesday, July 22, 2009 2:47 PM
    Moderator
  • Going from bad to worse... Began the recovery at 10am. It quickly checked off "Configuring your hardware" and "Recovering your Data", then worked on the "Starting Windows Home Server" from about 10:10am until about 4pm, when it told me to make sure it was connected to the Internet. It was. It recommended beginning again. I did at 4:15. BTW: all during this process all 7 lights are pulsing blue (power, network, health, and 4 drives). During the recovery reboot it took over 20 minutes to get a solid blue health light, only then did the 4 drive lights come on. Then they all started pulsing one flash every 2 seconds - and it hasn't stopped yet. Don't know if thiis helps or hurts, but it is only two weeks old. It has the 750Gb that came w/it and three more brand new Seagate 1TB Green drives I added. I've spend most ot the past 2 weeks loading data onto it. bill
    Wednesday, July 22, 2009 8:28 PM
  • Hi Bill,

    I'm not really sure about the pulsing drive lights, however I think this means it's busy recovering the data. I do know that depending on the amount of data on the server recovery can take a (very) long time. The more data, the longer it takes, so please be patient and give it some time (at least 24h)
    Thursday, July 23, 2009 5:19 AM
    Moderator
  • Brubber,

        Well, the Restore failed twice after running for several hours and I decided to throw in the towel and start clean.  I wiped the connector and WHS from the client and went for a fresh install.  It looked like it was working and ran all night. This morning around 0700 it failed and could not connect to either the server or the Internet (the internet was up).  I checked the bandwidth utilization during the night and nothing was being passed.  Pinging wouldn't work, nor would accessing it via explorer.  My Cisco network software could see the server but was not able to provide any detailed info on it.  BTW:  It had defaulted back to the original name "hpserver".  The pulsing blue lights had stopped and were now a steady, very low intensity blue.  The health light occasionally blinked red, then went back to blue.

        I believe your initial guess about a problem server was correct.  It has only been on line for 162 hours so I suspect the burn-in caused some internal fault.

    I'll pull the drives this evening and see if I can salvage any of my data.  I've still got the shipping box & will return the server - meanwhile I've already ordered a new one which will be here Friday.  Once it comes in we'll see if the backup works...

        What are the odds that the client, server, internet, and software all fail a the same time...?  I figure close to zero.

    I appreciate all the time you spent trying to help me out with this.
    Thursday, July 23, 2009 6:52 PM
  • Fresh install (factory reset) shouldn't take hours to run. Sounds like some hardware failure, so sending it back is probably your best option

    One thing I would try if it were (my machine) is pull all data drives (leave only system drive), DISconnect from internet then run factory reset. I know some people advise against it, however seen multiple cases where updates during install cause problems, and especially on headless machine there's no way to see what's going on.

    I also have HPEX475 overhere, has been running almost permanently for more then a year now, and I have been doing pretty bad things to it, however only required server reinstall only once. Guess it's just bad luck. Shame, because it's a very nice system when all is working as designed

    For recovering data on new server or after factory reset please check-out this FAQ from Olaf Engelke
    Thursday, July 23, 2009 8:21 PM
    Moderator
  • Brubber,

      I followed Olaf's instructions and copied the data on the three 1TB drives onto another external drive.  The article is a little unclear on what comes next.

       I cannot reinstall the server, add the three drives back in, let the system format them, then copy the data directly to one of the DE/shared directories?  That means I have to trickle it back to the server over the Internet again?

      Is there no faster way?  It sure would be nice to be able to plug in a USB, Firewire or sSATA device containing the data and copy it directly onto the server's drives at high speed...  Is that possible?

        The new server will arrive today (I had it overnighted) so it looks like this weekend is booked.

    bill
    Friday, July 24, 2009 12:40 PM
  • Brubber,

          OK, here's the latest:  The new server arrived Friday and installed perfectly and I reloaded my data, scavenged off the old drives onto another 2Tb external.  As far as I can tell, nothing is lost.  I DID have to reconfigure all user accounts, preferences, etc on the server, but that was expected an took only a short time.

        I successfully backed up my laptop.  Yaaayyy!  But the automated backup of my client failed again - "failed to take a snapshot of the volume".  I again deleted the hidden storage volumes, rebooted twice as they reinstalled themselves, and retried to back up the client again manually.  Again, it failed (same reason).

        We've worked our way through this series of setbacks only to find ourselves back almost where we started (except now we can back up the laptop without getting the BSOD, a SIGNIFICANT improvement!).

        Can you think of anything else that might cause the client's backup failure?  If not, I'm prepared to give up and continue backing up the client on the other external drive (it is eSATA and probably faster anyway), but I was hoping the WHS would perform as its supposed to.

    bill
    Sunday, July 26, 2009 1:01 PM
  • Could you please run chkdsk /r on all the partitions on the client with the problem? You may be notified that one or more partitions requires a reboot because the volume is in use; that's expected. If chkdsk detects and fixes any errors, those may have been interfering with the backup.
    I'm not on the WHS team, I just post a lot. :)
    Sunday, July 26, 2009 2:44 PM
    Moderator
  • Ken,

        I ran chkdsk /r last night.  A window pops up saying:

                 "The type of file system is NTFS.
                   Cannot lock current drive.

                   Chkdsk cannot run because the volume is in use by another process.  Would you like to schedule this volume to be checked the next time the system restarts? (Y/N)"

         I selected yes and it worked well into the night.  This morning I tried to backup again and it failed.  I ran chkdsk /r again and got the same message as above.  How do we "unlock" the drive so the backup can run?

    bill
    Tuesday, July 28, 2009 9:50 AM
  • Did you restart your client so chkdsk could run on your C: partition?
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, July 28, 2009 2:55 PM
    Moderator
  • Yes, after chkdsk completed sometine during the night the client rebooted automatically.  This morning I again tried chkdsk, found the volume was "locked", and I rebooted again.  Still no joy.
    Tuesday, July 28, 2009 5:11 PM
  • The volume is "locked" because it's the system volume on the client, and Windows keeps some files open in a way that chkdsk can't deal with. 

    You can see the results of the chkdsk by looking at the application event log on that client and filtering on events from the source "winlogon".

    I'm not on the WHS team, I just post a lot. :)
    Tuesday, July 28, 2009 7:30 PM
    Moderator
  • Sorry for the delay responding but Ken's answer arrived after I deployed overseas on temporary duty.  The problem was not solved when I left home, nor has there been a single successful backup while I've been gone.  I'll pick it up again next week (about 20 Aug) and see if we can solve this thing.
    bill
    Monday, August 17, 2009 6:51 AM
  • Been working to get it running, and here's my final solution:

    I ultimately accepted the fact that the WHS backup function was not going to work and decided I could live with that. 

    I noticed that the media sharing function was not working.  After jacking around with that for a weekend I decided I could live without that too.  The media sweep function actually never worked anyway but I had copied my music to WHS manually.

    Everything was OK until about November, when WHS said there was a software update.  My auto update was on but it would not download.  When I manually tried to download the update I got the message that it had failed, and recommended I try again later.  I tried almost daily for over a month with no luck.  I even tried reinstalling connector, and finally the whole s/w package - no luck.  I decided I could live without the update.

    In early December the rightmost health light turned red but the WHS software said everything was healthy.  I covered the light with tape.

    On 26 December it stopped streaming video, a function that previously functioned previously.  I resorted to carrying my movies downstairs on an external HDD.

    In early January I could not log on to the server, either remotely or on my local workstation.  At this point the server was doing little more than eating up electricity and heating up my room, so I unplugged it, pulled out my three drives, and dropped it out of my second story window onto my driveway & feel pretty good about it.

    As a software engineer I have some pretty strong opinions about the HP MediaSmart Server and WHS.  The hardware is garbage and the software is worse.  I don't recommend you buy this hardware at any price.  It is poorly designed, unreliable, difficult to install, impossiblt to keep running, and glacially slow.  It may be an adequate backup system IF IT WORKS, but what do you do when it fails?  It requires a lot of TLC to keep working and configured.  Heaven help you if you have to change routers, modify a firewall or install software that conflicts with it - and a LOT of software conflicts with it.  You will spend days cruising forums looking for some obscure tweak to get it working again.  Don't even bother calling HP Support unless you really like long stretches of classical music.  Any hardware or software that needs a social forum as large as this one to answer questions and supplement users manuals needs a complete redesign.  There are too many other options out there to waste your valuable time on this..."hardware" (spit on the ground).

    Sorry to be brutal but when I pay good $$ for a product I expect it to work as advertised.  The HP MediaSmart Server does not.

    However, if you are a megageek with lots of free time, and are willing to trade your life to keep a server running, this unit is perfect for you.
    Friday, January 22, 2010 5:05 PM
  • Sorry to hear your bad experience - but I have also one a MediaSmart 470ex. And this acts, as it should - running smoothly in a long forgotten corner.
    One problem is, that hardware may fail and software cannot cover that. And the support staff at HP may have had a bad day as you tried (or only limited staff at the time you called).
    Best greetings from Germany
    Olaf
    Friday, January 22, 2010 7:00 PM
    Moderator
  • Amazing, I also threw my HP Mediasmart out of the second floor window.  I was totally disgusted with it.  Did not do what it was supposed to do, in fact I could not do anything with it , it did make a good'ish heater though [NO backup's, NO media collation or NO media convertion [due to inadequate processing power], No Supprt]. - even the HP forum is "Poor".  Also although EU legislation states that there should be a 2 year warranty -for some reason HP only offer 1 for there hardware.  Shows how much confidence they have in their product, to offer one a single year - nuff said I think. I will have to try and find out how they can only offer 1 year, when legally they are required to offer two [all bye-the-bye now, but it may help other people].  I'm going to reinstate my Netgear ReadyNAS - they are very good and the forum is excellent [I have found].
    Sunday, January 24, 2010 2:31 PM