locked
windows security login prompt on Outlook while using CRM 4 add-in RRS feed

  • Question

  • I am having an annoying issue while using Outlook's add-in for CRM 4.  I have seen many other posts abut this but cannot resolve by their suggestions.  What I have is CRM 4 on a 2008 server using SQL 2005.  If I install the Outlook add-in, while clicking on a  folder such as Leads or Activities as it really doesn't matter, I get this login prompt come up.  If I click cancel a few times, it goes away and thing run fine.  This also happened while on CRM 3 and Outlook 2003. 

    Now, many other posts say to make sure the URL is in the IE trusted zone and click to login using current username and password etc. and all of this has been done.  The server is running IIS 7, the website for CRM has anonymous and windows integrated security on using kernal mode, when a pop-up does appear in Outlook, it shows the "Trysted Zone" at the bottom so I know that's working.  The odd thing is this though; to connect to the CRM server in IE8, I must use the following, http://<servername> with nothing behind it.  If I use http://<servername>.domain.com, it does not connect and neither does the Outlook add-in URL section, but, when I get the login prompt, I get the request for usename and password for <servername>.domain.com at the bottom of the credential window.  Odd to me anyways.

    What I placed in the Trusted Zone is both http://<servername> as well as http://<servername>.domain.com and it still does not work.  Also, I have added users to the NTFS permissions to the c:\inetpub\wwwroot for read access as once suggested as well.

    Any thoughts?

    Saturday, October 1, 2011 6:06 PM

Answers

  • don´t know what is going on with the pics..

    under security in IE for local and internet zone, uncheck the mark for enable protected mode

    enter your url´s in local not trusted and in advanced for local intranet zone, check the mark for Display mixed content and domain limits on access across data sources on


    greetz dao
    • Proposed as answer by Daniel Ovadia Monday, October 17, 2011 7:37 AM
    • Marked as answer by ehouser Wednesday, October 19, 2011 6:21 PM
    Wednesday, October 12, 2011 7:51 AM

All replies

  • Anyone????  
    Tuesday, October 11, 2011 2:25 PM
  • hi,

    did u uncheck this mark? also uncheck under local intranet? did u use in advanced option logon with current username and passwort?

     

     

    make follwing also in IE:

     


    greetz dao
    Tuesday, October 11, 2011 2:59 PM
  • Not sure what the images were supposed to be as they are not appearing, but on the advanced option, logon with current has been used without luck
    Tuesday, October 11, 2011 3:02 PM
  • hi,

    did u uncheck this mark? also uncheck under local intranet? did u use in advanced option logon with current username and passwort?

     

     

    make follwing also in IE:

     

     


    greetz dao
    Tuesday, October 11, 2011 3:06 PM
  • don´t know what is going on with the pics..

    under security in IE for local and internet zone, uncheck the mark for enable protected mode

    enter your url´s in local not trusted and in advanced for local intranet zone, check the mark for Display mixed content and domain limits on access across data sources on


    greetz dao
    • Proposed as answer by Daniel Ovadia Monday, October 17, 2011 7:37 AM
    • Marked as answer by ehouser Wednesday, October 19, 2011 6:21 PM
    Wednesday, October 12, 2011 7:51 AM
  • OK, so that works, thanks you, BUT I would not want to leave the IE zone of Internet without the protected mode unchecked.  Doesn't that defeat the whole purpose of protected mode?  Also, if I place the check mark back to the protected mode on Internet zone only, I will receive an error on printing My Activities.  For example, I go to Workplace>My Work>Activities and select Today.  Then I print these but receive an error back from CRM saying there was an error.  
    Friday, October 14, 2011 2:05 PM