locked
Visual Web Developer 2008 Express Edition - STOP <% tag enclosure! RRS feed

  • Question

  • There doesn't seem to be a category for "Visual Web Developer 2008 Express Edition" so i'm putting this question here instead since it involves VBSCRIPT.

    I code in classic asp.  That means web pages that end in .asp extensions.

    Inside the web page, the vb script code is inclosed in <% %>  tags.... like this:
    <HTML>
    <BODY>
    <%response.write "hi there"%>
    This is some regular html text.
    </BODY>
    </HTML>

    I always work in CODE VIEW.   Not html / design view.  Here's the problem.... as I'm coding, I never - ever EVER want the program to "finish" anything for me.   Automatic color coding is one thing.   Automatically ending tags is NOT something I EVER want it to do.

    I've spent hours inside the Microsoft Visual Web Developer 2008 Express Edition options to try to figure out how to stop this.   Every type I type <%, it automatically inserts a space and then %>.   IS THERE ANY WAY TO STOP THIS BEHAVIOUR???  When I'm coding I know exactly what I want to type, and I DO NOT want the program automatically finishing ANY tags for me, but finishing the <% %> is extremely annoying on top of all the rest.  I will do my own code, thank you and I do not need the program to type anything for me.

    Possible to stop tag enclosure for <% %>?  yes/no?
    • Moved by YiChun Chen Monday, November 30, 2009 10:29 AM It's off-topic here. Please consult your issue on ASP.NET forum. You will get more useful help. (From:Visual Basic Express Edition)
    Sunday, November 29, 2009 12:02 AM

Answers

  • Yes, there is a forum exactly for this.  Not necessarily easy to find since the ASP.NET stuff is on a different forum system!

    Here is the link, please post there:

    http://forums.asp.net/1125.aspx

    Thanks.
    • Marked as answer by YiChun Chen Monday, November 30, 2009 10:28 AM
    Sunday, November 29, 2009 2:12 AM

All replies

  • Yes, there is a forum exactly for this.  Not necessarily easy to find since the ASP.NET stuff is on a different forum system!

    Here is the link, please post there:

    http://forums.asp.net/1125.aspx

    Thanks.
    • Marked as answer by YiChun Chen Monday, November 30, 2009 10:28 AM
    Sunday, November 29, 2009 2:12 AM
  • In Visual Studio:

    tools -> options -> Text Editor -> HTML -> Format -> Auto Insert Close Tag
    Sunday, November 29, 2009 3:18 AM
  • In Visual Studio:

    tools -> options -> Text Editor -> HTML -> Format -> Auto Insert Close Tag

    I tried this, doesn't work.   I even closed the program and opened it again - the instant I hit <% it autoinserts a space and then types %> for me.

    I've gone into every detailed configuration option for each template and turned off autoinsert and autoclose tags and autoformat for all of them.  IT STILL DOES IT  AAAAAIGH!

    I will try using the forum that binarycoder mentioned, even though I'm using classic asp (vbscript, not asp.net)
    Sunday, November 29, 2009 10:38 AM