Email Router the caller was not authenticated RRS feed

  • Question

  • I have a live server and a dev server both have the email router running on them. The dev box can connect to the live organization service and retrieve users and queues. It can connect to itself and get users and queues.

    The live server can connect to the dev organization and retrieve users and queues. When I attempt to load data on the live server from the live server email router I get "the caller was not authenticated by the service" error.

    I have Googled for 2 days and have looked at everything I could find. The install must be good because I can connect to dev and the data is good because I can connect from another email router.

    I have done the obvious ie checked the users, made sure the account was in the PrivUsrgrp the url is correct and the account password worked for logging in to the CRM instance.

    I also uninstalled the email router and re-installed it. I'm stumped on this one. Any help would be appreciated.


    Tuesday, September 23, 2014 7:03 PM


  • I found my answer. I notice a security audit failure and when I looked that up I found this solution.

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. Right-click Lsa, point to New, and then click DWORD Value.
    4. Type DisableLoopbackCheck, and then press ENTER.
    5. Right-click DisableLoopbackCheck, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Exit Registry Editor.
    8. Restart the computer.

    Adding the new registry key fixed my issue.

    • Marked as answer by Brian Buchanan Wednesday, September 24, 2014 6:24 PM
    Wednesday, September 24, 2014 6:24 PM