none
Remote Connection from Windows media center edition RRS feed

  • Question

  • I have just set up WHS at home on an old Dell that met the system requirements. I added the connector software to a second computer on my networkat home. At home everything works fine (so far). At work I cannot connect remotely to the client computer at home through WHS. I can log on to the WHS server and it says that the client is available to connect to. I can also browse the shared folders. When I try connecting I get a warning box that says I need the terminal services client add-on. I have this add-on and it is enabled. I am trying to connect from work from a Windows media center SP3 machine using IE 7. I went to another machine at work  (we are all on the same peer-to-peer network going through the same router) that has XP Pro SP3 and IE 7 and I do not have this problem. I am connecting 2 WHS through XXXXXX.homeserver.com. I have added that website to my trusted zone at work. I have deleted the registry keys and added the registry setting for NVidia as that is my video card. I have tried connecting through safe mode and that has not worked. I do not know what else to do.

    Thanks for your help.

    Mitch
    Saturday, October 25, 2008 2:52 AM

All replies

  • Makman said:

    I have just set up WHS at home on an old Dell that met the system requirements. I added the connector software to a second computer on my networkat home. At home everything works fine (so far). At work I cannot connect remotely to the client computer at home through WHS. I can log on to the WHS server and it says that the client is available to connect to. I can also browse the shared folders. When I try connecting I get a warning box that says I need the terminal services client add-on. I have this add-on and it is enabled. I am trying to connect from work from a Windows media center SP3 machine using IE 7. I went to another machine at work  (we are all on the same peer-to-peer network going through the same router) that has XP Pro SP3 and IE 7 and I do not have this problem. I am connecting 2 WHS through XXXXXX.homeserver.com. I have added that website to my trusted zone at work. I have deleted the registry keys and added the registry setting for NVidia as that is my video card. I have tried connecting through safe mode and that has not worked. I do not know what else to do.

    Thanks for your help.

    Mitch


    Have you tried resetting IE7 on your MCE machine?  (Tools, Internet Options, Advanced tab, Reset button)
    Saturday, October 25, 2008 3:34 AM
    Moderator
  • Multiple times.

    Thanks
    Saturday, October 25, 2008 5:46 AM
  • anyone?
    Sunday, October 26, 2008 8:30 PM
  • Hello,
    did you already try to reinstall the Terminal Services Add-On with the method described in the thread http://social.microsoft.com/Forums/en-US/whssoftware/thread/e0e6ae17-fa40-4d55-bbdf-0e905f3ede94 ?

    The two batch files in that description can also be downloaded from here.

    Best greetings from Gemany
    Olaf
    Sunday, October 26, 2008 8:58 PM
    Moderator
  • Yes, I did and I just tried again. The add-on is there and enabled. It just seems that Internet Explorer or WHS doesn't know it's there. If I disable it I get the little notification saying that the website is trying to use an add-on that is disabled. When I enable it I no longer get that notification but I get the big error box in the middle of the screen saying that I need the add-on.


    Thanks,

    Mitch
    Sunday, October 26, 2008 9:34 PM
  • Did you also delete Temporary Internet Files, Cookies etc.?
    As a workaround you could try port forwarding of port 3389 from your router to the client PC.
    Adjust the Windows Firewall Remotedesktop exception scope on that client to allow connections from all networks.
    Try now to connect with the Remote Desktop client of your MCE PC to your homeserver.com address - this should bring you directly to your client.
    Best greetings from Germany
    Olaf
    Sunday, October 26, 2008 10:18 PM
    Moderator
  • I can use Remote Desktop to get to the client PC doing what you said (In fact I was able to do this before). However I cannot log onto my WHS server console from my MCE machine at work. I get the same error. I forgot to mention that at the beginning of the thread. I assume it is from the same problem.

    I have deleted cookies and temporary files etc.

    Thanks,

    Mitch

    Sunday, October 26, 2008 10:27 PM
  • Hi Mitch,
    what happens, if you disable the Windows Firewall (or any 3rd party firewall) on that machine?
    Can you connect after that?
    Best greetings from Germany
    Olaf

    Sunday, October 26, 2008 11:00 PM
    Moderator
  • I assume you mean my MCE machine at work. I have tried disabling zone alarm to no avail.

    Thanks,

    Mitch
    Sunday, October 26, 2008 11:03 PM
  • Hi Mitch,
    Zonealarm is such an tool, which digs itself deep into the system. So even if you disabled it somehow, you cannot be sure, that it is really out of the game.
    The only way to ensure would be uninstalling, before trying again.
    Best greetings from Germany
    Olaf
    Sunday, October 26, 2008 11:36 PM
    Moderator
  • I will uninstall it. But the other work machine that had no problem connecting also has ZA on it.

    I will let you know what happens.

    Thanks

    Mitch
    Monday, October 27, 2008 12:50 AM
  • Well, I uninstalled zone alarm and tried again. It did not work. I turned off Windows firewall it still did not work. I tried logging in with several of my usernames and it still did not work. I think I am out of luck on this one.

    Thanks,

    Mitch
    Monday, October 27, 2008 7:15 PM
  • Hi Mitch,
    sorry to hear about the current bad results. Around the time you are trying to establish the connection, are there any error messages related in the event log of that client and the server?

    If yes, please post them in detail.

    XP Mediacenter is a little bit special, since it is stuck somewhere between the home and pro editions of XP (at least the later versions), but this should not cause this kind of trouble. (I better not ask for uninstalling IE 7 and trying with IE6 ... )

    Best greetings from Germany

    Olaf

    Monday, October 27, 2008 7:55 PM
    Moderator
  • Actually I did try downgrading to Internet Explorer six yesterday, it did not work.

    I am not sure which logs you are talking about. My MCE machine a work, or the server at home? On the MCE machine, there are indeed RDP errors and they all indicate that the drivers for my home printers are unavailable. I did not check the other machine at work that has no problem connecting, but I know for a fact that it does not have my home printer drivers installed.

    Thanks,

    Mitch
    Monday, October 27, 2008 8:10 PM
  •  
    Makman said:

    Actually I did try downgrading to Internet Explorer six yesterday, it did not work.

    I am not sure which logs you are talking about. My MCE machine a work, or the server at home? On the MCE machine, there are indeed RDP errors and they all indicate that the drivers for my home printers are unavailable. I did not check the other machine at work that has no problem connecting, but I know for a fact that it does not have my home printer drivers installed.



    downgrading to IE6 may be a problem, if you installed SP3 on top. Otherwise it would be simple running spuninst.exe from c:\windows\ie7\spuninst folder.

    Confusing: The printer driver errors usually should happen on the machine, you are connecting to - since the terminal server tries to use the installed printers of the connecting client, if not configured differently, and is disappointed about not having drivers for those.  But on the client you should not see such errors, or only if you try to connect to your client via remote desktop.

    Can you RDP with Remote Desktop Client from your MCE machine to the server, if you forward port 3389 to your WHS in the router and do the firewall exception scope change as described before?

    Best greetings from Germany
    Olaf

    Monday, October 27, 2008 8:52 PM
    Moderator