locked
WgaTray.exe consuming almost 100% CPU, system slowed to crawl RRS feed

  • Question

  • System has slowed to a crawl last week or so. Especially yesterday after auto-update completed and WGA update was installed. That actually hung. System restarted and ever since WgaTray.exe is showing as using 99 - 100% of CPU. I have to kill it or lower priority in order to get work done. I use Live OneCare for regular system maintenance, anti-virus, etc. Defender for spyware detection and removal. This is a pretty vanilla XP-pro machine.

     

    I'd hate to disable WgaTray.exe on a long-term basis. Tried System Restore and of course it will not. System won't let me uninstall the latest WGA update either. (KB905474 installed on 3/28/2007) "this update cannot be removed". I'm not getting the Notifier pop-up, so I can't disable that way. (http://support.microsoft.com/Default.aspx?kbid=905474)

     

    For now, I have to kill the process, but I'd very much appreciate some better workaraound, back-out.

     

    Thanks.

     

     

    Diagnostic Report (1.7.0012.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Detailed Status: N/A
    Windows Product Key: *****-*****- remainder hidden

    Windows Product Key Hash: lcpIhbOAvsomDMfQC0kqjQFaslE=
    Windows Product ID: 55276-011-2982554-22662
    Windows Product ID Type: 5
    Windows License Type: Retail
    Windows OS version: 5.1.2600.2.00010100.2.0.pro
    ID: a2b9542f-dd7c-414b-baab-59d9eaabafbf
    Is Admin: Yes
    AutoDial: No
    Registry: 0x0
    WGA Version: Registered, 1.7.18.5
    Signed By: Microsoft
    Product Name: N/A
    Architecture: N/A
    Build lab: N/A
    TTS Error: N/A
    Validation Diagnostic:
    Resolution Status: N/A

    Notifications Data-->
    Cached Result: 0
    File Exists: Yes
    Version: 1.7.18.5
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: Microsoft

    OGA Data-->
    Office Status: 101 Not Activated
    OGA Version: Failed to retrieve file version. - 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: FCEE394C-3178-80070002_3E121E02-154-80070002_E5ECEA81-80-80070002_B4D0AA8B-864-80070002

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
    Default Browser: C:\Program Files\Internet Explorer\IEXPLORE.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>a2b9542f-dd7c-414b-baab-59d9eaabafbf</UGUID><Version>1.7.0012.0</Version><OS>5.1.2600.2.00010100.2.0.pro</OS><PKey>*****-*****-*****-*****-KX8CK</PKey><PID>55276-011-2982554-22662</PID><PIDType>5</PIDType><SID>S-1-5-21-1935655697-1177238915-839522115</SID><SYSTEM><Manufacturer>INTEL_</Manufacturer><Model>D845GBV2</Model></SYSTEM><BIOS><Manufacturer>Intel Corp.</Manufacturer><Version>RG84510A.86A.0017.P09.0209092000</Version><SMBIOSVersion major="2" minor="3"/><Date>20020909000000.000000+000</Date></BIOS><HWID>6CBC308F01842072</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/></MachineData>   <Software><Office><Result>101</Result><Products><Product GUID="{90120409-6000-11D3-8CFE-0050048383C9}"><LegitResult>100</LegitResult><Name>Microsoft Office XP Home</Name><Ver>10</Ver><Val>B4B7AB44C5014A8</Val><Hash>ci3aNCsVa4rfFKJbYH583UDiusw=</Hash><Pid>54187-640-1582921-17122</Pid><PidType>14</PidType></Product><Product GUID="{91110409-6000-11D3-8CFE-0150048383C9}"><LegitResult>101</LegitResult><Name>Microsoft Office Professional Edition 2003</Name><Ver>11</Ver><Val>9B2A8C4EF87B578</Val><Hash>zuAukDZh1aNNixBhWbjHbd0dJlA=</Hash><Pid>70145-700-3607156-57148</Pid><PidType>1</PidType></Product></Products></Office></Software></GenuineResults> 

     

    Thursday, March 29, 2007 1:05 PM

Answers

  • Thank you Anonymous, for telling us what fixed your issue!

     

    I have forwarded this post to the Dev that wrote WgaTray.exe, for analysis, in the hope that we can avoid this from affecting any other users.

     

    Thank you again,

    Darin Smith

    WGA Forum Program Manager

    --------------------------------------------------------

    All Users: Please go to http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=1255325&SiteID=25 before posting a question.

    --------------------------------------------------------

     

     

    Monday, April 2, 2007 9:34 PM

All replies

  • Hello Anonymous,

     

      Please go to https://support.microsoft.com/oas/default.aspx?c1=509&gprid=9860 and open a free WGA Service Request. Once done, please post the Service Request number in this thread.

     

    Thank you,
    Darin Smith
    WGA Forum Program Manager

    --------------------------------------------------------

    All Users: Please go to http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=1255325&SiteID=25 before posting a question.
    --------------------------------------------------------

     

     

    Thursday, March 29, 2007 8:37 PM
  • Does this confirmation number represent a "servide request" number?

    Confirmation number: 1032541047

    Friday, March 30, 2007 11:40 AM
  • This is fine, I will be monitoring the progress of this case and may contact you if my Devs or I have any questions or suggestions.

     

     

    Thank you,

    Darin Smith

    WGA Forum Program Manager

    --------------------------------------------------------

    All Users: Please go to http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=1255325&SiteID=25 before posting a question.

    --------------------------------------------------------

    Friday, March 30, 2007 9:41 PM
  • Thanks. I opened a WGA Service Request. The confirm number is Confirmation number: 1032590240
    Saturday, March 31, 2007 1:54 AM
  • Issue resolved. Downloaded and installed manual WGA update http://download.microsoft.com/download/8/8/e/88e78788-5d68-49e4-afdd-3c8c9ab77843/WindowsXP-KB905474-ENU-x86-Standalone.exe

    Seems to have resolved the problem.

     

    By the way, Microsoft responded promptly to my support request. The response had a fair amount of generality (like disable non-microsoft anti-virus, etc. even though I had specified I was using Live OneCare), but did also contain the suggestion to install the stand-alone. So, had I waited and followed their instructions, that would have solved my problem, too.

     

     

    Saturday, March 31, 2007 1:01 PM
  • Thank you Anonymous, for telling us what fixed your issue!

     

    I have forwarded this post to the Dev that wrote WgaTray.exe, for analysis, in the hope that we can avoid this from affecting any other users.

     

    Thank you again,

    Darin Smith

    WGA Forum Program Manager

    --------------------------------------------------------

    All Users: Please go to http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=1255325&SiteID=25 before posting a question.

    --------------------------------------------------------

     

     

    Monday, April 2, 2007 9:34 PM
  • WGA may be good,but is a curse to me.any program update or other program installation,and the os program declared as fraud.How to get rid of this.We cannot go on purchasing every now and the.
    Thursday, July 22, 2010 6:09 PM