Error "There is not enough space on the disk" copying very large files.


  • I've created a share in WHS called "RecordedTv".  I've turned duplication off for the share, and I have plenty of space available (~200GB).

    I setup a batch file to move recorded tv files from my MCE machine to WHS, this works fine most of the time, but the other night I recorded a 2 hour CSI (16GB) and when I try to move/copy the file I get the error "There is not enough space on the disk" - is there a file size limitation in WHS?  Should I bug this?



    Monday, March 12, 2007 5:52 PM

All replies

  • Is your primary hard drive in WHS smaller than the rest of your hard drives in the box (assuming you have more than 1). WHS currently caches all data on the primary drive before distributing it to the rest of the drives. So if there isn't enough space on the primary at the time the copy occurs, then you will get that error. It is my understanding that WHS tries to keep the primary data partition clear for this very reason. Later versions of WHS are supposed to have this copy space limitation removed.
    Monday, March 12, 2007 6:49 PM
  • No - my primary HD is the largest drive.  I have 3 drives:  HD1 Primary -200GB,  HD2 160 GB , HD3 40GB

    According to System storage I have around 200GB available.  The file I'm trying to copy is 16GB.  And the share that I amy trying to copy too has 'duplication' turned off.

    I don't see why I can't copy the file.


    EDIT - Is there any reason that having added the small 40GB drive could hurt performance/functionality?  I have another spare 40GB drive should I add it too?




    Monday, March 12, 2007 7:17 PM
  • Are you copying a lot at once? I'd still bet the primary disk is filling up and when you go to copy more files, it can't because DE hasn't distributed the new files to the other drives yet.

    What happens if you map one of the WHS shares to a drive letter? How much free space does that report? You can see the free space reported increase as DE moves new files off the primary to the other drives.

    I'd wait some time, see if it lets you copy later. If it works later, then what I described is likely what is happening.

    Monday, March 12, 2007 7:33 PM
  • "Are you copying a lot at once?"

    - I'm copying 1 file - which happens to be 16GB - a 2 hour ATSC HD Recording.

    "What happens if you map one of the WHS shares to a drive letter? How much free space does that report?"

    - That's how I'm copying it - I have the share permanently mapped as my R:\.  The R: reports size as 176GB  152GB free.

    I'll wait and see if it copies tonight.





    Monday, March 12, 2007 8:43 PM
  • Yeah, that is strange. I think as long as the share shows enough free space, then you should be able to copy a file up to that size.

    Sounds like this is a different problem. Do smaller files copy ok? Maybe it does have something to do with the 16 GB?

    Monday, March 12, 2007 8:51 PM
  • Yes,  smaller files copy fine.  I am also able to copy files around 6~7GB without problem - so it's not a 32-bit address/4GB limit.  That's why I was wondering if WHS (Or maybe something for the beta) had a max file size limit somewhere.



    Monday, March 12, 2007 9:58 PM
  • I know there has been some discussion on transfer size problems in beta 2 and how space is determined.  I am pretty sure the team is aware of this issue.  I still suggest filing a bug report and posting the connect link back in here so others can vote on it.
    Tuesday, March 13, 2007 8:24 PM
  • I have seen this exact error.  I have 1 TB+ of HD video material and have been copying this up to WHS and serving it out to a TVIX 5000 HD unit for playback.  Works very well. 

    I've put a bug report up here as during the copy operation something strange happened to my drives and I eventually ran out of space.  WHS thinks I've got lots of space left, unfortunately my disks think otherwise. 

    I found early on I was initially copying up too much, too fast and the primary disk couldn't keep up.  Eventually DEMigrator moved everything around, and I was able to start copying again.  Moving things around in 50GB chunks seemed to be the easiest way to do this.  Sometimes I just had to wait 20-30 mins for some space to be freed up on my primary disk while DEMigrator did its thing.  My primary physical disk is 320GB at this time.  I can see why the largest disk is recommended for the Primary.  I'll probably go 500GB next build, or 1TB for the final RTM build.

    On the file size limitation question - I don't think there is one.  I've got a 22GB file, a 17GB file, a few 16GB files and lots of files over 10GB. 



    Wednesday, March 14, 2007 3:45 AM
  •  Not sure if this is the same problem ,however I am recieving a Network Health Status at risk

    Storage Status

    Duplication is failing for the following shared folder. There is not enough free space available to maintain a copy on more than one drive.

    The share at risk is "Software"

    I am using a 250 GB drive as my primary drive with a 150 GB as my second drive and showing 327 GB free space.

    I am getting the error when "Duplication is enble " or "Disabled"

    This started after coping a 2.6 GB folder to "Software" share.


    Wednesday, March 14, 2007 10:38 PM
  • It could be related.  Could you do this:
    A) Note your "free space" as showing in the WHS console
    B)Have a look in Disk Management on the WHS server itself and determine the total amount of free space showing for the DATA disks.  You'll see two as you have two disks.

    Both should be equal.  That is the WHS 'free space' should equal the same space as showing on your two DATA disks when combined.  I am betting they are not equal. 

    In my case WHS thinks one thing in the console - which is correct - but my disks show much less space.  I think I know what the problem is that is causing this behaviour, but I'm waiting to hear from Microsoft on my bug report first.

    Thursday, March 15, 2007 5:35 AM
  • Thanks for the pointers,this is what I see

    My Computer on the server

    Sys (C:)  10 GB     5.27 GB  Free

    Data (D:) 222 GB   212 GB Free

    In Computer Management I see Different Data

    Disk 0  returns the same as My Computer Drive letter C: and D: 

    Disk 1 149GB  129Gb Free  No Drive Letter

    Server Storage on The Home Server Console reports

    WDC-WD2500JS-75NCB3    232.83 GB

    ST3160811AS                         149.05 GB

    Total Size:                                 381.88

    Free Space:                             350.86 GB

    Both drive reports healthy and the Share "Software" reports "Failing" with the same error message.All other shares are "Healthy"

    The Data Disk are certainly not "equal" in Computer Management and the fact that the second hard drive has no drive letter seems strange and does not appear in My Computer is troubling.

    There seems to be some error in the way the different parts of the WHS looks at and reports Disk Drives ,you are on the right track the problem lies here and I guess I will just follow this thread and report any changes on my end.



    Thursday, March 15, 2007 12:39 PM
  • I'm having a similar problem so I turned of duplication, stopped backups and cleaned it all.  I'm trying to move stuff from one 500GB drive up to the system (Main drive is 120 gbs, and a second drive of 500GBs) once I transferred the data I'm adding htis 500GB external into the mix.  Thought it'd solve the problem of space.  But then as I slowly copy stuff over it doesn't seem to have the problem.  I do notice that it seems to keep showing balancing storage, storage balanced...that might be related?  Because right now it is working.  When I first got the problem the Server Storage said I had about 230GBs free, but I had the alert that I had less than 5GBs free or something.


    I also got an error when I tried to copy a bunch of data (maybe this relates to the cache issue)  Because I got a warning saying I only had 64 GBs of space left.  So I copied 40GBs...and left it alone...since then I have copied more than that...we'll see what happens as it copies.  Unfortunately in the effort of moving adn testing large files.  I think I just blew away a 300GB, which I was going to back up...buh bye family photos...Hopefully I can recover it, I keep getting an error that it can't read the NTFS information...ugh.

    Saturday, June 23, 2007 1:16 AM
  • Rouza:  How did your Sys (CSmile Drive get to be 10GB, the standard install of RC1 fixes it at 20GB, having only 5.27 free on that drive/partition might be the root of the low disk space warning.

    The only real partition that gets a drive letter in My Computer>Manage>Storage>Disk Management will be the C: (Sys) partition.  Drive letter D: is managed by Drive Extender, and the way that works is files get saved to that partition first, then makes a copy to other partitions on other physical drives until there is no more space on the other drives.  If there are only two physical drives, then it always will reserve a copy on the first drive (partition, drive letter D) unless the share is marked as 'Don't Duplicate'.  That is at least how I understand it.
    Saturday, June 23, 2007 1:42 AM
  • A related error that I cannot seem to get rid of:

    WHS box has 400gb IDE as its system drive. The 2 X 200Gb IDE for storage etc and a 80gb that we had lying around that could fit into the box. WHS Console shouw all drives as healthy, and with 720GB FREE. System is a standard 20Gb and we have switched of duplication on all drives removed all the backups (2 of them and cleaned out the system as much as we can. The WHS console on one workstation says that theris is a System Disk low on space warning. If you RDC to the WHS server the Disk Manager snapin reports that the System drive has 16.4Gb free and is healthy...

    Go figure that one! I will run a CHKDSK on both volumes, reboot and see if the error comes back!

    Wednesday, August 22, 2007 3:14 PM
  •  David Wiles wrote:

    ...  The WHS console on one workstation says that theris is a System Disk low on space warning. If you RDC to the WHS server the Disk Manager snapin reports that the System drive has 16.4Gb free and is healthy...


    Do you mean the C drive (SYS Volume)?  If so, that sounds about right.  It's only 20 GB to begin with.

    Wednesday, August 22, 2007 3:41 PM
  • You may have solved this by now, though I was having the same problem and discovered that I couldn't copy an 8GB file to a 320 GB FAT32 disk.  I found I could copy it to a smaller disk formatted with NTFS. I recall having this problem about 18 months ago and I think the NTFS was the resolution.

    Friday, September 14, 2007 2:24 AM
  • Max file size on FAT32 is 2 GB.  NTFS formatted hard drives do not have this 2 GB limitation.

    Friday, September 14, 2007 3:01 PM