none
Disable registration of Private and Application network as head node name in DNS RRS feed

  • Question

  • Hi,

    We have set-up a 12 nodes Windows HPC 2008 R2 + 1 head node (HPC Pack version 3.0.2369.0). We also use this server for ANSYS License Manager. The system has 1 GigE private network and 1 Infiniband application network. Application is running fine in the system.

    The problem is, from time to time something will populate DNS entry for head node with IP address from private and application network in head node. This will confuse client workstation (which only connect to Enterprise network), since it will sometime give out private or application IP address, which is not reachable from client workstation.

    So my question is

    • How can I disable this behavior? I tried uncheck "Register address with DNS" (which actually is already unchecked) in head node Private and Application Network card but still not working. I also tried Set-HpcNetwork -PrivateDnsRegistrationType None but still not work.
    • So far it didn't affect node log-in and drive mapping. Can someone explain why it hadn't?

    Note that, most of the client are Windows 7 (64bit).

    Friday, October 21, 2011 9:17 AM

All replies

  • Hello,

    The fastest solution is to change a hosts file on each client. It takes a lot of time if you have lots of clients.

    And entry to c:\windows\system32\drivers\etc\hosts file:

    HeadnodeEnterpriseIp     heeadnodename

    HeadnodeEnterpriseIp     heeadnodename.domainname

    But, I am going to search a better solution.

    Friday, October 21, 2011 9:39 AM
  • That's what I told my customer to do. But changing all workstations hosts file is so tedious. If there is a way to fix this permanently on Head node please let me know. It looks a lot like something that could be done easily.
    Tuesday, October 25, 2011 2:21 PM