locked
SharePoint Products and Technologies wizard failure RRS feed

  • Question

  • Hello, I have a small farm test environment with Project Server 2007 SP3 April 2012 CU.

    1 application server with project server installed.  This server hosts the central admin and pwa sites.

    1 database server with sql server 2008.  this database server also has reporting services enabled which includes installing wss3.0 and joining it to the farm. 

    I patched the application server that hosts the central admin site with the JUNE 2012 cu for wss and ps2007 after stopping the www service on all servers and the project queue service.  Then patched the reporting database because it has wss.  I ran the products and technologies wiz on the app server and it completed successfuly.  I ran then ran the sharepoint products and technologies wiz on the reporting services server and it failed at step 8.  The logs indicates a PostSetupConfigurationTaskException when trying to upgrade the shared services database.  The versions table in the shared services database do not contian the same versions past and present as all of the other databases. 

    I have tried running the PSConfig.exe from the command line to ugrade, but that fails with the same error as the wizard.  I've also tried to restore the shared services database from backup using the central admin site, but the backup fails too.

    Does anyone have any other suggestions.  The site seems functional but I wouldn't feel comfortable moving forward with this in prod if I were to encounter the same error.

    Friday, July 27, 2012 3:35 PM

Answers

All replies

  • Please correct me if my understanding is incorrect

    You have 2007 farm with SP3 + April 2012 CU. Your goal is to install June 2012 CU

    1 App server and 1 db server with Database Engine and Reporting services.

    My question is why you need to install WSS 3.0 on db server and join to the farm?


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Saturday, July 28, 2012 1:13 AM
  • That is correct.   At the time that this was installed, it was my impression that wss needed to be installed on the reporting services server and joined to the farm as part of the configuration for Sharepoint integration. 

    This link has the requirements listed for ssrs in sharepoint integrated mode.

    http://msdn.microsoft.com/en-us/library/bb283190(v=sql.105).aspx


    • Edited by JennPenn07 Monday, July 30, 2012 12:53 PM
    Monday, July 30, 2012 12:51 PM
  • Hi,

    It’s not mandatory to join SSRS server to the farm, above document is about SharePoint Server 2010.

    You can disconnect this server from the farm, if you have to then we need to follow these steps

    • Disconnect the server from the farm
    • Install Project Server 2007
    • Cancel SharePoint Configuration wizard
    • Install Office Server SP3
    • Cancel SharePoint Configuration wizard
    • Install April 2010 CU for Office Serve r
    • Cancel SharePoint Configuration wizard
    • Install June 2012 CU
    • Run SharePoint Configuration wizard and connect to the farm

    P.S :

    1. Technically you don’t have to install April CU and then June CU, but I have found some issue when SP3 is directly upgraded to June CU, still testing this behavior, hence recommended to install both

    2. Office server CU contains both the components of SharePoint and Project Server. Please let me know if you need download links.

    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn



    Monday, July 30, 2012 1:26 PM
  • Hi Hrishi, thank you for your reply.  I am not getting the Modify server farm settings screen when I run the SP products and Tech..Configuration wizard.  Instead, i get the "Completing the SHPT products and tech..config..wizard". the only option is to finish the upgrade.  However it fails on step 8.

    The upgrade logs indicates that the problem occurs when trying to upgrade the Shared Services database.

    Wednesday, August 1, 2012 6:07 PM
  • Try removing the non working server from Central admin site


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    • Marked as answer by JennPenn07 Wednesday, August 1, 2012 8:06 PM
    Wednesday, August 1, 2012 7:30 PM
  • Thank you for your help!  I had wss web application and wss search services running on the reporting server.  Once I stopped it from Central Admin, I was able to complete the upgrade.  I queried all of my databases versions table and they all match.  Looks like I am good to go. :)

    Wednesday, August 1, 2012 8:12 PM
  • Excellent!!! happy to hear that

    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Wednesday, August 1, 2012 11:32 PM