locked
WIN7 and Live Mesh - Lock Symbol on Icons RRS feed

  • Question

  • So I have been using Live mesh since about day one on all my XP systems... So far with very good luck...

    This weekend I have updated one of my main systems to the Win7 RC - and placed it on my Mesh..

    Everything seems to be good except I have now noticed that a small lock symbol is showing up on some of the icons in the main folder of the folders i have synced with my WIN7 machine..

    Has anyone else seen this or is it a known issue?

    Any help would be appreciated.

    Monday, May 11, 2009 3:31 AM

Answers

  • I believe it's a new feature of Windows 7 RC.
    If there is a lock icon, then the folder is not shared with anybody else. For example, your user folder may have a lock icon, saying that no other user is able to access it without administrator authorization. I don't know the other symbols, but I would guess a Earth would appear for folders shared with everybody.

    Anyways, I don't think it should affect the synchronization with your other computers or Live Mesh
    Monday, May 11, 2009 11:24 PM

All replies

  • I've noticed it.  Not sure if it's a major issue.  A little confusing maybe.  Are the files locked for you or do they just have a lock icon?
    "We're all in it together, kid." - Harry Tuttle, Heating Engineer
    Monday, May 11, 2009 1:06 PM
  • I don't have access to my Windows 7 machines right now to check. Does it affect any functionality?
    What types of files are showing the symbol? When you right click the properties for the file, what do you see on the Win7 box vs. a Vista or XP box for the same file?

    -steve
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Monday, May 11, 2009 1:17 PM
    Moderator
  • I didn't have a chance to test it completely, but I was able to edit a TXT file with the lock, and save it.  I haven't seen the change come through on another machine though.

    I've also noticed this Windows 7 specific issue:

    http://twitpic.com/4rew4

    UI rendering issues when trying to resolve conflicts on Win7 machines.

    "We're all in it together, kid." - Harry Tuttle, Heating Engineer
    Monday, May 11, 2009 1:46 PM
  • That's a lovely rendering issue. ;-) That was mentioned in another thread that I read this morning.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Monday, May 11, 2009 2:27 PM
    Moderator
  • Ok - so as I see it - If you drag the icon / item from the mesh folder only lets say the desktop - then the lock dissapears...

    it does seem that you can edit them with no issues inside or outside of the meshed folder - and they seem to transfer ok also..

    So hopefully its just a icon issue...

    Running: 64bit Win7
    Latest version of Live Mesh
    All Updates on WIN7 are current
    Monday, May 11, 2009 4:38 PM
  • I don't have access to my Windows 7 machines right now to check. Does it affect any functionality?
    What types of files are showing the symbol? When you right click the properties for the file, what do you see on the Win7 box vs. a Vista or XP box for the same file?

    -steve
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator

    Ok, I cleared out my conflicts via a Vista box and the word "Test" I added to the TXT file with a lock icon.  That change seems to have been propogated to my other machines.

    So, even though the icons all have a lock, they don't seem to *be* locked.  I can edit them, and the changes are synced with other machines.  Doesn't seem to affect functionality based on my limited test.
    "We're all in it together, kid." - Harry Tuttle, Heating Engineer
    Monday, May 11, 2009 4:58 PM
  • I believe it's a new feature of Windows 7 RC.
    If there is a lock icon, then the folder is not shared with anybody else. For example, your user folder may have a lock icon, saying that no other user is able to access it without administrator authorization. I don't know the other symbols, but I would guess a Earth would appear for folders shared with everybody.

    Anyways, I don't think it should affect the synchronization with your other computers or Live Mesh
    Monday, May 11, 2009 11:24 PM
  • I believe it's a new feature of Windows 7 RC.
    If there is a lock icon, then the folder is not shared with anybody else. For example, your user folder may have a lock icon, saying that no other user is able to access it without administrator authorization. I don't know the other symbols, but I would guess a Earth would appear for folders shared with everybody.

    Anyways, I don't think it should affect the synchronization with your other computers or Live Mesh

    If this is the case then it doesn't make much sense on a shared folder.  All of the files in my "Household" folder that I share with my wife (via Mesh) have locks.  I guess that probably counts as Admin auth, but it could be confusing to the average user.
    "We're all in it together, kid." - Harry Tuttle, Heating Engineer
    Tuesday, May 12, 2009 1:20 PM
  • I agree its definately confussing - the first thing I thought when i saw it was admin access or no access / read only..... which is aparentally not true...

    So curious to the real answer from MS

    Or maybe I should write it up as a bug....

    Tuesday, May 12, 2009 2:50 PM
  • I agree its definately confussing - the first thing I thought when i saw it was admin access or no access / read only..... which is aparentally not true...

    So curious to the real answer from MS

    Or maybe I should write it up as a bug....


    I anticipate an argument that this works as expected.  Technically at the OS level, my wife can't see the files in that folder unless she's an Admin.  But she can see them via Live Mesh because of our policy there.

    I wonder what would happen if my wife and I both put the "Household" folder in our public documents.  I'd imagine things would be fine if I put a file in my Mesh folder, but later when my wife signs in and tries to synch, it might freak out when it sees that the file is already there.  Hopefully it's really smart, notices that the files are the same already, and figures it doesn't need to sync.  That'd save a little space - I think we're presently each keeping a copy of the folder in our "My Documents".

    I'd imagine that if we keep this folder in "public" it might also lose the locks.  Worth some experimentation...
    "We're all in it together, kid." - Harry Tuttle, Heating Engineer
    Tuesday, May 12, 2009 5:04 PM
  • Windows 7 feature annoyance:

    I am working with virturalbox [www.virtualbox.org ] bootings from .iso files etc.
    I created an .iso with "infrarecord" and could not see the file when I tried to open it in "virtualbox".
    I noticed the red lock near the icon.

    Initially, I thought that it must be a permissions problem. Trying to change the permissions failed.
    I received the error message "Unable to set new owner on blahblah.iso" "the system can not find the file specified" giving the "Users" group permissions to the file. New feature or irritation?  Only time will tell.

    Friday, July 24, 2009 2:42 PM
  • Windows 7 feature annoyance:

    I am working with virturalbox [www.virtualbox.org ] bootings from .iso files etc.
    I created an .iso with "infrarecord" and could not see the file when I tried to open it in "virtualbox".
    I noticed the red lock near the icon.

    Initially, I thought that it must be a permissions problem. Trying to change the permissions failed.
    I received the error message "Unable to set new owner on blahblah.iso" "the system can not find the file specified" giving the "Users" group permissions to the file. New feature or irritation?  Only time will tell.


    And this relates to Live Mesh how?
    You might want to check out the Windows 7 forums.
    http://social.technet.microsoft.com/Forums/en/category/w7itpro,windowsvistaitpro,windowsxpitpro/

    -steve

    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Friday, July 24, 2009 3:06 PM
    Moderator
  •  

    I thought it was related because the user posts above describe the same problem of not having access to files with the lock icon appearing next to it. So far I have not been able to find any documentation on this feature or problem/solution(s) posted on windows 7 forums, hence my post.  My problem is not specific to Mesh but simular in the fact that I can't access my files(with lock icon under windows 7) unless I create or copy them to the public folder (This solution was found in this thread). If this makes any sense.  Thanks for the link.

    Monday, July 27, 2009 3:00 AM
  • Thanks for the clarification and you're welcome for the link. Your case sounds like a basic sharing/permissions issue. You may want to right click the file or folder in question and check the permissions (while logged into the machine hosting the data).
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Monday, July 27, 2009 12:45 PM
    Moderator
  • Disclaimer: You should not follow any of these instructions. They will cause you harm in every conceivable way. Don’t continue I say again … go read a book, see a movie, hit the gym, spend time with family and friends but by all means don’t read any further and certainly don’t follow any of these instructions.
    Windows 7
    Are you getting these errors?
     “an error occurred while applying security information to: “filename”
    “access is denied”
    “you currently don’t have access to this folder”
    File Folder Lock On Lock Off Icon
    Note: you may want to create a “test folder” and test these instructions so you can get familiar with them. Also if you have lots of folders, subfolders and files your computer may take awhile to make all the changes. Just sit back and relax while it crunches away ;-)
    If you are going to want access to all your folders and files start with the topmost folder as we will be making a selection that will apply the setting to all subfolders and files. Ill point this out when we get to it later. You may only want to do this to files that you use directly and not mess with system files etc. These instructions can help you with files already on your system or files that you are bringing in from an external drive or other source.
    Here we go!
    First we will be taking “ownership” of your files and folders (instructions 1-18) then we will be granting you the proper “permissions” (instructions 19-30) ; these are two key principles you need to be aware of to properly manage your files. The good new is that once you make these changes they will persist and then you will be your local file guru!
    Instructions:
    TAKING OWNERSHIP (1-18):
    1) Turn on your computer and log into windows with administrator privileges. If you are the only user of your computer then chances are the normal account you log in with has these privileges. If someone else set your computer up for you they may have the administrator privileges and you should check with them.
    2) Right click on your top most folder and select properties.
    3) Select the security tab at the top.
    4) Don’t answer any questions that pop up just click the “advanced button” on the bottom right.
    5) Click the owner tab.
    6) Now click edit.
    7) Then click on “you”, that is, the account that you just logged into your computer with, also known as your “username”.
    8) Check the box “replace owner on subcontainers and objects”. I promised to point this out earlier. If you don’t check this box then any changes you make WON’T apply to the subfolders and files.
    9) Click apply.
    10) A dialog box should pop up with a message “You do not have…”
    11) you should select “yes”
    12) Another dialog box should pop up with a message “If you have just taken ownership …”
    13) Select “OK”
    14) Click “OK” again to close the “advanced security settings” screen were making changes to.
    15) The next box should now show you as the current owner
    16) Click “OK”
    17) Click “OK” again to close the properties tab
    18) We are now back at your folder listing. Congratulations! You are now the proud owner of your files! Take good care of them 
    SETTING PERMISSIONS
    19) OK, now let’s get started setting your permissions. Right click your topmost folder again and select properties.
    20) Select the security tab at the top.
    21) OPTIONAL: You will likely see a list of “group or user names” that have various permissions. You don’t need to make any changes to these. If you want to remove some then click edit, highlight a “group or user” and hit remove.
    22) If you are not already listed we need to add “you” to the list, again by “you” I mean the name of the account  that you logged into your computer with to start this session when you logged into windows, in other words your “username”. Click “add” then type JUST your username that comes up when you first log in to your computer by entering your username and password. You shouldn’t’ include any pathnames JUST the username.
    23) Click on “check names”; windows should find you.
    24) Click “OK”.
    25) Now you should be back at the “Permission/security” box
    26) Check the “full control” box under “allow”. Scroll down and you will see you can do everything now. Hey, stop obsessing …the “special permissions” tab is OK unchecked…  It is there if you were to want to fine tune. You took full control already what else do you want  You are behind the driver’s wheel my friend, enjoy!
    27) Select “apply”.
    28) Select “OK”
    29) Select “OK”
    30) OPTIONAL (THE little LOCK): did a “lock” appear. It might have if you removed all other “group or user names” back in step 21. The lock just means that YOU alone have access to these files. It is not bad in fact it is an easy way to see that the folder is unshared in every way. If you want to experiment with the “lock” try this: Right click the folder again but this time DON’T select properties instead a little higher up on the list select “share with”: see the lock by “nobody”. You aren’t sharing with anybody and so there is a lock to signify that. To experiment you can click “specific people” type “guest” click “add” then click to highlight the new “guest row” leave the “read” box checked and click “share”. You are now sharing those folders or files with “YOU” and anyone that logs onto your machine as a “Guest” and the lock has disappeared. To bring the lock back: right click the folder, click “share”, click “nobody”. LOCK ON / LOCK OFF …hey your Kung Fu is pretty good! For further experimenting with the lock try this but first a security warning: (SECURITY WARNING: changing these sharing settings may share your files with anyone going through your router/homegroup. This may compromise your security. Always protect access to your wireless router by using passwords to get onto the wireless network and also setting router passwords to prevent access to the router itself). If you set up a “homegroup” on your network and select this choice the “lock” will disappear and your files can now be shared with anyone logged into your network.
    • There could be multiple reasons for “access denied errors”. A nasty one is that the file/pathname is too long (>260 characters in Windows 7). You should start to shorten the root folder names as much as possible and bring down the longest path name to well under 260 characters (also including into that calculation the path where you will be copying the files).
    Enjoy!
    George
    This is a draft document; please send me an email to let me know how it went for you and to help improve the document.
    George2006@mailshack.com
    Tuesday, March 9, 2010 6:54 PM
  • Hi all,

    I've both "locked" and "unlocked" files in the same shared directory.

    So I don't think it's a matter of authorizations about the directory access.

    Said this... I definitely cannot understand the meaning of that symbol in the file icons.

    Any idea?

    -Phil

    Tuesday, May 18, 2010 1:04 PM
  • Hi all,

    I've both "locked" and "unlocked" files in the same shared directory.

    So I don't think it's a matter of authorizations about the directory access.

    Said this... I definitely cannot understand the meaning of that symbol in the file icons.

    Any idea?

    -Phil


    http://www.winhelponline.com/blog/lock-padlock-icon-files-folders-windows-7/

    Quote: "The lock (padlock) overlay icon appears for files/folders which are private, but located under a non-private directory. Per Raymond Chen [MS]:

    A private item is an item where the only user account with access is you.¹ You create one of these, for example, by going to the sharing wizard and saying Share with: Nobody. To avoid clutter, the overlay is shown only when there is a transition from non-private to private. (Otherwise you’d have a lock overlay on everything in your Documents folder, for example.)

    ¹Even though you are the only user account, there can still be access granted to groups and non-user accounts such as the Administrators group and the SYSTEM account."


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Tuesday, May 18, 2010 1:41 PM
    Moderator