locked
Vista Home Perium - No desktop icons or side bar RRS feed

  • Question

  • Hi

    I had a virus warning from AVG today. It said explorer.exe and wininit.exe were infected. I tried to update my virus checker and remove them but it could touch them as they are system files.

    While trying various things I rebooted. When the machine came back up there was just a blue screen after the login. Not the windows crash, just a blank desktop. No icons, no tool bars.

    I tried rebooting in safe mode but the same thing happened. No icons, no start menu - I could not do anything. I tried going back to the last good configuration from the F8 menu, That didnt help. I tried going to 640x480, but that didnt help.

    However I could press Ctrl Alt Del to get the welcome screen back up and I could start task manager. Looking at task manager neither the explorer.exe or wininit.exe were in the active processes list. I was able to get through to the help menu on task manager and from there updated my graphics drivers in case this was the issue as some forums suggested this. It didnt help.

    I then went through the help to trigger a system restore. I went back 5 days but when rebooting the same thing happened.

    The next time I rebooted to safe mode again and this time I had icons so I ran another full system scan on my virus checker.

    After this I rebooted to normal windows mode and I had icons and a normal desktop.

    I tried using Malware Bytes to find issues and it found and removed 2 things called Malware.Trace in users\public\documents\server called server.dat and admin.txt. It then rebooted but still pops up the warnings about explorer & wininit in the AVG resident shield.

    Does anyone have any ideas what I need to do to get rid of this?

    Thanks

    Iain

     

     

    • Moved by Hengzhe Li Wednesday, April 20, 2011 7:15 AM Forum Cleanup (From:MSDN, TechNet, and Expression Profile and Recognition System Discussions)
    Tuesday, November 9, 2010 1:24 PM