Error Embedding Video RRS feed

  • Question

  • Hi, I am having problems embedding a video to my blog using a 3rd party hosting site.  Error: Windows Live Writer has encountered a problem: Value of '0' is not valid for 'index'. 'index' should be between 0 and -1.

    I've copied and pasted the same code a number of times (I know it is correct) and I've even tried other videos. Same problem. Could it be that the video is too large? It's over 700mb.

    Thanks for your help!
    Tuesday, July 7, 2009 3:00 AM

All replies

  • I get an error as well when trying to embed video.  The strange thing is that the video (only when the embed code is pasted into the source) uploads fine to My Spaces blog, but it fails to upload to my Wordpress blog.  When I click the Preview tab, it shows up fine.  I have tried pasting the URL, but I get an unknown provider or incomplete URL (not true):


    And when I copy the embed code, it only works when I paste it into the source tab, where, as I mentioned, it previews fine, but it doesn't post to my Wordpress blog.  The embed code:

    <object id="wsj_fp" width="512" height="363"><param name="movie" value="http://s.wsj.net/media/swf/main.swf"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><param name="FlashVars" value="videoGUID={A0A13568-043B-468A-A8A9-0D5426057FEF}&playerid=1000&plyMediaEnabled=1&configURL=http://wsj.vo.llnwd.net/o28/players/&autoStart=false" base="rtmpt://wsj.fcod.llnwd.net/a1318/o28/video"name="main"></param><embed src="http://s.wsj.net/media/swf/main.swf" bgcolor="#FFFFFF"flashVars="videoGUID={A0A13568-043B-468A-A8A9-0D5426057FEF}&playerid=1000&plyMediaEnabled=1&configURL=http://wsj.vo.llnwd.net/o28/players/&autoStart=false" base="rtmpt://wsj.fcod.llnwd.net/a1318/o28/video" name="main" width="512" height="363" seamlesstabbing="false" type="application/x-shockwave-flash" swLiveConnect="true" pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></embed></object>

    I don't understand why it posts to one blog and not the other, nor why it previews properly in the edit/preview/source tabs.  Any ideas?  I appreciate any help.
    Thursday, August 27, 2009 5:13 AM
  • Some providers strip out embeds. You can find out by looking at the blog settings under Blogs -> Edit Blog Settings... Advanced.  In your case the the 'Embed Tags' dropdown problably says 'unknown.'  And so Writer publishes them and the provider drops them from the post.

    What blog provider is this?
    Wednesday, September 16, 2009 9:45 PM
  • Ron, I have the same "unknown provider or incomplete URL (not true for my last cases, one is even a proper microsoft one)" problem. Moreover I have Windows Live Spaces as the provider with Embedded Tags Supported.

    There is no other way as to embed via source when I get "This page has an unspecified potential security risk. Would you like to continue?"
    Sunday, September 20, 2009 5:53 AM