locked
server side XmlHttp request to Reporting service in online crm 2013 RRS feed

  • Question

  • I am trying XmlHttp request to Reporting Service of Mscrm online 2013...

    it not working... in responce, it return some html page with the below error :

    "It looks like #~#MemberName_LS#~# is used with more than one account. Which account do you want to use?"      Constants.TokenizedStringMsgs.GENERIC_ERROR = "<H1>Sorry, but we\'re having trouble signing you in</H1><p>Please try again in a few minutes. If this doesn\'t work, you might want to contact your admin and report the following error: #~#ErrorCode#~#.</p>";      Constants.TokenizedStringMsgs.UPN_DISAMBIGUATE_MESSAGE = "It looks like #~#MemberName_LS#~# is used with more than one account. Which account do you want to use?";


    I know its unsupported.... and its working fine in onpremise crm 2013...

    any solution how do i make it work in online crm...

    Actually i want to attach CRM report as an attachment to an email... in server side codeing


    Thursday, October 2, 2014 1:06 PM

All replies

  • Hello,

    I have never done this, but it is possible that CRM online webserver and SSRS are in different domains?  worth looking to see cors the issue since you said code works fine in OnPremise?

    https://hacks.mozilla.org/2009/07/cross-site-xmlhttprequest-with-cors/

    Regards,

    Jithesh.K

    Thursday, October 2, 2014 1:24 PM
  • Hello,

    Did you managed to get some solution for this?

    Thursday, October 9, 2014 2:57 PM