locked
can't login WHS remotely RRS feed

  • Question

  • Hi erverybody,
     
    I can't login remotely into WHS.
    Not through RDP nor with the console.
    This happened after removing Sharepoint services from WHS.

    Thanks in advance.
    • Changed type Erik Live Friday, January 9, 2009 4:58 PM
    Thursday, January 8, 2009 1:48 PM

Answers

  • That did it.

    Thank guys!!
    • Marked as answer by Erik Live Friday, January 9, 2009 5:36 PM
    Friday, January 9, 2009 5:36 PM

All replies

  • I restarted WHS, the clients and the ADSL modem/router and it works again.

    After I did another restart,  again remote access is impossible.
    Console doesn't work neither does RDP.
    • Marked as answer by Erik Live Thursday, January 8, 2009 4:01 PM
    • Unmarked as answer by Erik Live Thursday, January 8, 2009 4:17 PM
    Thursday, January 8, 2009 4:01 PM
  • This happened to me.. one minute things were working, next they werent.. after a bit of searching, the following fix worked for me, although Im not sure why I needed to do this...

    I followed these instrucitons I found, and it sorted out my problem...

     found my own answer. Apparently, this is a common problem althought not everyone seems to have it. That I don't understand. So I don't know if this should be considered a resolution or a workaround. The Microsoft team either needs to resolve this issue or make it part of the setup instructions. I joined Microsoft Connect for Windows Home Server so hopefully I could give them this feedback. (http://connect.microsoft.com/WindowsHomeServer)

    You have to edit your Hosts file on each client. This was a pretty standard practice a dozen years ago for network administrators but its been so long since I had to I almost forgot about such things. Follow this path on you PC:

    C:\Windows\System32\drivers\etc

    You can open the file name "Hosts" with NotePad. Below is the content of my file. I only had to add the last line which is the IP address of the WHS (named by default "Server"). This should work for you, too. Good luck!

    # Copyright © 1993-2006 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    # 102.54.94.97 rhino.acme.com # source server
    # 38.25.63.10 x.acme.com # x client host

    127.0.0.1 localhost
    ::1 localhost
    192.168.1.100 Server # Windows Home Server

    Simply add this line, as per your server name, and IP...

    192.168.1.100 yourservername # Windows Home Server

    Works for me....


    DrSoton
    Thursday, January 8, 2009 10:32 PM
  • If your console/remote access tab shows both web and remote working properly then no fix to hosts file is needed. With a upnp router in your network, and upnp allowed to be turned on, whs will do its connection setup automatically. But it does lose connection sometimes. The best way to know if the remote is working or not before you try it, is to have the add-in installed that emails any alerts to you (can't remember the name but got it from www.wegotserved.com). I occasionally see emails from my whs telling me the remote access went down and then came back up.
    Thursday, January 8, 2009 11:52 PM
  • Thanks for the help, but I can't find a hosts file.

    But it can't be that hard, is it?
    It always worked.
    I'm talking about my home network.
    So it has nothing to do with my router I guess.
    Remote console doesn't work neither does RDP on LAN.

    Thanks

    Friday, January 9, 2009 4:52 PM
  • That's because it's a system file, and in a hidden/system folder.
    As such, you'll need to enable those options in Explorer (tools > folder options > 'view' tab) in order to browse to it.

    Alternately:
    Start > Run > type C:\windows\system32\drivers\etc\hosts and hit <enter>
    Open the file with Notepad.
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Friday, January 9, 2009 5:09 PM
  • That did it.

    Thank guys!!
    • Marked as answer by Erik Live Friday, January 9, 2009 5:36 PM
    Friday, January 9, 2009 5:36 PM