locked
Trace Directory not defined. Report Server/CRM 2011 RRS feed

  • Question

  • Hi everybody.

    I have a strange problem regarding the MSCRM_FetchDataSource on reportserver. It seems that all my fetchXML reports are not working after a restart of the server. When I check the logs it says "cannot connect to datasource 'CRM' --> Trace Directory not defiened." Also when I manually check the datasource in reportserver i get the "Trace Directory not defined" error message. I tried enabling tracing on CRM server (not the same server as reportingserver), but that did not do anything.

    Its a two server confinguraton, one sql (2008) with reportingserver and one applicationserver (crm 2011 web).  Its CRM 2011 onpreimse with rollup 1.

    Can anybody point me in the right direction?

     

    Cheers.

    Tuesday, May 24, 2011 8:07 AM

Answers

  • Solved it my re-installing the srs-dataconnector if anyone was wondering.

    What caused this in the first place I have no idea.

    Note: I tried this before but my download folder had some strange settings so the installed failed. Moved the install files and it worked fine.

    PS. Uninstall before new install.

    • Marked as answer by Gaute Odin Monday, May 30, 2011 2:43 PM
    Monday, May 30, 2011 2:43 PM

All replies

  • And some additonal information from the logs.

    Invalid Trace Directory. Additional Info:[ Unable to Write file , Trace directory not defined (Reporting Process:File Name is Null. LocalTraceSettings: {Filename:  ,FileCountSuffix:1 ,TraceFileSize:10485760 ,TraceDirectory: ,TracingCallStack:Yes ,IsTracingOff:No ,LoadState:LoadSuccessfulUnreported ,RefreshTraceInt:-1 ,SiteWideRefreshTraceInt:-1 ,RegistryRefreshTraceInt:2} ] , AppDomain:CrmAsyncService)

     

    It says filename is null?

     

    Can it be anything with user permissions or folder permissons?

    Wednesday, May 25, 2011 11:15 AM
  • Try running this script in powershell to set your trace directory:

    Add-PSSnapin Microsoft.Crm.PowerShell
    $setting = Get-CrmSetting TraceSettings
    $setting.Directory="C:\Program Files\Microsoft Dynamics CRM\Trace"
    Set-CrmSetting $setting
    Get-CrmSetting TraceSettings

     

    Make sure you select a directory that exists and the crm account has write access to.


    Gonzalo | gonzaloruizcrm.blogspot.com


    Wednesday, May 25, 2011 11:54 AM
    Moderator
  • I tried it, but no change. I have also enabled trace on the crm application server and this works (trace file gets generated).  This problem is when the reportserver (not the same server as crm-app server) tries to connect via the MSCRM_FetchDataSource. All I get is "trace directory not defined". The reportserver is using NETWORK SERVICE, I have also given full permissions to networkservice and the machinename (reportserver) to the trace directory on the CRM server.

     

    Is there any trace directory on the reportserver also?

     

     


    • Edited by Gaute Odin Wednesday, May 25, 2011 12:22 PM spelling
    Wednesday, May 25, 2011 12:19 PM
  • Solved it my re-installing the srs-dataconnector if anyone was wondering.

    What caused this in the first place I have no idea.

    Note: I tried this before but my download folder had some strange settings so the installed failed. Moved the install files and it worked fine.

    PS. Uninstall before new install.

    • Marked as answer by Gaute Odin Monday, May 30, 2011 2:43 PM
    Monday, May 30, 2011 2:43 PM
  • After spending 2-3 hours mucking with tracing, adding removing accounts etc. I couldn't believe that a uninstall then re-install would work, but it did! It's not a graceful solution by any means, but it works.

     

    Thanks Gaute


    Blog: www.RyanonRails.com Email: Ryan.Michael.Jones@GMail.com Twitter: @RyanonRails
    Thursday, July 14, 2011 7:08 PM