locked
CRM 2011 to CRM 2013 In-Place Upgrade issue RRS feed

  • Question

  • Hi,

    We have started In-Place upgrade on one of our environment. The upgrade process started and after sometime it failed with below error.

    Action Microsoft.Crm.Setup.Server.InstallConfigDatabaseAction failed.
    Incorrect syntax near 'MERGE'.
    Incorrect syntax near the keyword 'AS'.
    Incorrect syntax near 'D'.
    Incorrect syntax near ')'.

    Now again if I restart the Setup, it is unable to start, it is writing the below error in the log. Tried multiple times, restarted the server, downloaded fresh setup from Microsoft site, but no luck.

    Column 'LicenseKeyV6RTM' does not exist on table ConfigSettings

    Cross-checked in the installed programs, the Server component is showing as CRM 2013 even though the setup was incomplete.

    Any thoughts on how to fix this issue?

    Thanks

    Jeevan


    Regards Jeevan Please vote for me if you find the answer is useful.

    Wednesday, December 4, 2013 7:56 AM

All replies

  • what version of CRM 2011 are you upgrading? You've got to have at least UR12 on there, and I would bet that column isn't there in earlier URs.

    The postings on this site are solely my own and do not represent or constitute Hitachi Solutions' positions, views, strategies or opinions.

    Wednesday, December 4, 2013 1:50 PM
  • We had UR 14 installed, I think upgrade cannot be done if we have below UR 14(read in some blog).


    Regards Jeevan Please vote for me if you find the answer is useful.

    Wednesday, December 4, 2013 2:09 PM
  • Was that CRM 2011 system a pre-release system back in the day? the column missing makes me think that there isn't a license key on your CRM 2011 system. Is it CRM for workgroups?

    I'd talk to Microsoft about it, and open a ticket.  It could be as simple as making the column.  If you have the time, it could be worthwhile to install CRM 2011 fresh on a separate system, and see if that column exists in the new database.  If it does, recreate it in your current CRM system and see if the upgrade works (make a backup first!)


    The postings on this site are solely my own and do not represent or constitute Hitachi Solutions' positions, views, strategies or opinions.

    Wednesday, December 4, 2013 10:13 PM
  • Column LicenseKeyV6RTM doesn't exists in other environments also, a column "LicenseKeyV5RTM" exists with License Key but not V6RTM even in other environments.

    I think this a new column that they might have added in CRM 2013 to hold the license key. In my case, first time when we started upgrade, the process failed, but it almost gone through the process, now when we are starting the setup again, it is checking for this new column expecting it as CRM 2013 instance. This is purely my understanding based on how it is behaving, not sure whether it is correct :)


    Regards Jeevan Please vote for me if you find the answer is useful.

    Thursday, December 5, 2013 9:40 AM
  • Did you found a solution for this problem?

    I've the same error messages in my environment...

    Perhaps this is a result of an older migration on my server.

    This is not the first in-place upgrade on our CRM server.

    Monday, April 28, 2014 11:38 AM