locked
LNK1104: cannot open file 'ent.lib' RRS feed

  • Question

  • Hello all,

    Im trying to make an online game using ENet and Cocos2d..

    I defined the include folder and the libs as well everything is good for the server side and it compiled and working 100%

    But when i tried to do the same for client side it gave me this really strange error 

    LNK1104: cannot open file 'ent.lib'

    Things i already tried:

    -checkd if the lib and the include files really exsist

    -deleted the libs and the include folder and tried again

    -restart VS2017 / Windows / Windows File explorer

    -Checked the .lib file permission

    etc...

    Please Help me with this error its driving me crazy since yesterday..

    Thanks in advance 

    Monday, February 12, 2018 11:57 AM

All replies

  • There are two pieces required for libraries. You must specify what the library is but you must also specify where the library is. In the project properties look at the "Library Directories" in the "VC++ Directories".

    This is a common beginner misunderstanding. Certainly there are many previous questions like this with answers.



    Sam Hobbs
    SimpleSamples.Info

    Monday, February 12, 2018 6:51 PM
  • Hi Darhal,

    Welcome to MSDN forum.

    Glad to know that you have solved the problem in the thread.

    Could you please share the solution or suggestions here and mark your reply as an answer which will be helpful for those who has the similar issue with you? Thank you for understanding.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 13, 2018 2:59 AM