none
[adsi]'' fails in powershell but works in ISE RRS feed

  • Question

  • I have a new Windows 2016 domain-joined server running powershell 5. If I type open a powershell window - normal domain user or admin- and run

    [adsi]''

    it returns an error that the server is not operational. If I load ISE and do the same, it correctly returns the domain details.

    This only seems to be happening on this one 2016 server, any ideas? Has something changed?

    Thanks

    • Moved by Bill_Stewart Friday, July 7, 2017 6:10 PM This is not break/fix Windows OS components forum
    Thursday, May 11, 2017 11:19 AM

All replies

  • Are you running both hosts as administrator?
    Thursday, May 11, 2017 11:27 AM
  • The most likely cause is that the firewall is not allowing the application to make outbound calls on the ADSI port.

    \_(ツ)_/

    Thursday, May 11, 2017 11:34 AM
  • You can also try this in case your environment is damaged.

    $dc = $env:logonserver -replace '\\\\'
    [adsi]"LDAP://$dc"


    \_(ツ)_/


    • Edited by jrv Thursday, May 11, 2017 11:39 AM
    Thursday, May 11, 2017 11:39 AM
  • This has the same result.
    Thursday, May 11, 2017 12:01 PM
  • This occurs when running powershell as a domain account that is a member of local admins, or even when run-as a normal domain user. The other host will be just our DCs, which are correctly configured.

    This command works fine even in powershell on a basic user workstation running as a domain user. All users should be able to complete this query to function on the domain really.

    Thanks

    Thursday, May 11, 2017 12:04 PM
  • Try -

    $dc = $env:logonserver -replace '\\\\'
    Telnet $dc 389


    \_(ツ)_/

    Thursday, May 11, 2017 12:05 PM
  • There is no application specific rule blocking just powershell and not ISE.

    Thanks

    Thursday, May 11, 2017 12:07 PM
  • How about no rule allowing PowerShell to connect outbound.

    Have yuo tried to reboot the system?


    \_(ツ)_/

    Thursday, May 11, 2017 12:08 PM