locked
Unable to validate SQL Server Reporting Services Report Server installation. RRS feed

  • Question

  • Hi,
    I'm trying to install the SSRS data connector for my CRM4 implementation.
    I'm using the method described here: http://support.microsoft.com/kb/947060
    (Method 2)
    but keep getting the same error message:

    Unable to validate SQL Server Reporting Services Report Server installation. Please check that it is correctly installed on the local machine.

    I've added the following to my XML file.
        <reportserverurl>http://SSRS-Server/Reportserver$MYORG_MSCRM </reportserverurl>
        <instancename>MYORG_MSCRM</instancename>

    Anyone knows what is still wrong?
    I tried several instance names but they all don't work either.
    I can access my SSRS server by going to http://SSRS-Server/Reports and it will give a list of all services running there.

    Any help would be much appreciated.  
    Thanks!
    Wednesday, June 10, 2009 8:26 AM

Answers

  • Found out from MS that we MUST install the SSRS connector on the SSRS machine. 
    • Marked as answer by ABR1 Friday, July 24, 2009 4:36 AM
    Friday, July 24, 2009 4:36 AM

All replies


  • Hi, 

    Have a read of this. It might help.

    Make sure you have applied the latest rollups.

    Hassan.

    Hassan Hussain | http://hassanhussain.wordpress.com/
    Wednesday, June 10, 2009 8:51 AM
  • I'm using SQL Server 2005 though.  I'll install that hotfix anyway and will post back.
    Wednesday, June 10, 2009 8:55 AM
  • Tried to install the SSRS hotfix, but can't as it says MSCRM Data Connector for SSRS was not found on the system. (of course -- I'm having trouble installing it in the first place!)
    I've installed the CRM one, but the problem still persists :(
    Wednesday, June 10, 2009 9:10 AM
  • Hi,
       In your DVD browse to following link \Server\i386\SrsDataConnector and SetupSrsDataConnector and install it this will get solved. Same Issue even I had faced.

    Note: If your server is 64 Bit then browse \Server\amd64\SrsDataConnector 


    Regards,
    Dyaman
    Wednesday, June 10, 2009 9:20 AM
  • Hi Dyamanagowda,
    That's what I'm trying to do -- install that and I can't get past the System Requirements / Environment Checks stage.
    Wednesday, June 10, 2009 9:24 AM
  • Yes this is frustrating! Even i am having the exact same issues. The actual error message being reported is :

    Check SqlServerValidator : Failure: Could not connect to the following SQL Server: 'mycrmsql01'. Verify that the server is up and running and that you have SQL Server administrative credentials. [DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found.

    This is bizarre because i am installing on the SQL Server itself, the install finds the SQL server as a valid choice on the previous install screen. Reports are currently running. I've just discovered that SSRS was either not installed initially or was uninstalled along the way sometime and now i need it installed.

    Monday, July 6, 2009 2:27 PM
  • Found out from MS that we MUST install the SSRS connector on the SSRS machine. 
    • Marked as answer by ABR1 Friday, July 24, 2009 4:36 AM
    Friday, July 24, 2009 4:36 AM
  • If you changed your install-config.xml file, you are probaly forgetting to run the install with the /CONFIG switch, as noted on the KB.

    D:\your_path>SetupSrsDataConnector /CONFIG .\install-config.xml

    (considering, of course, that you have a named instance on your SQL setup)

    Stay connected!
    • Proposed as answer by Sunil Raheja Thursday, December 9, 2010 4:19 AM
    Monday, September 20, 2010 3:57 PM
  • Changing the install-config.xml (by providing the report server url and the instance name) and then using the command prompt as given above to run the install, did the trick for me..

     

    Thanks a lot

    Thursday, December 9, 2010 4:20 AM
  • Hi to all,

    I'm trying to this using a remote SQL 2008 R2.

     

    on the URL http://server/ReportServer_<instance>, I can see the several xpto_MSCRM, but still can't connect to the report server.


    I've tried to install the connector on the CRM server and on the SQL server, the same error happens.

    Any ideas would be much appreciated.

    Regards.

    Jorge Gomes

    ====== solved =====

    I've changed the install-config.xml and run it on the SQL 2008 R2, and during the installation process I've said to update the installation files. Update Rollup 16 after all installs.

     



    Wednesday, April 6, 2011 11:28 AM