none
Xamarin.Form UWP Local Machine can't connect to WebAPI/HttpClient but Android do RRS feed

  • Question

  • I had upgraded my VS2017 15.2 to VS2017 15.7.5 with use. I am working by Xamarin.Form with .Net Standard. In 15.2 my apps can connect to online WepAPI/HttpClient  and get data into 3 platforms Android, IOS, and UWP. But when I upgraded to VS2017 15.7, I can get data in all platforms except UWP Although there is no syntax error and the app started fine but no data from/to online WepAPI. I searched in the internet I found some solutions:

    1. enable Capabilities in Package manifest  of the UWP project, and check Internet (Client) and Private Networks(Client & Server).

    2. Cleaning the project.

    3. Increasing and Describing Targeting SDK.

    4. Installing all Windows SDK from VS_installer in individual components tab.

    But All these solutions doesn't work for me at all.


    Friday, August 3, 2018 7:59 AM

All replies

  • Hi,

    Since the problem is related to Xamarin.Form UWP, it is out of the scope of UWP forum. I suggest that you might need to ask about this in the official Xamarin Forum.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, August 6, 2018 1:43 AM