locked
Live Mesh disconnects RRS feed

  • Question

  • Hi,

    I've tried searching the forums so I hope this hasn't been asked before. 

    I'm running v 0.9.4014.7 on Server 2008.  When I log into the machine using RDP, the machine will connect to the live mesh service.  If I close the Remote Desktop window to disconnect the session the machine will disconnect from the live mesh service after a period of time and no longer stays in sync with the other devices in the mesh.  From the live desktop it shows as "disconnected".  RDP'ing back into the machine will cause it to reconnect to the mesh.

    Is there a way to keep the machine logged into the mesh, or is it supposed to time out?

    Thanks!

    Friday, April 9, 2010 4:51 PM

Answers

  • I think I found an easier way...

    Exiting RDC without logging off should leave the applications running and the user logged in, but it was timing out.  The default settings for the GPO should have been fine at default, but I went into the security policies and set them manually to make sure it wasn't disconnecting me.  Here's what I did:

    Server 2008 R1 x64 Standard

    1)  Open up gpedit.msc

    2) Go to Computer Configuration->Administrative Templates->Windows Components->Terminal Services->Terminal Server->Session Time Limits

    3) Edit the settings to:

         Set time limit for disconnected sessions = Never

         Set time limit for active Terminal Services sessions = Never

         Set time limit for active but idle Terminal Services sessions = Never

         Set time limit for active Terminal Services sessions = Default

         Terminate session when time limits are reached = Disabled

         Set time limit for logoff of RemoteApp sessions = Default

     

    The default settings should have behaved this way anyway, but after explicitly defining them I've been able to stay logged in for 2+ hours so far.  The key is to disconnect the session (hit 'X' in the Remote Desktop window) and not logging off of the session (Going to Windows start and selecting 'Log off').

     

     

    • Edited by So.CaliGuy Tuesday, April 13, 2010 7:38 PM changed "terminate" to "disconnect"
    • Marked as answer by So.CaliGuy Friday, April 16, 2010 4:29 PM
    Tuesday, April 13, 2010 6:27 PM

All replies

  • First, I'll tell you that running on a Server SKU is unsupported, though you can see that it actually works. What that means, though, is that you can't file bug reports when running on a Server platform.

    That said, how do you know that it actually signs out and stops synchronizing? The only way to *really* know that would be to physically be at that machine to see the status of the notifier and to see if files are synchronizing in both directions. No matter what OS, when the PC starts, the Live Mesh service starts and you can use Live Mesh remote desktop to connect to it and log in. However, the Live Mesh client is not connected, logged in, or synchronizing until you log into the PC. If you log off the PC, the client should also close, though you'll probably find that it is actually still synchronzing despite no user being logged in - that's actually a bug, in my opinion.So, in your scenario, it is behaving as expected. The service starts with the OS, but no user is logged in, therefore no sync happens. Log into the PC via RDP (native Windows RDP or Live Mesh RDP) and the client starts and signs in with the saved LiveID if you selected to sign in automatically. Log out, and it should disconnect from the Mesh, though the machine is still available for Live Mesh Remote connection via another machines notifier/client or via the Live Desktop as the service is still running.

    I hope that helps.

    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Friday, April 9, 2010 7:06 PM
    Moderator
  • Thanks Stephen, what you described is exactly correct, and it's very helpful. 

    When I log off of the RDP session, the Live Mesh client disconnects immediately.  By closing out the terminal window without logging off it will continue to stay logged in to live mesh for a period of time before disconnecting.

    I was able to verify that it really was not syncing (and I assume signing out) because I have another server with DFS replication attached to the first server.  When I place a file into the DFS replicated folder on server 2, it will replicate it to server 1's folder which is shared in the mesh.  When the mesh client is logged in, placing the file in the folder on server 2 will replicate to server 1, and server 1 will mesh/sync it to the live desktop.  When the mesh client disconnects, I can place the file into server 2, it will replicate to server 1, but it doesn't mesh/sync to the live desktop.  That's how I was able to test whether it was actually sync'ing properly with the mesh without logging into server 1.

    The way you detailed it out makes it very clear what's happening.  With that said, is there any way to keep the service logged in indefinitely?  Like you said, this behavior would be the same on any of the Windows OS's.  If anyone were to RDP into a machine, and connect to the service, how would they get it to stay logged into the mesh server after ending the RDP session?

    Also, Live Mesh appears to be working beautifully on x64 Server 2008 Standard R1. 

     

    Friday, April 9, 2010 8:13 PM
  • You're welcome. At this point, no, the only way for the client to be logged in is if you remain logged in on that PC. When not logged in, the PC is available for connection, but no session is running for the Live Mesh client as no user is logged in.

    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Monday, April 12, 2010 1:06 PM
    Moderator
  • I know we're getting way out of the bounds of supported setups but I'm going to need this to work without being logged in, and I'm sure others will too.  I'll try running the Live Mesh client as a service so that it can run without a user logged in.  If anyone has any tips on this I'm willing to listen.  I imagine the tough part is going to be getting it to log into the Live Mesh server with a username and password.  If I have any success I'll post it here.  Suggestions are welcome!

    Tuesday, April 13, 2010 3:30 PM
  • I think I found an easier way...

    Exiting RDC without logging off should leave the applications running and the user logged in, but it was timing out.  The default settings for the GPO should have been fine at default, but I went into the security policies and set them manually to make sure it wasn't disconnecting me.  Here's what I did:

    Server 2008 R1 x64 Standard

    1)  Open up gpedit.msc

    2) Go to Computer Configuration->Administrative Templates->Windows Components->Terminal Services->Terminal Server->Session Time Limits

    3) Edit the settings to:

         Set time limit for disconnected sessions = Never

         Set time limit for active Terminal Services sessions = Never

         Set time limit for active but idle Terminal Services sessions = Never

         Set time limit for active Terminal Services sessions = Default

         Terminate session when time limits are reached = Disabled

         Set time limit for logoff of RemoteApp sessions = Default

     

    The default settings should have behaved this way anyway, but after explicitly defining them I've been able to stay logged in for 2+ hours so far.  The key is to disconnect the session (hit 'X' in the Remote Desktop window) and not logging off of the session (Going to Windows start and selecting 'Log off').

     

     

    • Edited by So.CaliGuy Tuesday, April 13, 2010 7:38 PM changed "terminate" to "disconnect"
    • Marked as answer by So.CaliGuy Friday, April 16, 2010 4:29 PM
    Tuesday, April 13, 2010 6:27 PM
  • Thanks for sharing your findings, So. CaliGuy.

    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Tuesday, April 13, 2010 7:01 PM
    Moderator
  • Alright!  My server has been logged into the Live Mesh session unattended for several days now.  Seems like the above solution of explicitly defining the terminal server's time limits has done the trick.  Hopefully this will help someone else out. 

    Thanks again for your help Steve!

     

    Friday, April 16, 2010 4:34 PM
  • Glad to read that all is well. :-) You're welcome, though I didn't help - you figured it out yourself. <g>

    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Friday, April 16, 2010 4:40 PM
    Moderator
  • I would also be extremely interested in a solution being provided so Windows Live Mesh will sync while not having an account logged into the console. Just figured I'd add my backing to this request.

     

    Thanks

    Saturday, November 27, 2010 10:06 PM
  • I would also be extremely interested in a solution being provided so Windows Live Mesh will sync while not having an account logged into the console. Just figured I'd add my backing to this request.

     

    Thanks


     

    Since you are referring to Windows Live Mesh, not Live Mesh - www.mesh.com, you are in the wrong forum.

     

    For discussion of the new Windows Live Mesh (formerly Sync), (as well as the released Live Sync version) go here:

    http://windowslivehelp.com/forums.aspx?productid=24

     

    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Monday, November 29, 2010 11:58 AM
    Moderator