locked
ocs bpa RRS feed

  • Question

  • Hi, 
    When I run the bpa on my 64bit windows 2008 server and when it comes to the point where it connects to active directory server I get an error back saying "a referral was returned from server" and then it can go no further . However if I run the BPA on the domain controller it connects fine. 
    Also the BPA that is now downloadable from Microsoft does it include the r2 files as when it checks for updates it says there are no updates. Or will I have to use my ocs rc bpa update and copy the files into the ocs 2007 bpa directory?


    Celtic
    Monday, February 23, 2009 4:04 PM

All replies

  • Are you running the original release or R2 version of the BPA?  Also, have you installed OCS in a child-domain?
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Thursday, February 26, 2009 12:25 AM
    Moderator
  • Well I downloaded from the public download bpa site so I would assume that Microsoft would have updated it to R2 version? But when I run check for updates it says there are none. I was afraid that I might have the wrong version so as we are a tap partner I had the R2 updated BPA files from OCS RC and copied them into the specific directory in BPA 2007.
    Yes I am running the BPA in a child domain, but pointing to a AD DC in that child domain. The BPA runs fine when ran directly on domain controller
    Celtic
    Thursday, February 26, 2009 11:01 AM
  • Disregard my first question; I was thinking of the updated BPA for SCMDM SP1 I just dug up the other day.  It looks like there's still only the single version for OCS at the moment.

    When you run the BPA from the OCS server can you verify if it's attempting to connect to a root or child DC when getting that error.  I've seen the same errors in an R2 deployment which is incorrectly querying the root-level DCs for information on child-level objects.  Are all your DCs also Global Catalog servers as well?
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Thursday, February 26, 2009 3:05 PM
    Moderator
  • Hi Jeff,
    It is attempting to connect to the child DC and yes they are GC servers
    Cheers
    Celtic
    Thursday, February 26, 2009 3:35 PM
  • Actually one thing I noticed from the BPA scan is that it listed the Forest as "Windows 2003 ready". The Forest is Windows 2003 but it is Windows 2000 functional level. I didnt spot this until I started the R2 deployment setup program and the deployment check was been done. I would have assumed that the BPA would have picked up on this as I had it ran before I went onsite. It made me look a bit foolish that I hadnt spotted the Windows 2000 AD functional level before but the BPA never picked up on it. I remember before it warning me about an mixed mode envirnoment. I wonder does " Windows 2003 ready" mean its not fully AD Windows 2003 yet. the same as when you buy a tv that says HD Ready when its not the full HD :-)
    Celtic
    Thursday, February 26, 2009 3:39 PM