locked
Live Business Gateway and Office Communicator Server 2007 OCS SIP URI settings RRS feed

  • Question

  •  

    Hi

     

    We are deploying OCS 2007 and LBG on windows server 2003.

     

    We can not get the last part of the puzzle working which is LBG for RCC.

     

    The LBG manual states the following for the SUP URI

     

     

    Enter the unique line server information for this ICP using the following format:

    sip:<username>@<PBX name>.<LBG name>.<FQDN>

    For example, sip:LBG @PBX1.LBG1.mitel.com where ’LBG’ is a generic service name that is common to all users , ’PBX1’ is the unique name of the 3300 ICP, ’LBG1’ is the unique name of the Live Business Gateway associated with this ICP, and the FQDN ’mitel.com’ is specific to the Live Business Gateway

     

    My question concerns the domain element referred to above as the FQDN.

     

    I have an internal domain of internal.local and my email (and sip) domain of external.com. Now should that sip uri be either

     

    Sip:lbg@pbx.lbgserver.internal.local or sip:lbg@pbx.lbgserver.external.com

     

    But there is one more thing I have noticed and that is that the mitel docs state that the fqdn should be the specific domain  the lbg server is residing on. Do they mean that the lbg server should be on its own domain with its own fqdn away from active directory. I noticed in a screen shot in the ocs 2007 resource kit that they were using mitel.com in the properties of the user uri. Could this be what I am missing? I don’t want to tear down the lbg server just yet and have tried a lot of different combinations so any help or pointers would be really welcome. I have checked the logs on LBG and it looks like green lights all the way it does not yield very useful information.

     

    Thanks in advance

     

    Andrew

    Saturday, August 30, 2008 8:16 AM

All replies

  • Andrew,

     

    I'm not aware of the Mitel's specific configuration requirements, but to answer your first question the FQDN needed in the Server URI field should simple be the name that the LBG is reachable on via DNS, it's not a SIP or AD domain it is looking for, but a DNS name simpkle for resolution and IP lookup.  Is that server in a seperate AD domain, or just a workgroup?  If it's in a workgroup, I'd suggest giving it a valid FQDN in a DNS domain namespace that you already control (e.g. server.dmzdomain.local) or some internal namespace.  I wouldn't attempt to rely on short-name resolution for that.

     

    Monday, September 1, 2008 12:59 PM
    Moderator
  • I also am trying to get this setup and not making much headway with the doc's. My mitel doesn't have a name the network knows. I would appreciate any help in filling in the sip url requirements for the integration. Thanx

     

    Friday, November 21, 2008 1:45 AM
  •  

    Hi Michael

    Well its almost the end of November and we have still not deployed OCS to our users yet because of issues around video which we are working hard on.

     

    In terms of the LBG issue and RCC this suddenly burst in to life one day, and as someone who has spent numerous hours on this I think it is only fair that I share my knowledge with you, as when it did start to work it came as quite a surprise to all involved. Mitel I have decided are about as useful as a chocolate fireguard on the documentation front, and I think we may even have had the correct config on numerous occasions but the lack of a reboot stopped it from working.

    Please note all of the below is provided as is and I make no guarantees or warranty as to its suitability and accept no liability.

    Here’s a quick breakdown of what I know           

    In your Mitel make sure it has a DNS name and knows where your internal DNS servers are and what the domain name is, this can be found in the pbx config under IP network configuration – system ip configuration. Remember you may never have needed this before because everything was being driven by IP but now you are going to start using DNS and resolution to find resources

    Make sure you internal DNS server knows the name and IP of your Mitel, the entry should match the hostname in the PBX config, you may need to create a record manually

    On the Mitel 3300 you also need to create a user that has the type of application, simply configure this as lbg as the user name and set a simple password to avoid typo’s you can make it more complicated later

    I strongly advise you run LBG on its own dedicated server – not because it works hard it just makes life easier in solving issues

    In the LBG software the tabs have the following values:-

    Live Business Gateway Tab

                    Ip address  - this should be the ip of the server LBG is running on

    Port- 5060

    On the ICP tab

    The ip address field should be the ip of the 3300

    The remote call control field should be sip:lbgserverdnsname@mitell330dnsname.domain.local

    Or to break that down if you server running lbg is london1, your domain is acme.local and the dns name of your 3300 is pbxlondon it would look like this

                    sip:london1@pbxlondon.acme.local

     

    Obviously if you are using a domain name of acme.com internaly it would be sip:london1@pbxlondon.acme.com

     

    The ESM username and password are what you entered in to the 3300 to allow the lbg application level access to the 3300 (this point is documented I think)

    On the active directory tab you need to configure access to ad with the domain name either acme.local or acme.com depending on your environment and an account that has access to the domain at the relevant level (assume domain admins group member but thats for you to decide)

    On the digit mod, thats for another day and is reasonably useless and orders things in it own way effectively ignoring any rules you create ! And the log is yet another pointless exercise in Mitels inability to produce anything half decent in terms of diagnostic information.

    So now you need to move your focus to the OCS config

    Go to the front end server role and open the properties of the front end you should see a routing tab

    Create routing rule in the following syntax

    Pbxdnsname.domain.local (or .com depending on your network)

    So ours would look like pbxlondon.acme.local

    The ip address is the ip address that LBG is running on

    The port is 5060

    Now go to the host authorization tab

    Select ip address (not FQDN) – enter the ip address of the server running LBG

    Select throttle as server and treat as authenticated - do not select outbound only

    OK that and close it

    (still with me, haven’t decided yet to run off and join the circus, or give up the whole project as a bad idea and quit, come on its a breeze all this infortion is so readily available who would have thought it was so easy ? )

    If you have your front end server selected and look at the righthand pane you should see under the uri information something like SIP.*@pbxlondon.acme.local now.

    Can you fix it – yes we can in the words of bob the builder

    So now we need to look at how we identify the users that will be RCC enabled and make sure they have the right syntax

    So now lets go to AD, enable or edit a user for communications server and configure them

    I am going to assume the sign in name and IM etc are all fully working in your domain and you generally have OCS working

    On the communications tab of the AD user object under additonal options - configure, this takes you to the next screen and the information you should have here should be:-

                    Enable remote call control (obviously as that’s what we want to work)

     

    Server uri this should be in the syntax of the following:-

                    sip:lbgseverdnsname@pbxdnsname.domain

     

    so in our example this would look like sip:london1@pbxlondon.acme.local

    Line uri this should be tel:xxxx;phone-context=mitel.com

    Now that really is the black magic moment because your now asking yourself – why am i using mitel.com it does not exist anywhere ???? and you are completely right – I believe this just tells it what context to communicate in – e.g. your using mitel lbg so mitel.com is the context - nothiong to do with dns, domains or anything.

    xxxx is your phone extension for example 9058 if thats your phone extension – watch out for the colon and the semi – colon in the line uri. (telcolon9058semicolonphone-context=mitel.com

    Now if I was a betting man I would say it should burst magically in to life, but it wont so don’t bet, reboot your servers (front end ocs and server running LBG) and then when it is convenient (*** just do it and blame it on your telephone company like I do) reboot the pbx. It should all things being equal work.

    I will keep my fingers crossed for you, and I must stress that this is not all my own work, we had considerable input form a very good partner, and access to some people close to the ocs roadmap at Mitel (allbeit it was like pulling teeth) . Please let me know how you get on. I would have responded sooner but the whole morning has been spent on a long standing OCS video  issue, which was delayed due to the highly inaccurate and contradicting documentation from MS. Trust me you cannot NAT the AC EDGE internal iP address, I have found out the hardway despite some MS documentation saying otherwise – but you can in R2 which is good to know even though I don’t have R2 or the budget to do it – bitter never – especially when MS claims the no NAT was an industry thing and not something they dreamt up but has mysteriously disappeared in the next version  !

    It would be nice to know your email address and hopefully exchange suggestions /comments / war stories from the front line if this is something you are working on closely/frequently, especially with R2 round the corner and a whole new world of pain waiting for us all.

    Good luck !
    Andrew

    Friday, November 21, 2008 4:25 PM
  • Hey Andrew nice post it finally helped me make some headway in my battles between lbg and ocs. No where did I once find anything that said hey check your dns on your mitel. Once I updated that I have made some progress but hit another roadblock,hopefully someone else will have had a similar issue. When making calls from communicator it works great or seems to at first I can dial from communicator and the caller will get the call and anser however thats where things seem to differ from what should happen. Everything seems fine for about 30 seconds then I get an error in communicator that the number is unavailable at which point I can do nothing with the call from communicator. During the first 30 seconds I can place the call on hold from communicator but I am unable to take it off hold and then I get the number is unavailable.

    Also when setting call forwarding I get an error right away saying cannot apply your new call forwarding settings. To turn off call forwarding, click OK. To ignore this error click cancel. If I click ok  it turns off the forwarding if I click cancel the forward actually works.

    Im hoping this is just because the mitel is down level a bit but its on the minimum required for supporting lbg. I'm hoping to update it soon but unfortunatly I cant just go ahead and do it

    Monday, December 29, 2008 10:26 PM
  • hOW DO YOU FIX THE ERROR
    "Cannot apply your new call-forwarding settings. To turn off call forwarding, click OK. To ignore this error, click Cancel."

    thANKS
    Monday, May 25, 2009 4:18 AM
  • Hi CasionGuy

    Is there a fix for this "Cannot apply your new call-forwarding settings. To turn off call forwarding, click OK. To ignore this error, click Cancel", how did you deal with the problem, was it solved

    THnaks
    Tuesday, May 26, 2009 1:38 AM