locked
404 when verifying web components RRS feed

  • Question

  • I have recently set up a Office Communications Server 2007 R2, and I'm struggeling to make things run smoothly.
    The Office Communicator informs me that it is unable to synchronize with the adress book, and from a bit of Googling this is for the same reason that I'm getting a 404.

    Normally this shuold be a certificate error, but I've tried both applying and re-applying the current certificate (which I believe is correct) but it does not help. Nor did adding DisableLoopbackCheck=1 to the registry do anything.

    I've tried looking for the folder (or VirtualFolder) that reports 404, but I'm unable to locate it - have I missed something during install or are there any quick tips for restoring this folder? Please help.

    The failure first shows up in the log under the "Check Http URL" and looks like this:

    URL: https://servername.domain.no/GroupExpansion/Int/service.asmx
    Received a failure HTTP response.: HTTP Response: 404 Not Found
    Content-Length:2698
    Cache-Control:private
    Content-Type:text/html; charset=utf-8
    Date:Mon, 17 Aug 2009 10:39:32 GMT
    Server:Microsoft-IIS/7.0
    X-AspNet-Version:2.0.50727
    X-Powered-By:ASP.NET

    Server Error in '/' Application.

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.


    Requested URL: /GroupExpansion/Int/service.asmx

    Version Information: Microsoft .NET Framework Version:2.0.50727.4016; ASP.NET Version:2.0.50727.4016

    Received a failure HTTP response.: NotFound
    Suggested Resolution: Check whether the Web Server or Office Communications Server component is running and also listening on the specified url. If server is behind a load balancer, please make sure the loopback connection is allowed from load balancer FQDN.
    Suggested Resolution: Check the Web Proxy setting in this machine and ensure that it is correctly configured
    Monday, August 17, 2009 10:45 AM

All replies

  • If you manually attempt to browse to the website address above I assume you run into the same issues? OCS uses basic IIS functionality so if you are unable to view the ewb addresses using IE the application will fail (you should receive a response similar t below). Is the server name you receive in the above warning correct?

    Live Server Distribution List Expander

    This web service expands Exchange Distribution lists

    The following operations are supported. For a formal definition, please review the Service Description.


    Brian Ricks, MCSE, MVP BriComp Computers, LLC http://blogs.bricomp.com/blogs/uc/default.aspx
    Monday, August 17, 2009 11:02 AM
  • Yes, the server name is correct. It appears that the GroupExpansion, Abs and etc folders are missing. I found the Group Expansion folder in OCS' Web Components folder, but adding this as either a virtual folder or application gives me error 500, and I'm unsure where - if anywhere - the other two folders are to be found.
    Monday, August 17, 2009 11:25 AM
  • Hi

    Per your description, you are deploying the OCS 2007 R2 Enterprise Edition, right? About the issue you referred, here is some suggestions for you.

    1.     According to you said: the GroupExpansion, Abs and etc folders were missing. So, you should make sure you had created the give shared folders for ABS and so on. And make sure the account using the share folders has the proper permission. You can refer to below link:

    http://technet.microsoft.com/en-us/library/dd425133(office.13).aspx

    2.     When you created the pool, did you type the UNC paths for the specify locations of miscellaneous server stores. Such as Address Book Server File sore and so on. You can refer to below link:

    http://technet.microsoft.com/en-us/library/dd441252(office.13).aspx

    In OCS 2007R2, the ABS is configured automatically. You also manage the ABS and change the settings by other ways. You can refer to below link:

    http://technet.microsoft.com/en-us/library/dd573019(office.13).aspx

     

    Hope this helpful!

    Regards!

     

     

    Monday, August 24, 2009 5:42 AM
    Moderator
  • Hi, Gavin.

    This is a OCS 2007 R2 Standard Edition, not Enterprise.
    Could anyone using a working R2 SE please show me how their IIS is configured, and which users/groups they're using?

    As far as I can tell from my mapping in IIS, the files exist, but the verifying tool still gives me a 404.
    Monday, September 21, 2009 9:31 AM
  • Has your setup/environment ever worked? While it is possible that manually creating the IIS virtuals and setting the permissions, if you have never been up and functioning I would worry that the setup did not complete correctly and wonder what else may be missing. In the temp directory of the account that installed OCS on the server (%temp%) look for the setup logs for OCS. You may also re-run setup and see if the installation is listed as Partial or complete.
    Brian Ricks, MCSE, MVP BriComp Computers, LLC http://blogs.bricomp.com/blogs/uc/default.aspx
    Monday, September 21, 2009 9:42 AM
  • Hi, Brian.

    No, the setup/environment has never worked as I wanted it to, yet the installation does not list anything as partial or incomplete. I'm thinking of just removing every last bit of OCS and starting over again. Is there any way I can go back to scratch, and remove any indication from AD that there's ever been an OCS server in the domain?

    Monday, September 21, 2009 9:51 AM
  • Deactivating the server should provide the results you are looking for. Deactivation cleans up AD from a server role perspective. Your user accounts/groups will still be present. It is possible to manually delete these groups and the run the Prepare Active Directory again (Forest Prep/Domain Prep) to recreate the groups and set the rights. The schema prep of course cannot be undone without perfoming a restore from some backup medium prior to the extension. Let us know if the setup works the second time around.
    Brian Ricks, MCSE, MVP BriComp Computers, LLC http://blogs.bricomp.com/blogs/uc/default.aspx
    Monday, September 21, 2009 10:08 AM
  • Something when really, really, really wrong when uninstalling. I'm unable to reinstall OCS, I'm unable to reinstall MSSQL Express. So the whole server is pretty much fubar, and in dire need of a reinstall.
    I've spent too many hours on this today, and my head is boiling so I'll try to continue my OCS adventure tomorrow. I still can't believe how unintuitive the whole OCS install process is.
    Monday, September 21, 2009 11:53 AM