none
How do I make Visual Studio 2013 use my dedicated graphics card instead of integrated graphics on my laptop? RRS feed

  • Question

  • I am using Alienware 13 as a portable workstation. I do game development on Unreal Engine 4 using Visual Studio 2013. The issue I am having is that when I want to debug codes in Visual Studio 2013, it launches Unreal Engine 4 through the debugger and uses the integrated graphics card rather than my dedicated graphics card, which is an nVida Geforce 860M.

    When I wanted to change the settings in the NVidia Control Panel, I see this:

    The drop-down menu is grayed out, so I cannot select to change the graphics card to my dedicated card.

    What should I do? How do I make it so that Visual Studio uses my dedicated card? Thanks in advance.

    • Moved by Tina-Shi Wednesday, April 1, 2015 3:24 AM the issue is not the VS IDE
    Monday, March 30, 2015 1:32 AM

Answers

  • After contacting with NVidia Support directly, they said that "the application itself that does not support Optimus or the application does not have the profile to support Optimus". They also said, and I quote:

    "Since you already have the latest driver installed, also, we tried with NVIDIA inspector tool and the issue is still there, it appears to be application specific issue. If it was an issue related to graphic card / drivers, you would have faced the issue with many other games as well. So I would suggest you to contact the application developer once again and let them know the same."

    It may seems I need to file a feature request, which is awkward since it hampers game development in a way. Before I do that, is there anything else I could do?

    EDIT:

    I submitted a bug report to Microsoft Connect here.

    Tuesday, March 31, 2015 10:46 PM

All replies

  • Hi tom_mai78101,

    Thank you for posting in the MSDN forum.

    It seems that it is not the correct forum for this issue, since this forum is to discuss Visual Studio WPF/SL Designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System, and Visual Studio Editor.

    As you said that you want to change the setting so that Visual Studio uses your dedicated card in NVidia Control Panel, since this NVidia Control Panel is third-party tool, we are not support it. So please post this issue this issue directly to this NVidia Control Panel Official website: http://www.nvidia.com/object/nvidia-communities.html , you will get better support.

    Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    • Edited by Tina-Shi Tuesday, March 31, 2015 3:18 AM
    Tuesday, March 31, 2015 3:18 AM
  • Once I received an answer from NVidia, I will post a reply here. Please do not mark or propose an answer for me before then, because I wanted to get this solved correctly in the intended forum format.

    Thanks.

    Tuesday, March 31, 2015 5:12 AM
  • After contacting with NVidia Support directly, they said that "the application itself that does not support Optimus or the application does not have the profile to support Optimus". They also said, and I quote:

    "Since you already have the latest driver installed, also, we tried with NVIDIA inspector tool and the issue is still there, it appears to be application specific issue. If it was an issue related to graphic card / drivers, you would have faced the issue with many other games as well. So I would suggest you to contact the application developer once again and let them know the same."

    It may seems I need to file a feature request, which is awkward since it hampers game development in a way. Before I do that, is there anything else I could do?

    EDIT:

    I submitted a bug report to Microsoft Connect here.

    Tuesday, March 31, 2015 10:46 PM
  • Hi tom_mai78101,

    Thanks for your reply.

    Since this forum is discuss this VS IDE issue, so I am moving your question to the moderator forum ("Where is the forum for..?"). The owner of the forum will direct you to a right forum.

    Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, April 1, 2015 3:23 AM
  • Thanks again.
    Wednesday, April 1, 2015 6:03 AM
  • You could submit feedback on connect.microsoft.com

    https://connect.microsoft.com/VisualStudio

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Thursday, April 2, 2015 1:25 AM
    Moderator
  • Friday, April 3, 2015 6:24 AM
  • Is there any updates on this matter?
    Sunday, April 12, 2015 8:24 PM
  • Feedback would not be presented here in "Where Is" forum. I'd look for it over here.

    https://connect.microsoft.com/VisualStudio

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.


    Sunday, April 12, 2015 9:00 PM
    Moderator
  • Alright, thanks again.
    Monday, April 13, 2015 4:34 AM
  • You can go to the control panel and go to the graphics and select the nvidia graphics now go to the advance setting click to the adjust Image Settings with Preview, select Use my preference emphasizing: Performance and click Apply.Click on Manage 3D Settings and open the drop down menu for Global Settings. Select the High-performance NVIDIA processor as your preferred graphics processor and click Apply. Now drop down the program setting and add the location of the program and select the high parformance the nvidia prcesser.visit my page for more informating .
    Wednesday, November 6, 2019 6:09 AM