Body must be 4 to 60000 characters error? RRS feed

  • Question

  • Ok, now that my Alerts are fixed, any time that I try to response I get the error:

    "Body must be 4 to 60000 characters" error -- problem is, the body IS more than 4 characters and is less than 60000 ??  So why am I getting this error?

    Thursday, April 2, 2009 3:32 PM


All replies

  • Rob, we've had a few reports of this.

    Which of the following happens for you after you hit reply?
    1. You stay on the same page and are shown a Text Editor (box with B I U buttons at the top)?
    2. You stay on the same page and a TextArea is show (box with no toolbar at the top)?
    3. You are navigated to a new page with that has a TextArea on it?

    Also, which browser/platform are you using? And if it's #2 above, do you notice any javascript error notifications?

    If you have difficulty replying to his message, you can Right Click on the Reply button and open in new tab/window and you should be able to enter/submit the reply from there.

    Rob J, Forums Dev
    Thursday, April 2, 2009 4:26 PM
  • Definitely NOT 3.  Not sure if it is 1 or 2?

    What happens:

    Hit Submit
    Stay on the same page
    A message box (separate window not page) is displayed with Title = "Windows Internet Explorer", a Close button (top right), in the message box window I have the caution icon on the left with text centered that says "Body must be 4 to 60000 characters long.", and an OK button.
    Ok just returns to page and nothing is submitted.

    IE7 on Vista x64.

    Thursday, April 2, 2009 4:39 PM
  • Ok.. follow ups.

    1. When doing your reply to this, did you use the normal way or did you right click reply/open in new window?
    2. Just after you hit reply, directly above the text area to type in, do you see a toolbar with Bold/Italic/Underline and some other options?

    Trying to narrow down, since you are able to reply to this, what the difference is. What thread (url) are you trying to reply to that you get the error?
    Rob J, Forums Dev
    • Proposed as answer by 欧光 Tuesday, September 6, 2011 10:46 PM
    Thursday, April 2, 2009 4:48 PM
  • I click on the standard Reply (with green arrow pointing left).  I do NOT get the B I U toolbar like I do with this reply.
    Thursday, April 2, 2009 5:01 PM
  • Can you post a url/link for one of the threads you try to reply to that you do not get the toolbar? Seems like it's going to be something specific to certain threads.

    Rob J, Forums Dev
    • Proposed as answer by 欧光 Tuesday, September 6, 2011 10:46 PM
    Thursday, April 2, 2009 5:08 PM
  • Great, I can repro on IE, works ok for FF. There must be some not-so-great html in one of the posts as I see formatting messed up in a couple spots. I'll see if I can fix the post up for now and we'll have to work on the underlying issue.
    Rob J, Forums Dev
    Thursday, April 2, 2009 5:19 PM
  • Ok, I cleaned up the offending post. This thread should be fixed now.
    Rob J, Forums Dev
    Thursday, April 2, 2009 5:32 PM
  • I think I've got some support evidence for this.  Occassionally I've seen the "naked" post editor pop up when I click the Reply button.  I just click Back, then Reply again and get the in-line editor.  It never consistently brought up the wrong editor.
    Hans Passant.
    Thursday, April 2, 2009 5:43 PM
  • Yep, that fixed it.

    Thursday, April 2, 2009 6:09 PM
  • Hans, this one would be consistent as there was an unclosed font tag in a post that messed up the rest of the page. Your case sounds like potentially a JS issue since back would effectively reinit the page js. If you happen to get the textarea only, check to browser status bar and see if there are any javascript error/warnings.
    Rob J, Forums Dev
    Thursday, April 2, 2009 6:17 PM
  • No script errors visible.  Happens on un/proprose answer too.  I had one thread that brought up a separate page 5 times in a row.  Clicked the Back button 5 times.  Enabled Firebug, which refreshes the page too, then it worked.
    Hans Passant.
    Friday, April 3, 2009 9:35 AM
  • I have noticed one thing, when I get textarea only.

    That is if page is not loaded fully and I hit reply, it gives a page with textarea only.

    Arjun Paudel
    Saturday, April 4, 2009 10:18 AM
  • Arjun, you are correct that until the page loads, the default action for the links is to go to an actual url. It's only after the pages script executes that the link actions are attached to their script based behaviors.
    Rob J, Forums Dev
    Monday, April 6, 2009 4:58 PM