locked
Using SDK Web Services and plugins on multiple servers RRS feed

  • Question

  • Hi all..

     

    I have a puzzling error. We're working on a CRM installation each of the following configured on a separate server:

        Server1: Application Server(CRM Web Server hosting the front end)

        Server2: Platform Server(workflows, email services, CRM Web Services used for SDK)

        Server3: SQL Server and SRS

    There are also several plugins registered which have been placed by CRM on Server1.

     

    Now, I have a VS project connecting to CRM via the SDK services on Server2 and adding a new record to the account entity. On the create command I encounter this soap exception: "0x80044191 Assembly can not be loaded from C:\Program Files\Microsoft Dynamics CRM\server\bin\assembly\MyOrganisation.Plugins.dll. Platform". I guess CRM is referring to this file since there is a plugin executed on adding a new record to this entity. That's fine, but the issue is that this file actually exists on Server1(Application Server). Not Server2(Platform Server + SDK Web Services).

     

    I hope that makes sense to somebody who can help?? Thanks heaps.

    Sunday, August 24, 2008 1:54 PM

Answers

  • If the plug-in is registered with the source on disk (rather than in the database), then it will need to be deployed on every platform server (not the application server)

    Monday, August 25, 2008 7:26 PM
    Moderator

All replies

  • The common reason for error 0x80044191 is your custom code issue, try to debug it.

     

    Jim

    Monday, August 25, 2008 8:09 AM
    Moderator
  • Thanks Jim,

     

    I know that the code returning this error is fine. Its only about 6 lines of code that works on the standard MS virtual image. Do you mean there could be other custom plugins registered on the entity that could be causing this?

     

    Monday, August 25, 2008 2:19 PM
  • If the plug-in is registered with the source on disk (rather than in the database), then it will need to be deployed on every platform server (not the application server)

    Monday, August 25, 2008 7:26 PM
    Moderator
  • That the ticket! thanks David. We re registered the plugins on database and all is well instantly.

     

    Wednesday, August 27, 2008 7:49 AM