locked
Firewall blocks home network RRS feed

  • Question

  • I have three PCs on a home network using Vista and Windows Live OneCare but they can't see each other unless I disable the firewall. What am I doing wrong?

    Friday, January 25, 2008 10:16 PM

Answers

  • Open OneCare on each PC and click on Change Settings. On the firewall tab, click on Configure Network and make sure that only one network is shown as connected and active and that it is identified as Home or Work and not Public.

    -steve

     

    Saturday, January 26, 2008 2:45 AM
    Moderator

All replies

  • Open OneCare on each PC and click on Change Settings. On the firewall tab, click on Configure Network and make sure that only one network is shown as connected and active and that it is identified as Home or Work and not Public.

    -steve

     

    Saturday, January 26, 2008 2:45 AM
    Moderator
  • And what if not all the PCs are running OneCare? Seems like the Firewall is little over protective.

     

    Sunday, January 27, 2008 5:00 PM
  • A PC not running OneCare that can't be accessed by a machine running OneCare means that Sharing on the target machine has not been configured to allow access.

    The firewall is designed to prevent File and Printer sharing unless you are on a private network and you have explicitly allowed it by setting up Shares. That's the job of any decent firewall.

    -steve

    Monday, January 28, 2008 1:29 AM
    Moderator
  • Not true. I have other machines that can access the shares just fine. Also, the situation is the other way around. The PC running OneCare can access the machine not running OneCare. The machine not running OneCare cannot access the machine running OneCare. The only way it works, is if I turn off the firewall or set the firewall to allow access to internet machines. Both machines are getting their IPs from the same DHCP server and both machines are hooked up to the same wireless access point.

     

    Monday, January 28, 2008 12:54 PM
  • Back to OneCare on the machine that can't access the other PC - open OneCare, change settings, firewall tab, configure network. It must be Home or Work in order for File and Printer Sharing to work with any other PC on your network. There is also an issue where OneCare locks down the firewall when it is on a Public network - if you have multiple active network connections listed, the firewall is locked down in most cases.

    Try the advanced settings for the firewall and place a check mark next to File and Printer Sharing Internet.

    -steve

     

    Monday, January 28, 2008 1:26 PM
    Moderator