locked
How to refresh disk information on new disk RRS feed

  • Question

  • I have a 160G SATA drive which used to be part of a RAID 0.1 pair and I want to wipe it and put it in my HP EX495 as a server backup drive.  I assume the fact that it was part of a RAID means that the drive doesn't have a partition table.  When I put it in the HP495 the first time and told it I wanted to use it as a backup drive it told me it wasn't initialized and I'd need to restart the server.  It also seems to think it is a 230G drive and has a volume name with RAID in the name.  So I took the drive out of the HP495 and put it in another Windows 7 machine and repartitioned and reformatted the drive and gave it a volume name of "backup".  Figuring I was all set I put the drive back in the HP495 and in the drive list it still shows up as a 230G drive with RAID in the volume name!  So it appears that the HP stored (incorrect) information about the raw drive somewhere and doesn't see that this information is out of date.  Any idea how to update this information?  The refresh button on the drive list didn't change anything.
    Sunday, December 13, 2009 6:08 PM

All replies

  • you could try putting it in the windows 7 computer and go to computer management and delete the partion, then put it in the Home Server and see if it show right then.
    HMG
    Sunday, December 13, 2009 7:37 PM
  • That didn't work.  Things have gotten even weirder - I took that drive and put it in an external ESATA enclosure and hooked it to the HPEX495 and was able to configure it as a server backup drive just fine.  So I figured the machine now has updated information on the drive, so I took it out of the external enclosure and put it back in the top internal bay of the EX495 thinking it'd work now.  Nope, the disk management console still thinks the drive is the RAID volume with the wrong disk size.

    So I'm back to my original question - how do you clear out the information WHS has obviously stored about a given disk drive so it can discover the correct information?
    Sunday, December 13, 2009 9:04 PM
  • There's a number of programs (free) that can write zeros to the entire hard drive.  One is available from Western Digital called "Data Lifeguard Diagnostic for Windows".  This should remove anything left on the drive.
    Sunday, December 13, 2009 9:54 PM
  • I don't think this is a matter of what's on the hard drive itself, it's a matter of what the WHS System Drive seems to store about it.  The 160G drive itself is just fine and has been formatted, the old information can only be seen when it is installed in an internal drive bay of the HPEX495.
    Sunday, December 13, 2009 10:46 PM
  • Have you tried restarting the server?
    I'm not on the WHS team, I just post a lot. :)
    Monday, December 14, 2009 3:49 AM
    Moderator
  • Multiple restarts haven't solved the issue.  If I put the same drive in an external enclosure it shows up correctly and I've even backed up the server to it, but if I then take that drive out of the external enclosure and put it back in an internal bay the description goes back to the RAID description.  It is clear that WHS is keeping some info about the drive that isn't being refreshed based on a unique hardware id on the drive.  I'd just like to find out how to clear that information and start using that drive fresh.
    Thursday, December 24, 2009 3:57 AM
  • Hi Steve,
    did you try the method from FAQ How to reinitialize a disk, which is not accepted for the storage pool?
    Best greetings from Germany
    Olaf

    Thursday, December 24, 2009 6:59 AM
    Moderator