Sync Framework 64bit "Attempted to read or write protected memory." RRS feed

  • Question

  • We're encountering an infrequent exception in our application on the 64bit platform only.  We're using MS Sync Framework V2 CTP1 with a custom provider and the standard SQLCE metadata store.

    Is this something solved in CTP2, or a known issue?  We've already installed, removed and re-installed the framework with no effect.

    <TraceRecord xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord" Severity="Critical"><TraceIdentifier>http://msdn.microsoft.com/TraceCodes/System/ActivityTracing/2004/07/Reliability/Exception/Unhandled</TraceIdentifier>
    <Description>Unhandled exception</Description>
    <ExceptionType>System.AccessViolationException, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089</ExceptionType>
    <Message>Attempted to read or write protected memory. This is often an indication that other memory is corrupt.</Message>

    at Microsoft.Synchronization.MetadataStorage.IReplicaMetadata2.GetFilteredChangeBatch(UInt32 dwBatchSize, ISyncKnowledge pSyncKnowledge, ISyncFilterInfo pFilterInfo,
    at Microsoft.Synchronization.MetadataStorage.SqlReplicaMetadata.GetFilteredChangeBatch(UInt32 batchSize, SyncKnowledge destinationKnowledge, FilterInfo filterInfo, ItemFilterCallback filterCallback)   IChangeBatchCallback pCallback, ISyncChangeBatch&amp;amp; ppSyncChangeBatch)

    ... (log editted for berevity and privacy)
    • Moved by Max Wang_1983 Thursday, April 21, 2011 11:59 PM forum consolidation (From:SyncFx - Microsoft Sync Framework Database Providers [ReadOnly])
    Thursday, August 13, 2009 8:21 PM


  • Hi Mark,

    CTP2 has had a lot of changes and without knowing your exact usage scenario it would be hard to pinpoint similar bugs. I know we did do a lot of work in CTP2 around the general perf of the system and the AV is usually an indication of a bug. Best way to find out is to install the CTP2 on a test machine to verify if the problem is solved or not. In case you see it reproing on CTP2 as well then please post back with a detailed explanation of scenario and when and how you see this AV.

    Maheshwar Jayaraman - WCF -- http://blogs.msdn.com/dotnetremoting
    Friday, August 14, 2009 1:18 AM