locked
Location of WLW settings/configuration - How to sync WLW between 2 computers? RRS feed

  • Question

  • I am blooging from my laptop and from my office desktop machine...

    I currently have WLW on my office desktop configured as i want, with all blogs (20+) i post to, with corrent settings, all the plugins etc...

    Now, I would like to use live sync, to sync all configuration (wordpress blogs, user,pw data, paths, themes) and posts, drafts, history of each blog with WLW installation on my laptop...

    How to do this simply and efficiently?

    Sunday, January 25, 2009 10:50 AM

Answers

  • If you want to confirm what is in the backup, rename the backup file from .wlwbackup to .cab and open it with something like winrar. The actual blog settings are .reg files as they have been backed up from the registry.
    SL - Windows Live Platform MVP
    • Marked as answer by MojMikro Wednesday, January 28, 2009 3:53 PM
    Wednesday, January 28, 2009 3:09 PM

All replies

  • The blog posts are in a folder in your documents folder called "My Weblog Posts", and your plugins are in c:\program files\windows live\writer\plugins" so you should be able to sync them just fine. Unfortunately, all the blog settings are stored in the computer's registry, so you wouldn't be able to sync them. However, rather than trawl through the registry to try and save your settings, I do provide an alternative method with my Live Writer Backup Utility http://scottisafooldev.spaces.live.com/blog/cns!FE151030F50B5B37!556.entry.
    SL - Windows Live Platform MVP
    • Marked as answer by MojMikro Monday, January 26, 2009 12:10 PM
    • Unmarked as answer by MojMikro Wednesday, January 28, 2009 3:05 PM
    Sunday, January 25, 2009 12:18 PM
  • Hey Scott! Great program! Will definitly help me to start and maintain same status...

    I will sync data folders, but for registry .... well, after i add all blogs/changes, hopefully changes will not be that frequent.

    My wishes for future of WLW still include easy sync between many computers (including settings - maybe registry is not the best place for them?)

     

    cheers and thanks again,

    Jaka

    Monday, January 26, 2009 12:12 PM
  • Scott,

     

    update... after installing your program, and transferring the backup to my other computer, and restoring it there... looks like everything is restored, with exception of my blog data (all blogs i had configured)... Can you or anyone verify this?

    Any solution?

    Btw- did you maybe try the WLW portable ? is this a solution as well?

     

    thanks,

    jaka

    Wednesday, January 28, 2009 3:05 PM
  • If you want to confirm what is in the backup, rename the backup file from .wlwbackup to .cab and open it with something like winrar. The actual blog settings are .reg files as they have been backed up from the registry.
    SL - Windows Live Platform MVP
    • Marked as answer by MojMikro Wednesday, January 28, 2009 3:53 PM
    Wednesday, January 28, 2009 3:09 PM
  • Ha!

    Followed your advice.

    In .cab there was a .reg file as well..

    I extracted it, double clicked onit, confirmed that i want it added into registry.

    Now, when i ran WLW all the settings were IN!

    Which suggest that there might be a problem with restore function of wlw backup?

    Also - it might be importaint to note, that i created backup on vista, and restore it on XP (some paths/registry might not be in same place?)

     

    thanks,

    jaka

    Wednesday, January 28, 2009 3:53 PM
  • As far as I'm aware, the registry paths are the same in both XP and in Vista, but good to know, I'll check it out. Either way, glad this has worked for you.
    SL - Windows Live Platform MVP
    Wednesday, January 28, 2009 3:56 PM
  • MojMikro, are you on an x64 version of Windows? If so, Scott, you might want to make sure your .exe is configured for x86 mode, not "Any" or whatever. Just a guess.
    Wednesday, January 28, 2009 4:34 PM
  • I'll double check, although wouldn't that cause the program to crash if it was that causing the problem? Cos that's what used to happen with my sidebar gadget, the program actually threw an exception. From the sounds of it, the program seems to be running with no errors. Either way, I'll double check :)
    SL - Windows Live Platform MVP
    Wednesday, January 28, 2009 4:37 PM
  • nope.. everything on 32-bit versions...
    Wednesday, January 28, 2009 10:57 PM
  • Scott...

    when i try to make a backup of WLW on my laptop (where i installed wlw, and then did restore of my WLW from PC), if fails to export registry settings (i tried checking all fields when creating backup, and then only - blog setting)... If i rename .wlwbackup to .cab and open it with izarc there is no registry file... Any ideas what to do?

    thanks,
    jaka

    p.s. i downloaded community clips and can now record a video if it helps :)
    Thursday, February 5, 2009 11:09 AM
  • Try running it as an administrator (if you're on XP, right click > Run As... and if you're on Vista/7, right click > Run as Administrator)
    SL - Windows Live Platform MVP
    Thursday, February 5, 2009 11:14 AM
  • Hmm, i work as user with full admin rights... so this should not be a problem.
    I am on XP...
    maybe we continue this out of forum? msn (weird_god AT hotmail.com) ?

    Thursday, February 5, 2009 11:35 AM
  • After some investigation, I now see what is happening, although I don't quite understand *why*. Anyhoo, details are on my blog post http://scottisafooldev.spaces.live.com/blog/cns!FE151030F50B5B37!2252.entry. I am going to look into rewriting the utility, so keep an eye out on my blog for further developments.
    SL - Windows Live Platform MVP
    Tuesday, February 10, 2009 7:32 PM