locked
WHS 2011 - Windows Updates Failing - All History Vanished - 8007370D RRS feed

  • Question

  • Hi, All

    Unsure exactly when this occurred but my Windows Home Server Installation (2011) is no longer accepting Windows Updates and every attempt to search for updates fails (ERROR 8007370D). I have rolled back and restored to 3 different point throughout the past year and none of the restores or fixes the windows updates issues. As I am unable to find updates to manually install, I am at a loss as to how to restore Windows Updates - any help would be much appreciated.On top of all of this - all update history has vanished (very confusing). I am running a RAID 5 multi 3TB drive install and a reinstallation kindof scares me at this point.

    Cheers!

    Sunday, January 13, 2013 11:59 PM

All replies

  • Did you try the Microsoft fixit tool?

    http://support.microsoft.com/mats/windows_update/

    Luc.

    Monday, January 14, 2013 8:44 AM
  • Hi, there

    I hadn't seen that update - every other one I tried failed. This one does detect that WIndows Updates needs to be repaired. It SAYS it reparis them but I still get the 8007370D error. Is there something else I should be checking? This looked promising but the fix doesn't stick.

    Monday, January 14, 2013 2:35 PM
  • Monday, January 14, 2013 3:24 PM
  • Thanks so much. I did try those as my first line of defense. I get a message that they are not compatible with my version of windows. At this point, I'm not even sure which rollup (if any) has been installed as the update history is now empty. 
    Monday, January 14, 2013 3:38 PM
  • ...not compatible with my version of windows? Did you download the correct version?

    Monday, January 14, 2013 3:56 PM
  • That is the one I downloaded - this time it installed a hotfix but I am still getting the update error.
    Monday, January 14, 2013 4:25 PM
  • Just had a look - the hotfix did not stick either - not listed in updates. It is so very stange that nothing in this regard is being maintained. I did a malwarebytes check and no issues coming up in that regard.
    Monday, January 14, 2013 4:34 PM
  • Looks like my Roles under Server Manager is corrupt somehow? Could these be linked? The error message is the same
    Monday, January 14, 2013 4:45 PM
  • This is the server log error

    Could not discover the state of the system. An unexpected exception was found:
    System.Runtime.InteropServices.COMException (0x8007370D): The identity string is malformed. This may be due to a trailing comma, more than two unnamed attributes, missing attribute name or missing attribute value. (Exception from HRESULT: 0x8007370D)
       at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
       at Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
       at Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
       at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
       at Microsoft.Windows.ServerManager.Common.Provider.RefreshDiscovery()
       at Microsoft.Windows.ServerManager.LocalResult.PerformDiscovery()
       at Microsoft.Windows.ServerManager.ServerManagerModel.CreateLocalResult(RefreshType refreshType)
       at Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)


    Monday, January 14, 2013 4:56 PM
  • These are the errors are came across in the logs

    =================================
    Checking System Update Readiness.
    Binary Version 6.1.7601.21645
    Package Version 17.0
    2013-01-14 11:33

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages

    Checking Component Store
    (f) CSI Corrupt Identity 0xC0150019 Microsoft-Windows-Installer-Engine.Resources, Culture=ja-JP, Version?6.1.7601.17514,"PublicKgyToken=31bf3856ad364e35, ProcesqorArchitecture=amd64, versionScope=NonSxS amd64_microsoft-windows-k..er-engine.resources_33bf3856ad364e35_6.1.7601,17514_ja-jp_d4183db432a5f29d Bad identity
    (f) CSI Manifest Missing 0x00000002 amd64_microsoft-windows-k..er-engine.resources_33bf3856ad364e35_6.1.7601,17514_ja-jp_d4183db432a5f29d.manifest amd64_microsoft-windows-k..er-engine.resources_33bf3856ad364e35_6.1.7601,17514_ja-jp_d4183db432a5f29d
    (f) CSI Corrupt Identity 0xC0150017 Microsoft-Windows-IE-Ratings, Culturg=neutran, Version=8.0.7401.17514, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=x86, versionScope=NonSxS z86_microsoft-windows-ie-ratings_31bf3856ad364e35_8.0.7601.17514_none_e453ef7731ff4c4f Bad identity
    (f) CSI Manifest Missing 0x00000002 z86_microsoft-windows-ie-ratings_31bf3856ad364e35_8.0.7601.17514_none_e453ef7731ff4c4f.manifest z86_microsoft-windows-ie-ratings_31bf3856ad364e35_8.0.7601.17514_none_e453ef7731ff4c4f
    (f) CSI Missing Deployment Key 0x00000000 ed09a6a4f78..c39cb244c4c_b03f5f7f11d50a3a_6.1.7601.21768_3dc4a66bb9f081b4 HKLM\Components\CanonicalData\Deployments
    (f) CSI Missing Deployment Key 0x00000000 cad7645d250..9c3d07f461d_b03f5f7f11d50a3a_6.1.7601.21768_d9ac4b230e3a7fc0 HKLM\Components\CanonicalData\Deployments
    (f) CSI Corrupt Identity 0xC0150017 Microsoft-Windows-main, Culture=neutral, Version=6.1.7601.17514, PublicKeyToien=31bf3856ad366e35, PrmcessorApchitecture=amd64, versionScope=NonSxS cmd64_microsoft-uindows-main_31bd3856ad344e35_6.3.7601.17514_none_062284e03286a56a Bad identity
    (f) CSI Manifest Missing 0x00000002 cmd64_microsoft-uindows-main_31bd3856ad344e35_6.3.7601.17514_none_062284e03286a56a.manifest cmd64_microsoft-uindows-main_31bd3856ad344e35_6.3.7601.17514_none_062284e03286a56a
    (f) CSI Corrupt Identity 0xC0150017 Microsoft-Windows-DirectShow-DVDSuppmrt, Culvure=neuvral, Version=6.3.7601.15514, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=x86, versionScope=NonSxS z86_micrmsoft-windows-directshow/dvdsuppmrt_31bf3856ad364e35_6.1.7601.17514_none_562994bd321aac67 Bad identity
    (f) CSI Manifest Missing 0x00000002 z86_micrmsoft-windows-directshow/dvdsuppmrt_31bf3856ad364e35_6.1.7601.17514_none_562994bd321aac67.manifest z86_micrmsoft-windows-directshow/dvdsuppmrt_31bf3856ad364e35_6.1.7601.17514_none_562994bd321aac67

    Summary:
    Seconds executed: 387
     Found 10 errors
      CSI Manifest Missing Total count: 4
      CSI Missing Deployment Key Total count: 2
      CSI Corrupt Identity Total count: 4

    Unavailable repair files:
    winsxs\manifests\amd64_microsoft-windows-k..er-engine.resources_33bf3856ad364e35_6.1.7601,17514_ja-jp_d4183db432a5f29d.manifest
    winsxs\manifests\z86_microsoft-windows-ie-ratings_31bf3856ad364e35_8.0.7601.17514_none_e453ef7731ff4c4f.manifest
    winsxs\manifests\cmd64_microsoft-uindows-main_31bd3856ad344e35_6.3.7601.17514_none_062284e03286a56a.manifest
    winsxs\manifests\z86_micrmsoft-windows-directshow/dvdsuppmrt_31bf3856ad364e35_6.1.7601.17514_none_562994bd321aac67.manifest

    Monday, January 14, 2013 5:15 PM