locked
CRM 4 - Note Attachment - File Downliad Failure RRS feed

  • Question

  • I am using Data Migration Manager to upload some documents into the Notes field of an Account.

    Upload is fine but when I view the Account; click Notes and then click on the document link, I get:

    "File Download Failure - There was a problem communicating with the Microsoft Dynamics CRM server.  Ther server might be unavailable."

    Not sure what has gone wrong.  The document has a size which appears to match the file on disk.  During the import I set the File Name and Document to be the same as the name of the file on disk so I don't think I've introduced an error by getting these attributes mixed up. 

    The other columns I am importing are Regarding and Title.

    Any ideas what could have gone wrong?

    It is a multi-tenancy, staging system.

    Monday, January 17, 2011 10:51 AM

All replies

  • Ah!

    Also get the error when I try to attach files.

    Should say that the Accounts have also been migrated into CRM as part of the same process.  I did create a new Account and tried to attach using the paperclip but got the same error.

    Tried it upload to a new Task.  Got the error but found that the file seemed to be uploaded.  Of course I can't open it as I get the error.

    Monday, January 17, 2011 11:08 AM
  • More info:

    Error code in IFrame id 0x80004005.

    Looks like permissions. 

    I wonder what permissions are the problem.  A location on the web server?  Anyone know what crm uses for temp files?

    Monday, January 17, 2011 2:35 PM
  • Turned on full Error Reporting and got the following error when I tried to upload an attachment to a note:

    Error Description:

    Column 'BlockedAttachmentsForDownload' does not exist on Table 'Deployment'

    Error Details:

    Column 'BlockedAttachmentsForDownload' does not exist on Table 'Deployment'

    Full Stack:

    [CrmException: Column 'BlockedAttachmentsForDownload' does not exist on Table 'Deployment']
      at Microsoft.Crm.ServerLocatorService.HasOnlyCachedColumns(Table table, String[] columns)
      at Microsoft.Crm.ServerLocatorService.RetrieveById(String tableName, Object primaryKey, String[] columns)
      at Microsoft.Crm.ServerLocatorService.GetDeploymentSetting(String settingName)
      at Microsoft.Crm.LocatorService.GetDeploymentSetting(String settingName)
      at Microsoft.Crm.Application.Utility.Util.IsBlockedAttachment(String fileName)
      at Microsoft.Crm.Web.Note.ConfigureForm()
      at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
      at System.Web.UI.Control.PreRenderRecursiveInternal()
      at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    
    [HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown.]
      at System.Web.UI.Page.HandleError(Exception e)
      at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
      at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
      at System.Web.UI.Page.ProcessRequest()
      at System.Web.UI.Page.ProcessRequest(HttpContext context)
      at ASP.sce_notes_edit_aspx.ProcessRequest(HttpContext context)
      at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
      at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    
    Error Number: 
    0x80040216

    Request URL:


    Tuesday, January 18, 2011 8:39 AM
  • Worked for me.

    Installed Rollup 6 and the problem went away.

    Carried on and installed Rollup 7 followed by Rollup 14.

    Problem still gone.

    Wednesday, January 19, 2011 8:28 AM
  • Hello Gordon,

    Hope you are doing good.

    I am new to CRM server.

    Could you please tell me how can I upload file/files to Note against a record ? I am completely blank except that I could think of

    first inserting a record then get its guid and then insert files for the retrieved guid.

    I am using MVC4- razor syntax.

    Thanks in advance.


    • Edited by ApurvaP Tuesday, February 11, 2014 12:18 PM
    Tuesday, February 11, 2014 12:17 PM