2017-09 Security & Quality Rollup for .NET Framework 4.7 on Windows 7 for x64 (KB4041083) RRS feed

  • Question

  • After downloading Sept 2017 updates for my Windows 7 x64 computer; everything 'Downloaded' successfully and Installed except KB4041083 which downloaded successfully but refused repeated efforts to install.  I didn't have any trouble downloading and installing the similar updates offered in August 2017 or even during July 2017 monthly updates so I feel I've installed every .NET Framework updates available.  Could someone help?  Thanx!  wfejnieh
    • Moved by 宝宝徐 Monday, September 18, 2017 6:56 AM
    Wednesday, September 13, 2017 10:23 PM

All replies

  • Hi,

    KB4041083 is not only for .NET Framework 4,7, but also 3.5.1, 4.5.2, and later.
    Have you tried to download and execute an offline installer of KB4041083?
    You can download it from Microsoft Update Catalog.



    Wednesday, September 13, 2017 11:38 PM
  • Hi wfeinieh,

    Thank you for posting in MSDN forum.

    Have you installed Win 7 Sp1?

    If not, please go to Windows 7 Service Pack 1 download page to  install it, because the minimum system requirement of .Net Framework 4.7 is Windows 7 SP1 (x86 and x64)

    In addition, your questions is related to Win 7 system update, I suggest you post in https://answers.microsoft.com/en-us/windows/forum/windows_7 to get a much professional support.

    Thank you for your understanding.

    Best Regards,

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by 宝宝徐 Friday, September 15, 2017 9:22 AM
    Thursday, September 14, 2017 6:10 AM
  • I had the same problem and found a solution in another thread. Download Net 4.7 offline installer and do a repair (worked for me). Someone else used it to do an uninstall/reinstall. Repairing or reinstalling Net 4.7 has been a solution.
    Tuesday, September 26, 2017 8:09 PM