none
Server reinstallation failed (sob) - little help? RRS feed

  • Question

  • My eval copy of WHS recently expired so I went out and bought a copy.  Not wanting to lose my backups or 1TB of data on the shares, I tried a server reinstallation - I read that this is the chosen route from Eval to Full Copy.

    So anyway, the reinstall looks to be going fine until it gets to the 'finalising installation' bit (the last bullet point on the install list) when I start getting all sorts of error messages like 'Windows Home Server Preserver Service encountered an error and needed to close'(?)  The most final error of all is 'Installing Windows Home Server failed:  The device is not connected (error code 0x8007048f)'. 

    This really tells me very little about why the resintall failed. 

    I've looked through the q_setup.log to no avail either.  I've uploaded that to here:

    http://www.mediafire.com/?sharekey=6f9afcec5370a678e7c82ed4b8f0c380e04e75f6e8ebb871

    The hardware setup is exactly the same as it was when it was the Eval copy of WHS, those few short days ago.

    The machine is currently in a state where the install fails on each re-boot, but it leaves me at the administrator desktop so I can still use it like a normal W2K3 server.

    I really really want to get my WHS back up and running, and I really really don't want to lose my backups or shared data - what can I do?

    Little help..? 
    Wednesday, February 11, 2009 5:27 PM

All replies

  • Hi,
    in your log the last step, which failed, was
    [11/02/2009 09:17:35  3c8] Creating directory D:\shares\Software\Home Server Connector Software
    [11/02/2009 09:17:35  3c8] ERROR: Failed to copy c:\WHS\WHSConnectorInstall.exe to D:\shares\Software\Home Server Connector Software\WHSConnectorInstall.exe (0x8007048f)

    So you may check, if both the folder D:\shares\Software\Home Server Connector Software and C:\WHS exist and if the files in the target location can be overwritten.
    Since in D:\shares are only tombstones, pointing to the other disks, it may be that one of the data disks fails, is corrupt or is not attached, hence the message you mentioned.
    Maybe a look into the event log of the server can give you some clarity.

    Best greetings from Germany
    Olaf
    Wednesday, February 11, 2009 7:59 PM
    Moderator
  • Thank you, I will take a look into the error message and the event logs this morning. (sigh)

    Friday, February 13, 2009 9:37 AM
  • I'm getting the same exact error message.  My setup is exactly the same and nothing has changed.
    I have verified that the files exist in both locations.  When I manually tried to copy the .msi file from C to D:\shares, etc.. I got a message that the file I was copying was older than the existing file.  So, I didn't over write it. 

    Ideas anyone?
    Wednesday, March 11, 2009 10:23 PM
  • Same issue here.  Tried reinstall at least 6 times.  Thought that perhaps updates were needed, but that seems to have accomplished nothing.  Wish i had a solution for you.
    Wednesday, March 25, 2009 9:41 PM
  • Did you apply the update to Power Pack 2 already (if you use the English version of WHS)?
    Installed via http://server:55000?
    Are there any specials on the client (i.e. security suite) or is it infected by malware?
    Best greetings from Germany
    Olaf
    Wednesday, March 25, 2009 10:38 PM
    Moderator