Windows Live Writer was not able to automatically detect your blog settings RRS feed

  • Question

  • Please help, I can no longer add new WP blogs to WLR.
    Steps taken:
    1. Select "Add blog account".
    2. Select "Other blog service" and click next.
    3. Add
    http://nearlyphree.com/ as my WP blog address. Then my WP username and password and check the "Remember my password" check box..
    I then get an error from WLR telling me WLR could not detect my blog settings which it should as I can manually input all these settings in a browser and it works fine.
    4. So I proceed by selecting WordPress 2.2+ from the drop down box (my WP blog version is v2.7.1). I then also fill out the input box below it with the info WLR requires which is: http://nearlyphree.com/public_html/xmlrpc.php
    I then get a message box pop up telling me "The server has reported that the following URL could not be found:".
    I can open up my FTP client and navigate to this exact "xmlrpc.php" file on my host in the exact path I gave WLR so it does in fact exist. I also checked that the file permissions set on the new WP blogs "xmlrpc.php" file on my host was identical to those of my other sites and it was.
    I also shut down my ZoneAlarm firewall and anti-virus service just in case that was the problem even though it's never been an issue in the past and sure enough it made no difference as WLR still could not find my http://nearlyphree.com/ WP blog.
    I already have 3 other WP blogs added to WLR, all are using the exact same version of WP, same theme and all hosted on the same VPS server. I can still connect to my other WP installations using WLR so it appears that old account creations still work, but adding new WP accounts within WLR fails.
    Since all my WP installations are identical and adding accounts to WLR in the past used to work I'm working under the assumption something has changed on Microsoft's end in the way it connects to WP blogs (yes - no - maybe?) and I'm hoping you have a solution to this problem as I'd prefer to use WLR to make my blog posts rather than using the WP backend (which by the way I can log into manually even though WLR can't find it).

    Questions you may have of me:

    1. What version of WLW am I using? v14.0.8064.206 en

    2. Is it possible I input the wrong user name or password or had white spaces at the begining or end? NO chance at all.

    3. My operating system is XP Pro SP3 (fully patched at all times).

    4. Hardware - Pentium 3.00 GHz dual core Duo with 4GB of RAM and an obscene amount of free HD space available.

    I hope someone has some ideas because using WP backend to create posts is painful to say the least. I love WLR interface and capabilities and really want to get back to using it again.

    Tuesday, April 14, 2009 5:39 AM


All replies

  • Hi Stephen,

    When I try to navigate to http://nearlyphree.com/public_html/xmlrpc.php I get:

    You 404’d it. Gnarly, dude.

    Could there have been a setup issue this particular WP instalation?   What happens when you try to hit that xmlrpc.php file from a different computer?

    Tuesday, April 14, 2009 6:09 PM
  • No that shouldn't have any affect on the outcome Ron. If I were to do the same search on one of my other WP blogs for the "xmlrpc.php" file that is working fine with WLR I get that same "You 404’d it. Gnarly, dude." message.

    For example here is another one of my sites that I was able to setup without a problem in WLR (http://carnivalcruisedealsblog.com/public_html/xmlrpc.php), but if I try to go to that same "xmlrpc.php" I'll still get that same "You 404’d it. Gnarly, dude." error message.

    So as you can see both blogs will show that same error message when navigating to the "xmlrpc.php" file, but the NearlyPhree WP blog is the only one that WLR can't make a connection too. Microsoft also released a bunch of new patches this morning which I installed which I hoped may help in some way, but after again trying to add my new blog to WLR it still fails.

    Thanks for the effort though Ron.

    Tuesday, April 14, 2009 6:19 PM
  • Does the the NearlyPhree WP blog have any plugins running?  If so can you try dissabling the WP plugins and trying to configure again?
    Tuesday, April 14, 2009 10:18 PM
  • Hi Stephen.  I think you don't have to disable plugins.

    In step 4 from your orriginal post, instead of using (http://nearlyphree.com/public_html/xmlrpc.php) can you try (http://nearlyphree.com/xmlrpc.php).  Let me know if that works. 

    • Marked as answer by Patriot12 Tuesday, April 14, 2009 11:38 PM
    Tuesday, April 14, 2009 10:38 PM
  • Woo Hoo! That last suggestion of removing the /public_html/ from the path did the trick Ron, you rock! I don't even like posting to my WP blogs anymore without the use of WLR and now I can use it for all of my blogs thanks to your help!

    Tuesday, April 14, 2009 11:38 PM