locked
6.5 hours into install - connector still not working I have a $600 brick with pretty lights RRS feed

  • Question

  • I am running Vista 32 bit SP 1.  Could not get connected, got standard error messages that Connector could not find the sever.  Spent 1.5 hours on the phone with HP, must have changed every setting on my machine. "lets try this, that did not work, try this" (1 hour 34 minutes of changes.  Finally, after editing the host file, I was able to connect, started setup. However, the icon for Home Server never worked, and the one in the tray never changed to green.  Tried to manually back up the laptop I was using - it showed in the list, but I could not click on it to back up - as if it was partially connected, but still missing something.  I did get the web access set up, it is still running. Rebooted machine - no connection.  I completely uninstalled McAfee hoping that was the issue, no luck.  the only change I made when I was able to log in was to give the remote site an address of ERCKVSERVER instead of HPSERVER.

    Tried re-installing - 6 times - the connector.  Gets all the way to the password, I enter password, it tells me it cannot find the sever.  This is getting old.  I am ready to take it back and buy USB storage, this is not worth it.  HP seems clueless, tech tells me it took him two weeks to get his running, tells me it is the software.

    I now have a $600 rock that I can only access from the internet.

    Any help would be appreciated (any Microsoft number I can call that knows what they are doing? HP doesn't...)

    Ralph
    Sunday, October 12, 2008 4:40 AM

Answers

  • Hello,
    did you try to add the corrected Windows Home Server address to hosts file of the client?
    192.168.2.2    ERCSERVER
    Also in the servers used network connections Internet Connection (TCP/IP) properties click Advanced, open the WINS tab and select NetBIOS over TCP/IP.

    I wonder, if there is a need for a connection specific DNS suffix (this ChaCha thing disturbes me) - try to remove that entry on client and server (it's on the Properties of the Network Connection/Internet Protocol(TCP/IP)/Advanced/DNS tab, where you can also remove the Register at DNS Server setting). Save the changes, reboot both machines and try again.

    Best greetings from Germany
    Olaf
    Tuesday, October 14, 2008 6:43 AM
    Moderator

All replies

  • raff98 said:

    I am running Vista 32 bit SP 1.  Could not get connected, got standard error messages that Connector could not find the sever.  Spent 1.5 hours on the phone with HP, must have changed every setting on my machine. "lets try this, that did not work, try this" (1 hour 34 minutes of changes.  Finally, after editing the host file, I was able to connect, started setup. However, the icon for Home Server never worked, and the one in the tray never changed to green.  Tried to manually back up the laptop I was using - it showed in the list, but I could not click on it to back up - as if it was partially connected, but still missing something.  I did get the web access set up, it is still running. Rebooted machine - no connection.  I completely uninstalled McAfee hoping that was the issue, no luck.  the only change I made when I was able to log in was to give the remote site an address of ERCKVSERVER instead of HPSERVER.

    Tried re-installing - 6 times - the connector.  Gets all the way to the password, I enter password, it tells me it cannot find the sever.  This is getting old.  I am ready to take it back and buy USB storage, this is not worth it.  HP seems clueless, tech tells me it took him two weeks to get his running, tells me it is the software.

    I now have a $600 rock that I can only access from the internet.

    Any help would be appreciated (any Microsoft number I can call that knows what they are doing? HP doesn't...)

    Ralph


    What happens when you ping the server (both by server name and by IP address)?  Did you try unplugging your router from your modem and see if the Connector software will find the server that way?
    Sunday, October 12, 2008 4:58 AM
    Moderator
  • raff98 said:

    I am running Vista 32 bit SP 1.  Could not get connected, got standard error messages that Connector could not find the sever.  Spent 1.5 hours on the phone with HP, must have changed every setting on my machine. "lets try this, that did not work, try this" (1 hour 34 minutes of changes.  Finally, after editing the host file, I was able to connect, started setup. However, the icon for Home Server never worked, and the one in the tray never changed to green.  Tried to manually back up the laptop I was using - it showed in the list, but I could not click on it to back up - as if it was partially connected, but still missing something.  I did get the web access set up, it is still running. Rebooted machine - no connection.  I completely uninstalled McAfee hoping that was the issue, no luck.  the only change I made when I was able to log in was to give the remote site an address of ERCKVSERVER instead of HPSERVER.

    Tried re-installing - 6 times - the connector.  Gets all the way to the password, I enter password, it tells me it cannot find the sever.  This is getting old.  I am ready to take it back and buy USB storage, this is not worth it.  HP seems clueless, tech tells me it took him two weeks to get his running, tells me it is the software.

    I now have a $600 rock that I can only access from the internet.

    Any help would be appreciated (any Microsoft number I can call that knows what they are doing? HP doesn't...)

    Ralph


    Hello Ralph,

    Can you contact us at whsforum@microsoft.com with a brief summary of what you have above and any additional information you have regarding your service call with HP?

    I'm going on vacation for two weeks so you may not get a response from me but I've alerted my manager to this situation and he will be waiting for your email.

    Thank you

    Lara Jones [MSFT] Windows Home Server Team
    Sunday, October 12, 2008 5:11 AM
    Moderator
  • I bow in your presence!!!

    Ping works either way ,,but

    Unplugged modem, linked up in seconds.  Is this just a one time install issue (I hope), or do I need further settings to deal with the modem issue?

    Gracious

    Ralph
    Sunday, October 12, 2008 5:20 AM
  • Hi Ralph,
    seems you run into name resolution problems.
    Your Windows Home Server and your PC should use the IP address of your router as DNS server. If they use an DNS server in the internet instead, it may happen, that the client tries to resolve the name there - which will not work properly, because the Internet Service Provider will not know your Windows Home Server.
    You did not write about which hardware you have as a router, since dependent from the model you can configure the DHCP settings including the DNS information on the router.

    Alternatively you could start notepad by right click and Run as Administrator and open the file C:\Windows\system32\drivers\etc\hosts. In this file you would add a line for the Windows Home Server containing the IP address and the server name. The only problem with such manual assignments is, that they may fail, if your server did not get a static IP address assigned.

    For more details how to assign a static IP address look also here:
    http://mswhs.com/2007/07/10/setup-static-ip-for-windows-home-server/


    Best greetings from Germany
    Olaf

    Sunday, October 12, 2008 9:21 AM
    Moderator
  • I am running a Belkin N1 router F5D8232-4,

    WAN
    Connection Type
    Dynamic
      Subnet mask
    255.255.240.0
      Wan IP
    72.189.58.60
      Default gateway
    72.189.48.1
      DNS Address
    65.32.5.111
    65.32.5.112

    LAN
    IP address
    192.168.2.1
    Subnet mask
    255.255.255.0
      DHCP Server
    Enabled


    I do have a command in the host file 192.168.2.3  "XXXSERVER"

    As soon as I unplug the modem, everything works great.  Should I sign up for a static IP?  I tried searching the forum on settup like you described, did not see anything close to my issues.

    Also, I tried manually assigning DNS to 192.168.2.1, but then I cannot connect to internet.

    My router has significant options - now I just need to understand how to set them up.

    I feel a little better - getting closer!
    Sunday, October 12, 2008 6:00 PM
  • Hi again,
    there is no need to configure anything on the router for the internal access - and it's configuration options are very limited (I  assume you tried to change the IP address for the DNS server on the router? This could not work.)

    You can create a static IP address for your Windows Home Server, although your router does not seem to support any reservation, so you must do it on the server directly.
    You could use any IP address which are higher than 192.168.2.100, i.e.
    IP address of the server: 192.168.2.200
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.2.1
    DNS Server: 192.168.2.1


    After changing the servers TCP/Ip settings to these, can your server connect to the Internet?

    Don't forget to readjust the hosts file on the client (or remove the line with the old IP address). You should reboot the client after doing so.
    Please open also a command line on your client PC and enter the command:
    ipconfig /all

    What is the result of this?

    Best greetings from Germany
    Olaf
    Sunday, October 12, 2008 7:15 PM
    Moderator
  •  Again, thank you!!!  I have not tried yet to assign an IP address - maybe later this evening.  For what it is worth, my router is pretty advanced for a home router, I just need to understand how to set it up.  Here is ipconfig

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Dad-PC

       Primary Dns Suffix  . . . . . . . :

       Node Type . . . . . . . . . . . . : Hybrid

       IP Routing Enabled. . . . . . . . : No

       WINS Proxy Enabled. . . . . . . . : No

       DNS Suffix Search List. . . . . . : ChaCha

    Wireless LAN adapter Wireless Network Connection:

       Connection-specific DNS Suffix  . : ChaCha

       Description . . . . . . . . . . . : Broadcom 802.11a/b/g WLAN

       Physical Address. . . . . . . . . : 00-14-A5-FF-4E-0D

       DHCP Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : fe80::edd4:8e54:b6b:d5a%9(Preferred)

       IPv4 Address. . . . . . . . . . . : 192.168.2.6(Preferred)

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Lease Obtained. . . . . . . . . . : Sunday, October 12, 2008 8:25:42 PM

       Lease Expires . . . . . . . . . . : Wednesday, October 10, 2018 8:25:52 PM

       Default Gateway . . . . . . . . . : 192.168.2.1

       DHCP Server . . . . . . . . . . . : 192.168.2.1

       DHCPv6 IAID . . . . . . . . . . . : 151000229

       DNS Servers . . . . . . . . . . . : 192.168.2.1

       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

       Media State . . . . . . . . . . . : Media disconnected

       Connection-specific DNS Suffix  . : ChaCha

       Description . . . . . . . . . . . : NVIDIA nForce Networking Controller

       Physical Address. . . . . . . . . : 00-16-36-AF-BF-D7

       DHCP Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 6:

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

       Physical Address. . . . . . . . . : 02-00-54-55-4E-01

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e50:1084:4b7:b742:c5c3(Prefe

    rred)

       Link-local IPv6 Address . . . . . : fe80::1084:4b7:b742:c5c3%10(Preferred)

       Default Gateway . . . . . . . . . : ::

       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter Local Area Connection* 7:

       Connection-specific DNS Suffix  . : ChaCha

       Description . . . . . . . . . . . : isatap.ChaCha

       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : fe80::5efe:192.168.2.6%17(Preferred)

       Default Gateway . . . . . . . . . :

       DNS Servers . . . . . . . . . . . : 192.168.2.1

       NetBIOS over Tcpip. . . . . . . . : Disabled

    Monday, October 13, 2008 12:44 AM
  • Also, I did try to change my DNS to 192.168.2.1, which is my router address.  Could no longer get online, had to change it back to get DNS automatically.  Would it help if I got a static IP.  My ISP offers it for a small fee per month.

    Greetings from sunny Florida!
    Monday, October 13, 2008 12:46 AM
  •  
    raff98 said:

    Also, I did try to change my DNS to 192.168.2.1, which is my router address.  Could no longer get online, had to change it back to get DNS automatically.  Would it help if I got a static IP.  My ISP offers it for a small fee per month.


    no need for a static IP on the Internet side.
    As mentioned, only the DNS server on client and server should be changed to the address of the router, not the one on the router itself - not clear for me, if this was what you tried (since the client shows the proper setting here).

    Is the behavior different, if you use a wired connection? Wireless connections can be very unperformant and unreliable.

    You could also try, to disable all network connections on your client, which you are not using.
    (In Network and Sharing Center, click on Manage Network Connections, Right click on the unused connections and select Disable.)
    Eventually also disable the TCP/IP v.6 protocol in the properties of your wireless adapter.
    (Right click the connection in above screen and select Properties. uncheck the checkbox Internet Protocol Version 6 and click OK.)

    Please run ipconfig /all also on your WHS directly to verify the settings.

    Best greetings from Germany
    Olaf
    Monday, October 13, 2008 7:53 AM
    Moderator
  • My WHS ( also renamed to SERVER-PVM ) with all the  Windows updates installed, had the  Windows  FireWall active. there were numerous  Windows Media Connect  [ UDP ports allowed (from 10243-10285  with some gaps) ]. I assume(d), that these are the ports the  Diccovery / Login to the WHS via the Discovery.exe process. In one Obsessive Compulsive Disorder frenzy, I temporarily turned off the firewall on the  WHS via  Remote Desktop Client [ C:\WINNT\system32\mstsc.exe /Console ]. VIOLA !!!  Success.. I could now successfully enter my password and re-donnect to my WHS.. Maybe this is of value. Good Luck.
    • Proposed as answer by MeadowsPV Monday, October 13, 2008 8:56 AM
    Monday, October 13, 2008 8:56 AM
  • Olaf Engelke said:

     

    raff98 said:

    Also, I did try to change my DNS to 192.168.2.1, which is my router address.  Could no longer get online, had to change it back to get DNS automatically.  Would it help if I got a static IP.  My ISP offers it for a small fee per month.


    no need for a static IP on the Internet side.
    As mentioned, only the DNS server on client and server should be changed to the address of the router, not the one on the router itself - not clear for me, if this was what you tried (since the client shows the proper setting here).

    Is the behavior different, if you use a wired connection? Wireless connections can be very unperformant and unreliable.

    You could also try, to disable all network connections on your client, which you are not using.
    (In Network and Sharing Center, click on Manage Network Connections, Right click on the unused connections and select Disable.)
    Eventually also disable the TCP/IP v.6 protocol in the properties of your wireless adapter.
    (Right click the connection in above screen and select Properties. uncheck the checkbox Internet Protocol Version 6 and click OK.)

    Please run ipconfig /all also on your WHS directly to verify the settings.

    Best greetings from Germany
    Olaf



    Ok, I understand what Olaf is saying...  I had just read another post where he said to set the client DNS setting to the server.

    I think there is a little bit of translation error..


    What Olaf means is that the Client DNS setting should be the same DNS IP addresses that your router is using.

    My router has a fixed IP address assigned by my Internet Provider and I use OpenDNS so my DNS servers are 208.67.222.222 and 208.67.220.220    Those DNS servers are set in the IP configuration of my WHS and my Router.  They are also set in the IP configuration of my Vista work station/client, but I have assigned a fixed IP address to it.

    Rick M

    Rick McMillion
    Monday, October 13, 2008 10:15 AM
  • Hi Rick,
    no translation error on my side:
    It is really often the case, that systems are configured in a way, that they have an external DNS server in their TCP/IP properties - and try to register themself on this DNS server. And sure enough, they try to use this DNS server also for resolving internal names, which cannot work for private network addresses.

    Most routers act themself as a DNS forwarder for name resolution queries to the DNS server of the ISP.
    So the DNS client (Windows XP, Vista, WHS) also need to know, which device they can query for a name in their own network - which is the router. He can also register his network connection locally on the routers DNS that way, if the router allows this (depends from the DNS implementation of the router). Even if not, the communication between the rejecting router and the client will fail faster, which speeds up the boot process.
    The router tries to resolve queried names by himself (which may work or not) and only, if this does not work, forwards the query to the DNS server of the ISP.

    While it is recommended to use the router as DNS server for the local clients, this does not mean, that it always works. Depends from the router and maybe from the requirements of the ISP. In this rare case you could be right, but it is recommended to uncheck Register this connection's addresses in DNS in the TCP/IP properties after clicking Advanced button and selecting DNS tab.

    Best greetings from Germany
    Olaf
    Monday, October 13, 2008 11:30 AM
    Moderator
  • I disabled all connections except wireless and wired.  No difference in performance if hooked up to my ethernet.  TCP/IP v.6 is disabled.  Unchecked "Register ...in DNS"

    I do not have XP pro or Vista Ultimate, how do I run ipconfig on WHS without Remote Desktop?

    Also had power outage last night, which changed IP address of WHS (which was what worried me about adding into Hosts file)

     

    As soon as I disconnect my modem, works great, plug it back in, no more access to WHS.

     

    I find it wierd that I CAN access the folders on WHS via my network (can add, remove files, map to server) while modem is plugged in, but cannot run connector.

     

    I saw mention of OpenDNS.  Would this help?  It appears WHS Connecter gets confused as soon as my modem is plugged in.

     

    Olaf: thanks for the help so far.  I want to go out an buy another 2Tb of storage, but the $% Windows Home Connector is a pain.  I should update Microsoft and change the title - over 10 hours and still $600 brick....

    Monday, October 13, 2008 12:56 PM
  • Hello,
    you do not need the Pro or Ultimate versions of Windows to access the WHS via Remote Desktop (only if you wish to install the workstation itself via Remote Desktop, these versions are needed). You find the Remote Desktop Client usually in Start / All Programs /Accessories (in some versions still under Communications).

    Different IP address after power outage is nothing unusual - that is why I recommend to associate a fixed IP address to the WHS.

    What exactly do you mean with "the modem"?
    Do you have a separate device besides the router? Or do you mean the connection from the router to the DSL splitter (or whatever you have there instead)?

    Best greetings from Germany
    Olaf
    Monday, October 13, 2008 1:07 PM
    Moderator
  • I have a cable modem to my Belkin N1 router.  I disconnect the ethernet cable between the cable modem and the router - works great.  Plug it back in, bye bye connector, cannot find WHS.  Just installed on Connector on XP Pro - did the same thing.  router disconnected from cable modem (internet) works great.  Plug it in, connector cannot find WHS
    Monday, October 13, 2008 7:00 PM
  • Still waiting for your results of ipconfig /all from WHS.
    You could read also through 
    http://blogs.msdn.com/eldar/archive/2007/04/28/windows-home-server-client-join-troubleshoooting-hints.aspx
    Maybe you spot something here, which we did oversee in the discussions.

    What is the modem model? Possible there is something wrong in the router/modem combo, which causes WHS Connector to hick up.
    Could be it needs to run in bridge mode (I have no such combo running, so I don't know the exact steps and side effects) and the built in modem of the router needs to be deactivated.
    Best greetings from Germany
    Olaf
    Monday, October 13, 2008 8:21 PM
    Moderator
  • I hate to say it - but no clue how to get a command prompt on WHS to run ipconfig
    Monday, October 13, 2008 8:28 PM
  • raff98 said:

    I hate to say it - but no clue how to get a command prompt on WHS to run ipconfig

    On your client click Start / All Programs / Accessories / Remote Desktop Connection (or similar).
    Enter the name of your WHS.
    Click Connect.
    As account name enter Administrator, as password the console password.
    You should now be logged in to the desktop of your home server.
    Click Start/Run and type cmd here. Click OK.
    Here is the command prompt of WHS.

    After running ipconfig /all also check the event log of your WHS for error messages and warnings.
    To do so, click Start/Run (still in the Remote Desktop session) and type eventvwr.

    Best greetings from Germany
    Olaf
    Monday, October 13, 2008 8:48 PM
    Moderator
  •  

    Windows IP Configuration

     

       Host Name . . . . . . . . . . . . : ERCSERVER

       Primary Dns Suffix  . . . . . . . :

       Node Type . . . . . . . . . . . . : Unknown

       IP Routing Enabled. . . . . . . . : No

       WINS Proxy Enabled. . . . . . . . : No

       DNS Suffix Search List. . . . . . : ChaCha

     

    Ethernet adapter Local Area Connection:

     

       Connection-specific DNS Suffix  . : ChaCha

       Description . . . . . . . . . . . : SiS191 1000/100/10 Ethernet Device

       Physical Address. . . . . . . . . : 00-0A-E4-87-71-E9

       DHCP Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

       IP Address. . . . . . . . . . . . : 192.168.2.2

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . : 192.168.2.1

       DHCP Server . . . . . . . . . . . : 192.168.2.1

       DNS Servers . . . . . . . . . . . : 192.168.2.1

       Lease Obtained. . . . . . . . . . : Sunday, October 12, 2008 3:16:16 PM

       Lease Expires . . . . . . . . . . : Wednesday, October 10, 2018 3:16:16 PM

     

    When I run event viewer, I Have nothing but information items listed for "HomeServer".  No errors for any tries to connect that failed.  It as if WHS never saw my attemps to log in when I have my modem connected.

    Monday, October 13, 2008 9:24 PM
  • i have the same router and when it's working it works great...anyway have you tried resetting your router and modem back factory defaults and set them up all over again?
    Monday, October 13, 2008 10:13 PM
  • Thanks for the thought.  I restored to defaults, still same issue - works great when my modem is diconnected from the router, but as soon as I plug in the modem: poof WHS gives error messages and closes

    Tuesday, October 14, 2008 3:26 AM
  • Olaf: thanks for the support.  Been online with MS about two hours.  No comment.  I am 99% sure I have a DNS conflict.  I tried using a manual IP on WHS, and manually entering the DNS (same one my router gets from the internet)  That did not work.  Somehow, I know this is simple DNS issue, I'm just not smart enough to get around it. Any ideas?

    You could make a fortune in support.....
    Tuesday, October 14, 2008 5:07 AM
  • if you think it's a DNS issue, then try using OpenDNS.  I use their DNS servers and they work great.

    Their DNS IP addresses are:

    208.67.222.222
    208.67.220.220


    I use those same DNS server IP addresses on my Router, my WHS, and my work stations that have a fixed IP address.

    It won't hurt to give it a try, who knows?  :)

    Rick M


    Rick McMillion
    Tuesday, October 14, 2008 5:57 AM
  • Hello,
    did you try to add the corrected Windows Home Server address to hosts file of the client?
    192.168.2.2    ERCSERVER
    Also in the servers used network connections Internet Connection (TCP/IP) properties click Advanced, open the WINS tab and select NetBIOS over TCP/IP.

    I wonder, if there is a need for a connection specific DNS suffix (this ChaCha thing disturbes me) - try to remove that entry on client and server (it's on the Properties of the Network Connection/Internet Protocol(TCP/IP)/Advanced/DNS tab, where you can also remove the Register at DNS Server setting). Save the changes, reboot both machines and try again.

    Best greetings from Germany
    Olaf
    Tuesday, October 14, 2008 6:43 AM
    Moderator
  • good catch, I just noticed the chacha thing.  I wonder how that got in there and what it's all about also


    Rick McMillion
    Tuesday, October 14, 2008 7:34 AM
  • Olaf: in my router it has an option to name the local domain name network.  "Local Domain Name You can set a local domain name (network name) for your network. There is no need to change this setting unless you have a specific advanced need to do so. You can name the network anything you want such as "MY NETWORK". 
    It defaults to Belkin, but I changed it to match my wireless SSID.  Anyway, I deleted the entry in the field, and just like magic, the WHS works like a charm. (after 17 hours)
    Thank you Thank You Thank You!!!!!
    Tuesday, October 14, 2008 2:03 PM
  • Great, that we could solve it finally. Thanks for reporting the result back.
    Good luck with your WHS!
    Best greetings from Germany
    Olaf
    Tuesday, October 14, 2008 7:52 PM
    Moderator