none
Problem in adding O365 API in my botapplication RRS feed

  • Question

  • I am trying to create O365 assisting bot using visual C#, bot framework and Azure cloud service for publishing. First I added connected service(O365 API). I created tenant in Azure. Then registered my application and got the Application id. In the configuration window (in visual studio) for O365 API service, I filled up the domain name then filled up the client id which was retrieved when app registration was done in Azure. But it shows an error that connected services component office 365 API's failed;(HRESULT:0*80131509)Insufficient privileges to complete the operation. Please help me in solving the problem.

    Thanks in Advance.

    • Edited by yaduska Monday, December 18, 2017 3:18 AM
    • Moved by 宝宝徐 Tuesday, December 26, 2017 7:40 AM
    Monday, December 18, 2017 3:17 AM

All replies

  • Hi yaduska,

    Welcome to MSDN forum.

    This forum is discussing Visual Studio WPF/SL Designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System, and Visual Studio Editor. Your issue is related to Azure, please go to Azure forum to open a new thread to talk about it.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, December 19, 2017 7:09 AM