locked
UI breakage in the in the progress bar of business Process Flow RRS feed

  • Question

  • I have changed the default business process flow of Lead to have the following stages

    Propose > Evaluate > Close

    I have coded a custom workflow activity that will show the progress on the "Close" stage  when the statecode of the Lead changes to disqualified or qualified. But I am seeing this problem

    There are 2 flags (one on propose and one on Close)  and the blue highlight does not move from Propose. However, whenI refresh the page it shows the right thing  - one flag and the blue highlight on Close stage

    Here is the my code that is changing the stage

            private void changeStage (string newStageValue)
            {
                string fetchXMLStage =
                                "<fetch mapping='logical'>" +
                                    "<entity name='processstage'>" +
                                        "<attribute name='processstageid' />" +
                                        "<attribute name='stagename' />" +
                                        "<attribute name='processid' />" +
                                        "<filter type='and'>" +
                                            "<condition attribute='stagename' operator='eq' value='" + newStageValue + "' />" +
                                            "<condition attribute='processid' operator='eq' value='" + CurrentLeadRecord["processid"].ToString().Replace("}", "").Replace("}", "") + "' />" +
                                        "</filter>" +
                                    "</entity>" +
                                "</fetch>";

                EntityCollection entCollectionStage = Service.RetrieveMultiple(new FetchExpression(fetchXMLStage));
                if (entCollectionStage.Entities.Count > 0)
                {
                    var stage = entCollectionStage.Entities[0];
                    CurrentLeadRecord["stageid"] = Guid.Parse(stage["processstageid"].ToString());
                    Service.Update(CurrentLeadRecord);
                }
           
            }

    So, could anyone tell me how can the problem be fixed without manually clicking the refresh.

    Thanks,

    Hasib


    Hasibur Rahman

    Friday, March 18, 2016 1:05 AM