locked
No RetriveEntityRequest since custom Cumstomer Field on Entity RRS feed

  • Question

  • Hello,

    We have created a new custom customer field in CRM 2016 SP1.

    Since this we don't can execute a RetiveEntityRequest

    RetrieveEntityRequest a = new RetrieveEntityRequest();
    a.EntityFilters = EntityFilters.Attributes;
    a.RetrieveAsIfPublished = true;
    a.LogicalName = "new_mitgliedschaft";
    RetrieveEntityResponse b = null;
    
    b = (RetrieveEntityResponse)crmOrgService.Execute(a);

    The Last Line will Fault: OrganizationServiceFault: Found an integer attribute with unrecognized format: new_kundeidtype

    I use the last SDK version.

    The incident is existing on both: CRM OnPremise and CRM Online

    When I delete the custom customer field on the entity the RetrieveEntityRequest will work.

    Wednesday, June 15, 2016 3:32 PM

All replies

  • Hi Tavok,

    We tried the same thing at our end. And are facing the same issue L.

    Just we tried one thing if you set the  a.RetrieveAsIfPublished = false; then request gets executed successfully.

    Hope this helps!

    Thanks!

    Sam

        

    Inogic | Blog | news@inogic.com

    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Thursday, June 16, 2016 10:18 AM
  • Hi all,

    We were facing the same problem and Sam's workaround solved the issue.

    Why does setting RetrieveAsIfPublished false solve the problem?

    I'm nervous around magic switches I don't understand... :)

    Thanks,

    Simon


    • Edited by simonletch Tuesday, July 12, 2016 2:37 PM
    Tuesday, July 12, 2016 2:25 PM
  • Hi,

    same problem, workaround solved it. Why does setting RetrieveAsIfPublished false solve the problem?

    Thanks

    Monday, July 18, 2016 3:27 PM
  • Hi Simon,
     

    We don’t know the exact reason how this issue is resolved by just setting the above Property to false.

    For more information over the RetrieveAsIfPublished property you may refer this blog:  

     
     
    Hope this helps.
     
    Thanks!
     
    Sam

    Inogic | Blog | news@inogic.com

    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"


    • Edited by Sam-Inogic Tuesday, July 19, 2016 12:56 PM
    Tuesday, July 19, 2016 11:14 AM