locked
Possible Connector Issues Solution. RRS feed

  • Question

  • If you are having issues with the connector you can just skip to the FIX section to the bottom!

     

    So moving on….I managed to resolve the issue I was having and wanted to share with everyone who may be in the same predicament.

    After setting up WHS 2011 and connecting my machines to it, I never logged in to the dashboard from any of the client machines. I simply used RDP to connect to the WHS box directly. The day came that I needed to restore a file and found that I couldn’t login to the dashboard from ANY of my client computers....kept getting access denied errors…..this is where the fun began....

    I focused on one machine, a Windows 7 x 64 machine.

    I uninstalled the client, rebooted and tried to re-install it. It kept failing with the message that and unknown network error had occurred (so informative!). The connector install was always able to find my WHS on its own during the install process so I knew it wasn’t the problem that most people were having. I took to Google and tried everything people were posting;

    Make sure the time zones matched.

    Set both the WHS and the client to Pacific Time

    Disable IPv6

    Use host files

    Enable IPv6

    Lots of registry keys edits/deletions based on various forum posts I found

    Uninstalled the rollup update

    Re-installed the rollup update

    Downloaded the connector using the hostname

    Downloaded the connector using the IP

    Changed my WHS admin password to be as simple as possible

    Deleted and recreated my user account from the WHS

    The whole .net uninstall – reinstall

     

    Nothing worked!!!

     

    ******* The FIX******

    So just out of boredom and to feel some semblance of success I decided to fix some errors in the event log on the WHS regarding the Active Directory Certificate Services. I ran some of the commands in the 2 articles listed below and realized that the ADCS database was corrupted! Following the articles I was able to correct the corrupted database and rebooted as part of the process.

    VOILA! Problem fixed, I was able to login to the dashboard from all the computers and most importantly I was able to re-install the client on the computer in question. Hopefully this helps some of the people who have been connector related issues.

     

    So in short if you have connector issues look at the ADCS events and make sure that it is working without issues.

     

    http://technet.microsoft.com/en-us/library/cc774578(WS.10).aspx

    http://support.microsoft.com/kb/930832

     

    P.S.

    WHS 2011 is truly a MAJOR disappointment, if you are on WHS V1 stay put!

    Wednesday, October 12, 2011 3:20 AM