locked
EMail router crm 2011 Incoming profile error RRS feed

  • Question

  • Hi

    I have CRM 2011 on its own server, Exchange 2010 on the SBS 2011 server.

    I have configured the incoming profile using Exchange Web Services URL as http://sbs2011/EWS/Exchange.asmx

    When I test access I get the below error.  I am not sure how to resolve this as I have little experience with sbs2011 and Exchange 2010

    Incoming Status: Failure - Verify that you specified the correct Exchange Web Services URL. The request failed with the error message:--<html><head><title>Object moved</title></head><body><h2>Object moved to <a href="HTTPS://SBS2011/EWS/EXCHANGE.ASMX">here</a>.</h2></body></html>--.

     


    Marc Collins www.QGate.co.uk
    Friday, June 17, 2011 1:57 PM

Answers

  • I have a workaround now even though I don't think it should be setup like this.  I have changed the incoming profile web serivces URL to fit in with the certificate and it has worked.  The URL is now https://external.domain.com/EWS/exchange.asmx.

    Does anyone see any issues with this and what else would I need to configure for this to function correctly?


    Marc Collins www.QGate.co.uk
    • Proposed as answer by BuggFix Wednesday, August 8, 2012 7:07 AM
    • Marked as answer by Marc J Collins Wednesday, August 8, 2012 7:12 AM
    Monday, June 20, 2011 9:19 AM

All replies

  • Hi,

    Try accesing http://sbs2011/EWS/exchange.asmx from internet explorer and see if it shows results, if it does not work then try this URL https://sbs2011/EWS/exchange.asmx (if this works then try this to configure incomming profile)


    Jehanzeb Javeed

    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile

    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Saturday, June 18, 2011 8:56 PM
  • Hi Jehanzeb

    I have tried both of these options.  When I browse to http://sbs2011/EWS/exchange.asmx, I am redirected to https://sbs2011/EWS/services.wsdl.  However, I am greeted with a certificate error first. 

    I also get a certificate error when I browse to https://sbs2011/EWS/exchange.asmx as well.  The certificate has been issues to a different web address.  The error I see when I test this URL is below.  Maybe there is a way round this.

    "The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. The remote certificate is invalid according to the validation procedure"


    Marc Collins www.QGate.co.uk
    Monday, June 20, 2011 7:47 AM
  • I have a workaround now even though I don't think it should be setup like this.  I have changed the incoming profile web serivces URL to fit in with the certificate and it has worked.  The URL is now https://external.domain.com/EWS/exchange.asmx.

    Does anyone see any issues with this and what else would I need to configure for this to function correctly?


    Marc Collins www.QGate.co.uk
    • Proposed as answer by BuggFix Wednesday, August 8, 2012 7:07 AM
    • Marked as answer by Marc J Collins Wednesday, August 8, 2012 7:12 AM
    Monday, June 20, 2011 9:19 AM
  • I would say that this is the best solution - you could make sure that your internal DNS points the external record to the internal server IP - but if it is set to use SSL it doesn't matter. Even if it is querying the external address of the router it should be fine as lots of Exchange services do this by default.

    Tuesday, May 22, 2012 11:45 AM