After Synchronization Table Still Empty RRS feed

  • Question

  • Hello.

    I am having the following problem with Sync Framework 2.1 trying to sync between SQL Server 2008 and SQL Compact Edition 3.5 SP2:
    I am doing a CEDatabaseCreationMode.FullInitialization but afer synchronization has finished without errors only the table and the table_tracking table was created but there was no data inserted!
    On the SQL Server 2008 side there are at least 5000 entries that should be downloaded to the client in my opinion! I am using the SyncOrchestrator for synchronization and have tried Download, Upload, DownloadAndUpload, UploadAndDownload. None of these changes helped.

    When I then enter a new value manually on the server, the table_tracking is filled and after synchronization I've got an entry in the client database.
    But it is impossible for me to get the old entries to the client! No matter what I try - everything fails!
    To insert the first 5000 rows, I am using Bulk-Copy - but that's not a problem, right?

    Has anyone an idea what can cause this? What do I have to do so that the client gets initially all the data from the server?

    Thanks a lot for any kind of help!
    All the best,

    • Edited by timtos Thursday, February 24, 2011 4:11 PM More detailed information
    Thursday, February 24, 2011 3:58 PM


All replies

  • did you populate the table after provisioning? afaik, bulk copy by default does not fire triggers and Sync Fx tracking tables are populated via triggers.

    if you have populated the table prior to provisioning, try setting the PopulateTrackingTable option.

    Friday, February 25, 2011 1:05 AM
  • Hi JuneT,

    thanks for the reply!
    But unfortunately I did populate the table after provisioning!
    Setting the PopulateTrackingTable didn't help.

    So I guess you're right that bulk copy doesn't fire triggers.
    Until now I don't know how to set it up to fire triggers...

    One more idea? :)

    Thanks again and a lot,


    Sunday, February 27, 2011 10:06 PM
    • Marked as answer by timtos Monday, February 28, 2011 9:27 AM
    Sunday, February 27, 2011 11:17 PM
  • Thank you!!! That looks good... :)
    Monday, February 28, 2011 9:28 AM