locked
Any idea about the cause of this error? RRS feed

  • Question

  • Hi, I have a workflow which is triggered by the update of some fields. It uses a custom activity for mathematical operations, but the error happens with simple Update record step. It is strange that it doesn't happen all the time, when I run the failed wfs again, it goes well. The following is the exception I can see in wf history:

    Workflow paused due to error: Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: An unexpected error occurred.Detail:
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147220970</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
      <Message>An unexpected error occurred.</Message>
      <Timestamp>2013-09-12T12:58:36.4669183Z</Timestamp>
      <InnerFault>
        <ErrorCode>-2147220970</ErrorCode>
        <ErrorDetails xmlns:d3p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
        <Message>System.InvalidOperationException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #2FFD07BF</Message>
        <Timestamp>2013-09-12T12:58:36.4669183Z</Timestamp>
        <InnerFault i:nil="true" />
        <TraceText i:nil="true" />
      </InnerFault>
      <TraceText i:nil="true" />
    </OrganizationServiceFault>
       at Microsoft.Crm.Extensibility.OrganizationSdkServiceInternal.RetrieveMultiple(QueryBase query, CorrelationToken correlationToken, CallerOriginToken callerOriginToken, WebServiceType serviceType)
       at Microsoft.Crm.Extensibility.InprocessServiceProxy.RetrieveMultipleCore(QueryBase query)
       at Microsoft.Crm.Workflow.RegardingObjectUtility.CreateLookup(String entityName, Guid entityId)
       at Microsoft.Crm.Workflow.WorkflowContextBase.SetStepRegardingRecord(String entityName, Guid entityId)
       at Microsoft.Crm.Workflow.Services.UpdateActivityService.<>c__DisplayClass1.<UpdateInternal>b__0(IOrganizationService sdkService)
       at Microsoft.Crm.Workflow.Services.ActivityServiceBase.ExecuteInTransactedContext(ActivityDelegate activityDelegate)
       at Microsoft.Crm.Workflow.Services.UpdateActivityService.UpdateInternal(Entity entity, String stepId)
       at Microsoft.Crm.Workflow.Services.UpdateActivityService.ExecuteInternal(ActivityContext executionContext, UpdateEntity updateEntity)
       at Microsoft.Crm.Workflow.Services.UpdateActivityService.Execute(ActivityContext executionContext, UpdateEntity updateEntity)
       at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
       at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

    Not so intuitive, if it was some plugin that throws the exception, I would get at least the namespace. Could it be performance issue or async service problem?

    Thanks in advance


    Zarko


    • Edited by Radevic Thursday, September 26, 2013 10:17 AM edit
    Thursday, September 26, 2013 10:16 AM

All replies

  • This error is not sufficiently specific to help. If you are running CRM OnPremise, then enable tracing, and this should give more information

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Thursday, September 26, 2013 11:56 AM
    Moderator
  • Ok, the error says: Crm Exception: Message: <entityName> With Id = a5c1e918-642a-e311-a60c-005056b75bcb Does Not Exist, ErrorCode: -2147220969. Any idea how could this happen? The workflow does run on an existing record. I don't have any timeout steps before that update statement wich throws the error.

    Zarko

    Tuesday, October 1, 2013 10:14 AM
  • what is the status of record which you are updating?

    Regards Faisal

    Tuesday, October 1, 2013 12:03 PM
  • It is an active record. I emphasize again, when I ran instances manually again, it went well.

    Zarko

    Tuesday, October 8, 2013 8:33 AM