locked
Domain functional level requirement for 2015 on-prems RRS feed

  • Question

  • Hi

    I would like to install CRM 2015 in my current domain (2003 native mode) but I'm not sure if this will work because of the domain functional level requirement for 2015 (Windows Server 2008 and above).

    My deployment will not be an IFD and not use ADFS, nor will it use any time of client certificate (or even https for that matter).

    Is the domain functional mode still a hard requirement in this scenario?

    Thanks

    Nicolas

    Friday, January 30, 2015 6:43 PM

Answers

  • So I did the install and everything looks good...
    • Marked as answer by nico_husson Tuesday, March 31, 2015 1:57 AM
    Tuesday, February 10, 2015 9:35 PM

All replies

  • Do you have multiple AD domains ? If you have multiple AD domains, with CRM users in a different domain from the CRM server, then the domain functional level may be relevant.

    If not, then I think you should be OK, but you won't know till you've tried. A set of tests is:

    • Installed CRM
    • Add a user
    • Check the user can access CRM
    • Check the user can run CRM reports

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Friday, January 30, 2015 9:23 PM
    Moderator
  • So I did the install and everything looks good...
    • Marked as answer by nico_husson Tuesday, March 31, 2015 1:57 AM
    Tuesday, February 10, 2015 9:35 PM