none
Just-In-Time Debugging NOT Working on Windows 7 64-bit Professional

    General discussion

  • I have Visual Studio 2010 Ultimate installed, and it seems the registry has the right keys:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug]
    "UserDebuggerHotKey"=dword:00000000
    "Debugger"="\"C:\\Windows\\system32\\vsjitdebugger.exe\" -p %ld -e %ld"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\AutoExclusionList]
    "DWM.exe"=dword:00000001

    However, JIT debugging just does not work. Any time a program crashes, the OS seems to be recording something, but nothing appears at all after a few seconds and I am just returned to the command prompt (if I try a console program on the command prompt). The program just silently crashes without showing any OS or debugger messages.

    Anybody having ideas what can be going on? How can I fix this?


    • Edited by Adah Wednesday, July 25, 2012 2:45 AM
    Wednesday, July 25, 2012 2:43 AM

All replies

  • Hi Adah,

    Thank you for posting in the MSDN forum.

    Did you enable Just-In-Time debugging from the Options dialog box in VS? For detailed information, see “Just-In-Time Debugging

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, July 26, 2012 7:24 AM
    Moderator
  • Yes, all three types are checked. I even tried unchecking them, quitting VS, and re-checking them.
    Thursday, July 26, 2012 1:19 PM
  • Well, this is a long time coming but I ran into this same problem and I found the solution.

    WER (Windows Error Reporting) was configured to silently handle crashes.

    See: https://msdn.microsoft.com/en-us/library/windows/desktop/bb513638(v=vs.85).aspx

    I had to set

        DontShowUI

    to zero. (I don't know how it got set to 1).

    In HKEY_CURRENT_USER\Software\Microsoft\Windows\Windows Error Reporting.

    As soon as I did that, an app crash would pop a dialog asking me if I want to debug.


    Joe

    Wednesday, August 03, 2016 8:35 PM
  • I put a value of 1 into the field "Disabled" for both key paths.
    Tuesday, February 28, 2017 11:19 PM
  • On my previous pc I was able to attach a debugger from the JIT "program crash" dialog by setting Disabled to 1 in the reg key
    HKLM\Software\Microsoft\Windows\Windows Error Reporting
    However, on my current Win10 pc, I found it necessary to set Disabled to 1 here in wow6432node...
    HKLM\Software\WOW6432Node\Microsoft\Windows\Windows Error Reporting
    Once I did that, everything worked. Previous pc was also 64bit, not sure why this is now needed, but after trying lots of other things I found this made it work... may be helpful to others.
    Monday, September 24, 2018 6:11 AM