locked
ERROR: The object cannot be updated because it is read-only. RRS feed

  • Question

  • When attempting to reactivate a case I get the following error:

    ERROR: The object cannot be updated because it is read-only.

     

    I am a full admin... we are on Rollup 8

     

    Other records work fine... there are quite a bit of custom actions programmed into the events of the case... anyone had this before?

    Thursday, May 27, 2010 5:55 PM

Answers

  • Are the plugins that run on setstate of a case?  It seems that the case is being updated before it gets re-activated.  You can't update a case while it is inactive.
    Blake Scarlavai - http://mscrmdev.blogspot.com/ - Sonoma Partners - http://www.sonomapartners.com/
    • Marked as answer by 41714049 Thursday, May 27, 2010 9:08 PM
    Thursday, May 27, 2010 6:36 PM
  • I FOUND IT!

    There was a ForceSubmit() in the onSave event... oh my... that was a pain.  Thanks for all your help guys.

    • Marked as answer by 41714049 Thursday, May 27, 2010 9:08 PM
    Thursday, May 27, 2010 9:08 PM

All replies

  • Are the plugins that run on setstate of a case?  It seems that the case is being updated before it gets re-activated.  You can't update a case while it is inactive.
    Blake Scarlavai - http://mscrmdev.blogspot.com/ - Sonoma Partners - http://www.sonomapartners.com/
    • Marked as answer by 41714049 Thursday, May 27, 2010 9:08 PM
    Thursday, May 27, 2010 6:36 PM
  • check similiar thread as follow which got potential solution for this.

    http://social.microsoft.com/Forums/en-US/crm/thread/221cdd85-c845-4c43-9e63-4d639b0fb50a

    Thursday, May 27, 2010 7:13 PM
    Answerer
  • Ahh... I see... I think I know where the problem lies then. I would need to determine if the case is active before running the code I have in the Form Load.

    I would need to run some commands only if the record is active.  How would I determine if the record is active?

    Thursday, May 27, 2010 8:21 PM
  • Never mind my last post it is not what I thought... I turned off all of my form load events and it is still happening ... all I have left is my onchange events but there were no changes so they were not triggered... because it is inactive... any ideas?

    Please assist.
    Thursday, May 27, 2010 9:00 PM
  • click on account, contact and related look up values on this case record and see if any one of them is inactive..

    also go to sever and check event log and see what error you see there for the same..paste it over here and we could try to assist more for the same..

     

    Thursday, May 27, 2010 9:06 PM
    Answerer
  • I FOUND IT!

    There was a ForceSubmit() in the onSave event... oh my... that was a pain.  Thanks for all your help guys.

    • Marked as answer by 41714049 Thursday, May 27, 2010 9:08 PM
    Thursday, May 27, 2010 9:08 PM