locked
Windows 8 Authentication Issues - How to when login is name@domain.com??? RRS feed

  • Question

  • I've upgraded all of my systems to Windows 8 and discovered an issue with Windows Home Server 2011; hoping it's not an "issue" and that I'm just missing something?

    With Windows 8 most of the reason I moved to it quickly was because of the cloud aspects of it, login to a machine with your email address and poof, everything is there and setup as you want...Problem is, I can't authenticate (automatically as before using Windows 7 logins) to shares on the server?

    I know I can create local accounts and solve it that way, but then that means USING local accounts on Windows 8 which defeats the purpose for me upgrading to it?

    Anyone know any solutions to this?

    Tuesday, October 30, 2012 7:14 PM

Answers

  • This is easily addressed in two ways:

    Method 1: Set the Launchpad to run automatically at login. When logging in the first time, make sure to check the option to save both your username and password. You will become authorized once he Launchpad is loaded on the desktop.

    Method 2: Set Launchpad to never run. Then create a persistent Windows credential using Credential Manager in Control Panel (Charms->Search->Settings->"credential").  The reason you don't want Launchpad to run if you use this method is that it will overwrite your saved credentials when logged in, and the ones it uses have only session-level persistence.

    • Proposed as answer by Ken Warren Thursday, November 1, 2012 4:01 PM
    • Marked as answer by mcdonsco Thursday, November 1, 2012 4:37 PM
    Thursday, November 1, 2012 9:35 AM

All replies

  • I've upgraded all of my systems to Windows 8 and discovered an issue with Windows Home Server 2011; hoping it's not an "issue" and that I'm just missing something?

    With Windows 8 most of the reason I moved to it quickly was because of the cloud aspects of it, login to a machine with your email address and poof, everything is there and setup as you want...Problem is, I can't authenticate (automatically as before using Windows 7 logins) to shares on the server?

    I know I can create local accounts and solve it that way, but then that means USING local accounts on Windows 8 which defeats the purpose for me upgrading to it?

    Anyone know any solutions to this?

    I have the same problem with WHS v1, so I have had to use local accounts also.

    Colin

    Tuesday, October 30, 2012 9:40 PM
  • would be nice if you could just specify credentials, but the OS just says "no you don't have permission" without any prompt for authentication...was just thinking maybe I could setup an account I can use just for that on the server, but since it won't PROMPT for authentication, not really an option.
    Tuesday, October 30, 2012 10:08 PM
  • Damn it, thought I fixed it...but no, still no worky
    Wednesday, October 31, 2012 1:03 AM
  • Same case here. 

    I'll report back if a workaround is discovered.

    Wednesday, October 31, 2012 8:27 PM
  • This is easily addressed in two ways:

    Method 1: Set the Launchpad to run automatically at login. When logging in the first time, make sure to check the option to save both your username and password. You will become authorized once he Launchpad is loaded on the desktop.

    Method 2: Set Launchpad to never run. Then create a persistent Windows credential using Credential Manager in Control Panel (Charms->Search->Settings->"credential").  The reason you don't want Launchpad to run if you use this method is that it will overwrite your saved credentials when logged in, and the ones it uses have only session-level persistence.

    • Proposed as answer by Ken Warren Thursday, November 1, 2012 4:01 PM
    • Marked as answer by mcdonsco Thursday, November 1, 2012 4:37 PM
    Thursday, November 1, 2012 9:35 AM
  • Method 2 did the trick, thanks! (don't use Launchpad, I always remove it from the registry once installed as I don't like it coming up every time I boot up).

    Thanks again!

    Thursday, November 1, 2012 4:37 PM
  • Method 2 did the trick, thanks! (don't use Launchpad, I always remove it from the registry once installed as I don't like it coming up every time I boot up).

    Thanks again!

    Great!

    FYI, since Update Rollup 3, there is now an option to have the Launchpad come up minimized by default.  This resolved the issue for me of the Launchpad becoming annoying every time you log in...   :-)


    • Edited by Gary Voth Thursday, November 1, 2012 6:09 PM
    Thursday, November 1, 2012 6:09 PM
  • So by using Method 2, you can see the shared areas of WHS but how do you do backups?  run Dashboard?

    Dew


    Dewberry

    Tuesday, November 6, 2012 4:07 AM
  • Client backups run automatically, and are independent of the LaunchPad.

    I'm not on the WHS team, I just post a lot. :)

    Tuesday, November 6, 2012 4:51 AM
  • The Launchpad worked for me on a new Windows 8 PC, but this hasn't worked for me on an old PC that I upgraded. My assumption is that to fix the problem, you have to reinstall the Launchpad. Just wanted to put that out there for those who see this, have upgraded, and are unable to access their server shares. Reinstall Launchpad.

    Hope that helps some folks.

    Sunday, November 11, 2012 9:17 PM
  • I'm having a related issue. Not sure if the session persistence that Launchpad forces is the culprit.

    I have a scheduled task that copies some files from the Win8 client to a WHS11 share. I setup the Win8 machine with a Microsoft account, so I could be a complete Bing-er and learn to love WinPhone just like Steve Sinofsky intended. On the WHS11 machine, I have my more typical--and still used on my Win7 and Vista clients--"local" account. When I run the task from scheduled tasks directly, it works fine. When it wakes the PC up on schedule and runs, it does not authenticate against the server and the script fails.

    So I've told WHS Dashboard not to start on the Win8 machine, exited it, and added a persistent Windows credential. I'll have to wait until tomorrow morning to see whether it solves my problem.

    IF MS ever issues another rollup for WHS 11 (slim odds, I'm certain), a change to Dashboard to not delete a pre-exisiting persistent Windows credential would be REALLY HELPFUL. Dashboard and its SysTray icon have some utility; it if you can't use it without breaking other things, well, then it's worse than useless.


    • Edited by Dick Watson Saturday, November 24, 2012 6:04 PM
    Saturday, November 24, 2012 6:02 PM
  • Hi Dick.

    You can always set up a scheduled task to run with specific user credentials. If all else fails, it should be simple enough to create matching user accounts on both the server and the client so that your scheduled task can run successfully.

    BTW, it's not the Dashboard the manages the login credentials, but the Launchpad. I do agree with your suggestion for the WHS team: the Launchpad should first check to see if valid credentials are in place and create a new, session-level one only if none can be found. 

    • Edited by Gary Voth Monday, November 26, 2012 6:03 PM
    Monday, November 26, 2012 6:01 PM
  • Correct--meant Launchpad all places.

    I'd also thought of the local account approach--would have to share the Microsoft account's profile folder with that local user to make it work since that's where the fles are. I may yet do this approach in place of maiming, and not otherwise using, Launchpad. Not using Launchpa seems the most direct way to fix the Launchpad-created problem.

    And, yes, the persistent Windows credential did solve the scheduled task problem. Just can't start Launchpad or the persistent credential gets whacked.

    Tuesday, November 27, 2012 1:59 AM