none
HELP: Assembly Initialization Error: File not found. Something weird about the used reference RRS feed

  • Question

  • I moved one project from solution A to solution B using TFS move (with uncommitted changes). I got compile time errors since the references were not found. There were 2 references used. I removed and added them again and compile time errors were fixed. I ran a test case and I get file not found exception.

    As per the reference properties, the Path of used reference is C:_src\HIP\Out\Debug\CIP\Bin\amd64\DataPipe\MaterializedEntityManagerTest\Caradigm.Platform.Pipeline.MaterializedEntityManager.dll

    As per the error below, I think it is looking for this, file:///C:/_src/HIP/Out/Debug/CIP/Test/amd64/DataPipe/MaterializedEntityManager

    Note that it is looking for it in the folder structure -  CIP\Test instead of CIP\Bin. This file does not exist in the Test folder. ANyways I decided to copy to the test folder and give it a shot, the folder being...  C:_src\HIP\Out\Debug\CIP\test\amd64\DataPipe\MaterializedEntityManagerTest\Caradigm.Platform.Pipeline.MaterializedEntityManager.dll. Unexpectedly, I still get the same error.

    I'm now going crazy with this error. What am i missing???


    Test Name:  CdcEnableWithNoTableTest
    Test FullName:  Caradigm.Platform.Pipeline.MaterializedEntityManager.Test.DefiningQueryParserTests.CdcEnableWithNoTableTest
    Test Source:    c:\_src\HIP\prod\test\DataPipeline\MaterializationTest\EntityViewManagerTest\DefiningQueryParserTests.cs : line 15
    Test Outcome:   Failed
    Test Duration:  0:00:00
    
    Result Message: 
    Assembly Initialization method Caradigm.Platform.Pipeline.MaterializedEntityManager.Test.UnitTestInitializer.AssemblyInitialize threw exception. System.IO.FileNotFoundException: System.IO.FileNotFoundException: Could not load file or assembly 'Caradigm.Platform.Pipeline.MaterializedEntityManager, Version=3.0.0.0, Culture=neutral, PublicKeyToken=a03c60abe3a7c396' or one of its dependencies. The system cannot find the file specified.=== Pre-bind state information ===
    LOG: DisplayName = Caradigm.Platform.Pipeline.MaterializedEntityManager, Version=3.0.0.0, Culture=neutral, PublicKeyToken=a03c60abe3a7c396
     (Fully-specified)
    LOG: Appbase = file:///C:/_src/HIP/Out/Debug/CIP/Test/amd64/DataPipe/MaterializedEntityManager
    LOG: Initial PrivatePath = NULL
    Calling assembly : Caradigm.Platform.Pipeline.MaterializedEntityManager.Test, Version=3.0.0.0, Culture=neutral, PublicKeyToken=a03c60abe3a7c396.
    ===
    LOG: This bind starts in default load context.
    LOG: Using application configuration file: C:\PROGRAM FILES (X86)\MICROSOFT VISUAL STUDIO 12.0\COMMON7\IDE\COMMONEXTENSIONS\MICROSOFT\TESTWINDOW\vstest.executionengine.x86.exe.Config
    LOG: Using host configuration file: 
    LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config.
    LOG: Post-policy reference: Caradigm.Platform.Pipeline.MaterializedEntityManager, Version=3.0.0.0, Culture=neutral, PublicKeyToken=a03c60abe3a7c396
    LOG: Attempting download of new URL file:///C:/_src/HIP/Out/Debug/CIP/Test/amd64/DataPipe/MaterializedEntityManager/Caradigm.Platform.Pipeline.MaterializedEntityManager.DLL.
    LOG: Attempting download of new URL file:///C:/_src/HIP/Out/Debug/CIP/Test/amd64/DataPipe/MaterializedEntityManager/Caradigm.Platform.Pipeline.MaterializedEntityManager/Caradigm.Platform.Pipeline.MaterializedEntityManager.DLL.
    LOG: Attempting download of new URL file:///C:/_src/HIP/Out/Debug/CIP/Test/amd64/DataPipe/MaterializedEntityManager/Caradigm.Platform.Pipeline.MaterializedEntityManager.EXE.
    LOG: Attempting download of new URL file:///C:/_src/HIP/Out/Debug/CIP/Test/amd64/DataPipe/MaterializedEntityManager/Caradigm.Platform.Pipeline.MaterializedEntityManager/Caradigm.Platform.Pipeline.MaterializedEntityManager.EXE.
    . Aborting test execution.
    Result StackTrace:  at Caradigm.Platform.Pipeline.MaterializedEntityManager.Test.UnitTestInitializer.AssemblyInitialize(TestContext context)






    • Edited by CrazyPlanet Thursday, March 5, 2015 4:22 PM
    • Moved by Caillen Monday, March 9, 2015 9:59 AM
    Thursday, March 5, 2015 4:18 PM

Answers

  • Hi,

    Maybe TFS forum is the correct forum for your question, but I'm not sure. I move your question to [where is the forum for...] where the moderators may direct you to the right place.

    Thanks for your understanding.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, March 9, 2015 10:00 AM